Bug 468335 - [Patch] add support to tdbsam backend
[Patch] add support to tdbsam backend
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-samba (Show other bugs)
4.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 03:49 EDT by Olivier Fourdan
Modified: 2013-03-03 21:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 15:57:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport of fix from system-config-samba-1.2.40 (5.89 KB, patch)
2008-10-24 03:49 EDT, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2008-10-24 03:49:21 EDT
Created attachment 321376 [details]
Backport of fix from system-config-samba-1.2.40

+++ This bug was initially created as a clone of Bug #418561 +++

Description of problem:

Unable to add/delete/modify passwords for users who use the tdbsam backend.

Version-Release number of selected component (if applicable):
system-config-samba-1.2.21-1

How reproducible:
100%

Steps to Reproduce:
1. Install samba packages, 
2. Make sure passdb backend = tdbsam and smbpasswd is empty
2. Install system-config-samba
3. Create user in the GUI

  
Actual results:

No users are visible in the GUI but are added in the smbusers file

Expected results:

Users should be visible in the GUI

Additional info:

This bug is similar to Bug #418561 on RHEL5.

The patch attached backports the fix that went in system-config-samba-1.2.40, is use pdbedit instead of accessing the smbpasswd file.
Comment 2 RHEL Product and Program Management 2008-10-31 12:49:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 RHEL Product and Program Management 2010-10-22 15:03:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.