Bug 468367 - rsyslogd core dumps
rsyslogd core dumps
Status: CLOSED DUPLICATE of bug 384341
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
8
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Tomas Heinrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 08:25 EDT by JW
Modified: 2016-09-20 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 15:35:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-10-24 08:25:03 EDT
Description of problem:
rsyslogd, which is supposed to log all critical errors, warnings, etc, should be one of the more stable programs. Otherwise a hacker could start hacking password etc without being detected. Unfortunately rsyslogd is prone to the occasional core dump. How on earth could anyone write a program which manages to corrupt a simple double-linked list?

Version-Release number of selected component (if applicable):
rsyslog-1.19.6-3

How reproducible:
Very.

Steps to Reproduce:
1. run rsyslogd on a busy computer for month or so.
  
Actual results:
*** glibc detected *** rsyslogd: corrupted double-linked list: 0x08f19170 ***
======= Backtrace: =========
/lib/libc.so.6[0x1d258d]
/lib/libc.so.6(__libc_malloc+0x82)[0x1d3c32]
rsyslogd(MsgSetRawMsg+0x33)[0x8058c83]
rsyslogd[0x80508fc]
rsyslogd(printchopped+0x11c)[0x8050b0c]
rsyslogd[0x805225a]
rsyslogd(main+0xbae)[0x8053ace]
/lib/libc.so.6(__libc_start_main+0xe0)[0x17d390]
rsyslogd[0x804c511]
======= Memory map: ========
00110000-0012b000 r-xp 00000000 08:02 707559     /lib/ld-2.7.so
0012b000-0012c000 r-xp 0001a000 08:02 707559     /lib/ld-2.7.so
0012c000-0012d000 rwxp 0001b000 08:02 707559     /lib/ld-2.7.so
0012d000-0012e000 r-xp 0012d000 00:00 0          [vdso]
0012e000-00140000 r-xp 00000000 08:02 706461     /lib/libz.so.1.2.3
00140000-00141000 rwxp 00011000 08:02 706461     /lib/libz.so.1.2.3
00141000-00155000 r-xp 00000000 08:02 707593     /lib/libpthread-2.7.so
00155000-00156000 r-xp 00013000 08:02 707593     /lib/libpthread-2.7.so
00156000-00157000 rwxp 00014000 08:02 707593     /lib/libpthread-2.7.so
00157000-00159000 rwxp 00157000 00:00 0 
00159000-0015c000 r-xp 00000000 08:02 706457     /lib/libdl-2.7.so
0015c000-0015d000 r-xp 00002000 08:02 706457     /lib/libdl-2.7.so
0015d000-0015e000 rwxp 00003000 08:02 706457     /lib/libdl-2.7.so
0015e000-00165000 r-xp 00000000 08:02 706538     /lib/librt-2.7.so
00165000-00166000 r-xp 00006000 08:02 706538     /lib/librt-2.7.so
00166000-00167000 rwxp 00007000 08:02 706538     /lib/librt-2.7.so
00167000-002be000 r-xp 00000000 08:02 707546     /lib/libc-2.7.so
002be000-002c0000 r-xp 00156000 08:02 707546     /lib/libc-2.7.so
002c0000-002c1000 rwxp 00158000 08:02 707546     /lib/libc-2.7.so
002c1000-002c4000 rwxp 002c1000 00:00 0 
002c4000-002ce000 r-xp 00000000 08:02 706442     /lib/libnss_files-2.7.so
002ce000-002cf000 r-xp 00009000 08:02 706442     /lib/libnss_files-2.7.so
002cf000-002d0000 rwxp 0000a000 08:02 706442     /lib/libnss_files-2.7.so
002d0000-002db000 r-xp 00000000 08:02 707566     /lib/libgcc_s-4.1.2-20070925.so.1
002db000-002dc000 rwxp 0000a000 08:02 707566     /lib/libgcc_s-4.1.2-20070925.so:
08048000-08068000 r-xp 00000000 08:02 1781369    /sbin/rsyslogd
08068000-08069000 rw-p 00020000 08:02 1781369    /sbin/rsyslogd
08ed1000-08f34000 rw-p 08ed1000 00:00 0 
b7200000-b722b000 rw-p b7200000 00:00 0 
b722b000-b7300000 ---p b722b000 00:00 0 
b7400000-b743c000 rw-p b7400000 00:00 0 
b743c000-b7500000 ---p b743c000 00:00 0 
b75c2000-b75c3000 ---p b75c2000 00:00 0 
b75c3000-b7fc5000 rw-p b75c3000 00:00 0 
b7fe1000-b7fe2000 rw-p b7fe1000 00:00 0 
bfd5b000-bfd70000 rw-p bffea000 00:00 0          [stack]


Expected results:
<empty>

Additional info:
Because rsyslogd is so unreliable one has to run a script which periodically checks that rsyslogd is still running. No joke!
Comment 1 Tomas Heinrich 2008-10-24 19:04:37 EDT
Hi JW,

the version you're using is quite old, the current version should be rsyslog-2.0.2-3.fc8. The problem you're experiencing seems to be a variant of bug 384341, which has been fixed. Please try to update to the current version.
Comment 2 Tomas Heinrich 2008-11-10 15:35:41 EST

*** This bug has been marked as a duplicate of bug 384341 ***

Note You need to log in before you can comment on or make changes to this bug.