Bug 468370 - Document: Qpid cluster to support AIS redundant-ring
Document: Qpid cluster to support AIS redundant-ring
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference (Show other bugs)
beta
All Linux
medium Severity medium
: 1.1
: ---
Assigned To: Lana Brindley
Jeff Needle
: Documentation
Depends On: 468173
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 08:41 EDT by Alan Conway
Modified: 2013-10-23 19:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 23:09:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-10-24 08:41:24 EDT
This needs to go into the FAQ around cluster/ or in the cluster config section. 
See https://bugzilla.redhat.com/show_bug.cgi?id=468173 for details
Comment 1 Lana Brindley 2008-10-29 18:04:36 EDT
Due to be written Mon 3 Nov and will be available for technical review ~ 5 Nov

LKB
Comment 2 Lana Brindley 2008-11-03 22:01:29 EST
Hi Alan,

Sorry to leave this so late, but I've just read through the bug you linked to and I'm still clueless as to what this is about. I'm going to go ahead and release this book for tech review without this bug for now, BUT if you can get some info (or a draft version of the type of thing you're looking for here) to me in the next couple of days (say by the end of this week), then we still might be able to sneak it in.

Thanks,
LKB
Comment 3 Lana Brindley 2008-11-04 17:30:50 EST
From Mick Goulish:

Redundant-ring mode in OpenAIS is a redundancy mechanism at the level of
the network interface.  Here are instructions for setting it up.



1. Find a machine with two network interfaces as reported by
"/sbin/ifconfig
-a".
   One such machine is MRG7.  ( It has eth0 and eth1. )


2. Also, the machine should be RHEL 5.X.  Ideally 5.2, since the current
customer for this functionality requires 5.2.   This functionality is not
available for RHEL 4.*.


3. Make sure openais and openais-devel packages are installed on the machine.


4. As root: "service openais stop"


5. Use something very much like this example as your /etc/ais/openais.conf file:


------------------ start openais.conf -----------------
# Please read the openais.conf.5 manual page

totem {
        version: 2
        secauth: off
        threads: 0
        rrp_mode: passive

        # ------------  eth1 -----------------
        interface {
                ringnumber: 0
                bindnetaddr: 20.0.10.0
                mcastaddr: 226.94.1.1
                mcastport: 5405
        }

        # ------------  eth0 -----------------
        interface {
                ringnumber: 1
                bindnetaddr: 10.16.40.0
                mcastaddr: 226.94.1.1
                mcastport: 5405
        }
}

logging {
        debug: off
        timestamp: on

        # added these lines:
        to_stderr: yes
        to_syslog: yes
        logger {
                 ident: CPG
                 debug: off
               }
}

amf {
        mode: disabled
}
------------------- end openais.conf ------------------


6. Use the above example for the file /etc/ais/openais.conf
   Except edit it to get the correct addresses in the two bindnetaddr fields.
   Here's how to get the correct address:

       6.1  For each active interface, the command  "/sbin/ifconfig -a"  
            will report an address and a mask.  

       6.2  Bitwise-AND the two together to find the correct value for 
            the bindnetaddr field.


7. After editing the /etc/ais/openais.conf file, become root and 
   do this:  "service openais start".


7. Run any (or all) cluster tests -- "make check" or standalone.  They 
   should behave as usual.  You are now running the cluster against a 
   two-ring openais set-up.
Comment 4 Lana Brindley 2008-11-11 01:47:26 EST
(In reply to comment #3)
> From Mick Goulish:
<snip>
> 
> 
> 6. Use the above example for the file /etc/ais/openais.conf
>    Except edit it to get the correct addresses in the two bindnetaddr fields.
>    Here's how to get the correct address:
> 
>        6.1  For each active interface, the command  "/sbin/ifconfig -a"  
>             will report an address and a mask.  
> 
>        6.2  Bitwise-AND the two together to find the correct value for 
>             the bindnetaddr field.


How can I do this from the shell prompt?
$((192.168.0.1 & 255.255.255.0)) doesn't seem to work for me :(

L
Comment 5 mick 2008-11-11 14:37:50 EST
Here's a cool way that you can do a binary AND of two such addresses -- one component at a time.   ( Thanks mattf! )

For example, to do 148 & 250, do this:

   python -c "print 148&250"


( It's not good to use as example where the mask is all 255s and 0s, since 255 & X == X    and    0 & X == 0 )
Comment 6 Lana Brindley 2008-11-13 01:25:57 EST
Thanks Mick!

This information is now in, and will be available for review shortly.

LKB
Comment 7 Lana Brindley 2008-11-14 04:15:51 EST
Updated. Now available for further review.

LKB

Note You need to log in before you can comment on or make changes to this bug.