Bug 468413 - Doesn't start (bad value of /apps/ekiga/general/gconf_test_age or crash)
Doesn't start (bad value of /apps/ekiga/general/gconf_test_age or crash)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 12:39 EDT by Matěj Cepl
Modified: 2008-11-14 06:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 06:14:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of ekiga -d 5 -u 4 2>&1 (22.78 KB, text/plain)
2008-10-24 12:39 EDT, Matěj Cepl
no flags Details
output of LANG=en_IE.utf8 ekiga -d 5 -u 4 2>&1 (8.82 KB, text/plain)
2008-10-24 12:41 EDT, Matěj Cepl
no flags Details
output of gconftool-2 -R /apps/ekiga >ekiga-gconf.txt (5.72 KB, text/plain)
2008-10-24 12:42 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-10-24 12:39:53 EDT
Created attachment 321430 [details]
output of ekiga -d 5 -u 4 2>&1

Description of problem:
When starting ekiga with cs_CZ.utf8 locale I get on start error message:

Ekiga obdržela neplatnou hodnotu konfiguračního klíče "/apps/ekiga/general/gconf_test_age".

To pravděpodobně znamená, že vaše konfigurační schémata nebyla správně nainstalována, nebo nejsou správně nastavena oprávnění.

Přečtěte si prosím FAQ (http://www.ekiga.org/), část webu GConf o řešení problémů (http://www.gnome.org/projects/gconf/), nebo archivy konferencí (http://mail.gnome.org) pro získání více informací o tomto problému.

which means roughly:

Ekiga received invalid value of the configuration key "/apps/ekiga/general/gconf_test_age".

That probably means, that your configuration schema was not correctly installed, or that the authorization bits are set correctly.

Please read FAQ ...

and when running

ekiga -d 5 -u 4 I get ekiga-first.log

When trying to run 

LANG=en_IE.utf8 ekiga -d 5 -u 4

(to make English error message), ekiga crashes (see attached log ekiga-second.txt).

Version-Release number of selected component (if applicable):
ekiga-3.0.1-2.fc10.i386

How reproducible:
100% (5 of 5)

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
crash or invalid start

Expected results:
ekiga running
Comment 1 Matěj Cepl 2008-10-24 12:41:33 EDT
Created attachment 321432 [details]
output of LANG=en_IE.utf8 ekiga -d 5 -u 4 2>&1

and the backtrace (which is not in log) is:

(ekiga:15305): GConf-CRITICAL **: gconf_value_get_int: assertion `value != NULL' failed

(ekiga:15305): GConf-CRITICAL **: gconf_value_get_string: assertion `value != NULL' failed
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
*** glibc detected *** ekiga: free(): invalid pointer: 0x00404fc0 ***
======= Backtrace: =========
/lib/libc.so.6[0xe4b454]
/lib/libc.so.6(cfree+0x96)[0xe4d406]
/lib/libglib-2.0.so.0(g_free+0x36)[0x7c1716]
/usr/lib/gtk-2.0/modules/libgnomebreakpad.so[0x437667b]
/usr/lib/gtk-2.0/modules/libgnomebreakpad.so[0x43766e5]
[0x110400]
[0x110416]
/lib/libc.so.6(gsignal+0x50)[0xe074c0]
/lib/libc.so.6(abort+0x188)[0xe08e88]
/usr/lib/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x158)[0xda6c18]
/usr/lib/libstdc++.so.6[0xda4b05]
/usr/lib/libstdc++.so.6[0xda4b42]
/usr/lib/libstdc++.so.6[0xda4c7a]
/usr/lib/libstdc++.so.6(_ZSt19__throw_logic_errorPKc+0x7f)[0xd3a1df]
/usr/lib/libstdc++.so.6[0xd8016a]
/usr/lib/libstdc++.so.6(_ZNSsC1EPKcRKSaIcE+0x46)[0xd80266]
ekiga(_ZN4Opal10ConfBridge19on_property_changedESsP12_GmConfEntry+0x249)[0x810dbc9]
ekiga(_ZN4sigc8internal10slot_call2INS_18bound_mem_functor2IvN4Opal10ConfBridgeESsP12_GmConfEntryEEvSsS6_E7call_itEPNS0_8slot_repERKSsRKS6_+0x6b)[0x811070b]
ekiga[0x8152f17]
ekiga[0x8128eff]
/usr/lib/libgconf-2.so.4[0x5dc4744]
/usr/lib/libgconf-2.so.4(gconf_listeners_notify+0x14e)[0x5db390e]
/usr/lib/libgconf-2.so.4[0x5dc1694]
/usr/lib/libgconf-2.so.4(gconf_client_notify+0xb7)[0x5dc4667]
ekiga(gm_conf_notifier_trigger+0x2b)[0x81290db]
ekiga(_ZN5Ekiga10ConfBridge4loadERSt6vectorISsSaISsEE+0x4d)[0x8152e2d]
ekiga(_ZN4Opal10ConfBridgeC1ERN5Ekiga7ServiceE+0xbde)[0x810c74e]
ekiga(_Z9opal_initRN5Ekiga11ServiceCoreEPiPPPc+0x328)[0x8110b88]
ekiga(_Z11engine_initiPPcPN5Ekiga7RuntimeERPNS1_11ServiceCoreE+0x4c4)[0x8136ed4]
ekiga(_ZN12GnomeMeeting10InitEngineEv+0x8c)[0x80e709c]
ekiga(main+0x31d)[0x80d6d3d]
/lib/libc.so.6(__libc_start_main+0xe5)[0xdf26d5]
ekiga[0x80b6f91]
======= Memory map: ========
00110000-00111000 r-xp 00110000 00:00 0          [vdso]
00111000-00142000 r-xp 00000000 fd:00 2093680    /usr/lib/libebook-1.2.so.9.3.0
00142000-00146000 rw-p 00031000 fd:00 2093680    /usr/lib/libebook-1.2.so.9.3.0
00146000-0016d000 r-xp 00000000 fd:00 2093702    /usr/lib/libedataserver-1.2.so.11.0.0
0016d000-0016e000 rw-p 00027000 fd:00 2093702    /usr/lib/libedataserver-1.2.so.11.0.0
0016e000-00182000 r-xp 00000000 fd:00 5008864    /usr/lib/libgnome-2.so.0.2400.1
00182000-00183000 rw-p 00013000 fd:00 5008864    /usr/lib/libgnome-2.so.0.2400.1
00183000-00215000 r-xp 00000000 fd:00 5004269    /usr/lib/libgdk-x11-2.0.so.0.1400.4
00215000-00218000 rw-p 00092000 fd:00 5004269    /usr/lib/libgdk-x11-2.0.so.0.1400.4
00218000-00233000 r-xp 00000000 fd:00 5009058    /usr/lib/libatk-1.0.so.0.2409.1
00233000-00235000 rw-p 0001a000 fd:00 5009058    /usr/lib/libatk-1.0.so.0.2409.1
00235000-0025e000 r-xp 00000000 fd:00 5006578    /usr/lib/libpangoft2-1.0.so.0.2201.0
0025e000-0025f000 rw-p 00029000 fd:00 5006578    /usr/lib/libpangoft2-1.0.so.0.2201.0
0025f000-00262000 r-xp 00000000 fd:00 4217521    /lib/libplds4.so
00262000-00263000 rw-p 00002000 fd:00 4217521    /lib/libplds4.so
00263000-00266000 r-xp 00000000 fd:00 4217486    /lib/libuuid.so.1.2
00266000-00267000 rw-p 00003000 fd:00 4217486    /lib/libuuid.so.1.2
00267000-002ae000 r-xp 00000000 fd:00 4215003    /lib/libssl.so.0.9.8g
002ae000-002b2000 rw-p 00046000 fd:00 4215003    /lib/libssl.so.0.9.8g
002b2000-002b3000 r-xp 00000000 fd:00 5005755    /usr/lib/libxcb-xlib.so.0.0.0
002b3000-002b4000 rw-p 00000000 fd:00 5005755    /usr/lib/libxcb-xlib.so.0.0.0
002b4000-002d1000 r-xp 00000000 fd:00 5017328    /usr/lib/libdbus-glib-1.so.2.1.0
002d1000-002d2000 rw-p 0001d000 fd:00 5017328    /usr/lib/libdbus-glib-1.so.2.1.0
002d2000-00343000 r-xp 00000000 fd:00 4217485    /lib/libgio-2.0.so.0.1800.2
00343000-00345000 rw-p 00071000 fd:00 4217485    /lib/libgio-2.0.so.0.1800.2
00345000-00361000 r-xp 00000000 fd:00 5005773    /usr/lib/libgdk_pixbuf-2.0.so.0.1400.4
00361000-00362000 rw-p 0001b000 fd:00 5005773    /usr/lib/libgdk_pixbuf-2.0.so.0.1400.4
00362000-0036c000 r-xp 00000000 fd:00 5007743    /usr/lib/libpangocairo-1.0.so.0.2201.0
0036c000-0036d000 rw-p 00009000 fd:00 5007743    /usr/lib/libpangocairo-1.0.so.0.2201.0
0036d000-003b1000 r-xp 00000000 fd:00 5005100    /usr/lib/libpango-1.0.so.0.2201.0
003b1000-003b3000 rw-p 00044000 fd:00 5005100    /usr/lib/libpango-1.0.so.0.2201.0
003b3000-003c0000 r-xp 00000000 fd:00 4214874    /lib/libgcc_s-4.3.2-20081008.so.1
003c0000-003c1000 rw-p 0000c000 fd:00 4214874    /lib/libgcc_s-4.3.2-20081008.so.1
003c1000-003c5000 r-xp 00000000 fd:00 4215146    /lib/libplc4.so
003c5000-003c6000 rw-p 00003000 fd:00 4215146    /lib/libplc4.so
[matej@viklef ~]$
Comment 2 Matěj Cepl 2008-10-24 12:42:36 EDT
Created attachment 321433 [details]
output of gconftool-2 -R /apps/ekiga >ekiga-gconf.txt
Comment 3 Peter Robinson 2008-10-25 04:08:25 EDT
Reported upstream at b.g.o as bug # 557847
Comment 4 Matthias Clasen 2008-10-27 11:31:06 EDT
I can't reproduce this.
Comment 5 Peter Robinson 2008-10-27 11:44:28 EDT
Nor can I. I was wondering whether it might have been due to a missing string in a translation or something similar hence the != NULL string error (but I don't know enough of how the translations work to be sure).
Comment 6 Tom "spot" Callaway 2008-10-27 14:47:51 EDT
I can't reproduce this one either. Lifting F10DesktopBlocker.
Comment 7 Matěj Cepl 2008-10-28 17:52:43 EDT
(In reply to comment #5)
> Nor can I. I was wondering whether it might have been due to a missing string
> in a translation or something similar hence the != NULL string error (but I
> don't know enough of how the translations work to be sure).

Note that I cannot run LANG=C ekiga, because it ends in crash.
Comment 8 Peter Robinson 2008-11-14 06:14:57 EST
Closing as it was an issue with users gconf. See b.g.o bug 557847 filed upstream for further details.

Note You need to log in before you can comment on or make changes to this bug.