Bug 468425 - Yum Cannot retrieve repository metadata In Fedora 10 beta release...
Yum Cannot retrieve repository metadata In Fedora 10 beta release...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 13:54 EDT by ext4
Modified: 2014-01-21 18:06 EST (History)
7 users (show)

See Also:
Fixed In Version: 9 8 7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 07:44:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ext4 2008-10-24 13:54:32 EDT
Description of problem: yum doesnt work right out of the box.after f10 beta installation


Version-Release number of selected component (if applicable):
fedora core 10 beta 9.91

How reproducible:always


Steps to Reproduce:
1.open terminal
2.su -
3.error is produce after i've entered the "yum update" command.
  
Actual results:
[root@Sypher ~]# yum update
Loaded plugins: refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

Expected results:
starting the actual update process without errors
from any selected repository after f10 beta install

Additional info:yum doesnt work right after i finish installing fedora 10 beta release.
Comment 1 seth vidal 2008-10-24 14:16:24 EDT
Can you access the network in general at this time?
Comment 2 Tim Lauridsen 2008-11-01 06:41:17 EDT
what does 'yum repolist' says

the beta should point to 'rawhide' not 'fedora' the is no fedora/9.92/ repos :)
Comment 3 seth vidal 2008-11-04 10:44:53 EST
needinfo soon, if possible
Comment 4 Bug Zapper 2008-11-25 23:12:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 John J. McDonough 2008-11-28 15:37:48 EST
Reproduceable on F10 after a fresh install:

[root@Conor ~]# yum check-update
Loaded plugins: refresh-packagekit
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f10&arch=i386 error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: updates. Please verify its path and try again

I had seen this on a system upgraded from preview, so I did a clean reinstall same thing.  Someone else is also reporting it on IRC.
Comment 6 John J. McDonough 2008-11-29 11:37:43 EST
This problem seems to have been resolved.  Was it a repository issue?
Comment 7 Richard Zuber 2008-11-29 18:22:21 EST
Not resolved for me. Got this after F9 to F10 upgrade. 

[root@risko-laptop ~]# yum check-update
Loaded plugins: refresh-packagekit
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10&arch=i386 error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

But it seems like some problem on the other side because 
wget http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10&arch=i386

Fails 

And wget from anywhere else works fine.
The link http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10&arch=i386
can be opened in web browser fine.


[root@risko-laptop ~]# wget http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10&arch=i386
[1] 4055
[root@risko-laptop ~]# --2008-11-29 23:16:59--  http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10
Resolving mirrors.fedoraproject.org... failed: Name or service not known.
wget: unable to resolve host address `mirrors.fedoraproject.org'

[1]+  Exit 1                  wget http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10
[root@risko-laptop ~]# wget http://ftp.heanet.ie/pub/gentoo/releases/x86/current/installcd/install-x86-minimal-2008.0.iso
--2008-11-29 23:18:07--  http://ftp.heanet.ie/pub/gentoo/releases/x86/current/installcd/install-x86-minimal-2008.0.iso
Resolving ftp.heanet.ie... 193.1.193.64, 2001:770:18:aa40::c101:c140
Connecting to ftp.heanet.ie|193.1.193.64|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 83396608 (80M) [application/octet-stream]
Saving to: `install-x86-minimal-2008.0.iso'

 1% [>                                                                                                                                       ] 946,488      220K/s  eta 6m 7s   ^C
[root@risko-laptop ~]# 


Maybe related to this 

https://bugzilla.redhat.com/show_bug.cgi?id=459756
Comment 8 Richard Zuber 2008-12-01 03:51:24 EST
Just arrive at work with the F10 laptop and on the corp network ,,, YUM works....seems like Eircom or someone else is messing up with the DNS.

So resolved for me....

Note You need to log in before you can comment on or make changes to this bug.