Bug 468448 - Intel driver not catching fn-button events on x61 in 5.3 beta candidate
Intel driver not catching fn-button events on x61 in 5.3 beta candidate
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.3
All Linux
high Severity high
: rc
: 5.4
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
: 470455 (view as bug list)
Depends On:
Blocks: 447297 483784
  Show dependency treegraph
 
Reported: 2008-10-24 15:12 EDT by Siddharth Nagar
Modified: 2009-09-02 07:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Lenovo Thinkpad notebooks have a "Fn" key that can be combined with the numbered function keys to access a variety of features, typically including volume, screen brightness, sleep, and switching to an external monitor. Previously, these key combinations would not produce the desired outcomes on X61 Thinkpads. Although some of these functions were enabled by changes in other software components, no support existed within the graphics drivers for the key combinations that would brighten and dim the display. Support for these features is now present in the driver, allowing X61 users to take advantage of this feature on their notebooks.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:55:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Siddharth Nagar 2008-10-24 15:12:10 EDT
Description of problem:
The X11 intel driver on a X61 (7674Y23) with the 5.3 beta candidate does not catch fn-key events such as brightness or the fn+f7 display switch.

The driver version is xorg-x11-drv-i810-1.6.5-9.18.el5
Comment 1 Daniel Riek 2008-10-24 15:44:38 EDT
The events are actually visible when running acipd -d
Comment 2 Adam Jackson 2008-11-10 10:51:24 EST
riek: can you paste what acpid -d prints when you hit those buttons?  There was a bug here at one point where we caught the wrong keycodes, but I thought that was fixed by now.

Also, do you have thinkpad-acpi loaded?
Comment 3 Siddharth Nagar 2008-11-10 15:44:48 EST
The output from 'acpid -d' is attached below. I pressed all the keys from F1 to F12. The only key combination that appears to work is the Fn+F4 (suspend). The brightness controls seem to register but the screen doesn't change the level of brightness.

The thinkpad-acpi driver is loaded (modprobe reports it in the list. Let me know if there is a more accurate way to determine what is loaded).

------ BEGIN ---------

n Nov 10 15:25:47 2008] starting up
[Mon Nov 10 15:25:47 2008] DBG: parsing conf file /etc/acpi/events/video.conf
[Mon Nov 10 15:25:47 2008] DBG: skipping incomplete file /etc/acpi/events/video.conf
[Mon Nov 10 15:25:47 2008] DBG: parsing conf file /etc/acpi/events/power.conf
[Mon Nov 10 15:25:47 2008] 1 rule loaded
[Mon Nov 10 15:25:50 2008] client connected from 3226[68:68]
[Mon Nov 10 15:25:50 2008] 1 client rule loaded
[Mon Nov 10 15:26:24 2008] received event "button/sleep SLPB 00000080 00000001"
[Mon Nov 10 15:26:24 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:26:24 2008] notifying client 3226[68:68]
[Mon Nov 10 15:26:24 2008] DBG: 1 total rule matched
[Mon Nov 10 15:26:24 2008] completed event "button/sleep SLPB 00000080 00000001"
[Mon Nov 10 15:26:27 2008] client connected from 3450[0:0]
[Mon Nov 10 15:26:27 2008] 1 client rule loaded
[Mon Nov 10 15:26:43 2008] received event "processor CPU0 00000081 00000000"
[Mon Nov 10 15:26:43 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:26:43 2008] notifying client 3226[68:68]
[Mon Nov 10 15:26:43 2008] DBG: rule from 3450[0:0] matched
[Mon Nov 10 15:26:43 2008] notifying client 3450[0:0]
[Mon Nov 10 15:26:43 2008] client has disconnected
[Mon Nov 10 15:26:43 2008] DBG: 2 total rules matched
[Mon Nov 10 15:26:43 2008] completed event "processor CPU0 00000081 00000000"
[Mon Nov 10 15:26:43 2008] received event "processor CPU1 00000081 00000000"
[Mon Nov 10 15:26:43 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:26:43 2008] notifying client 3226[68:68]
[Mon Nov 10 15:26:43 2008] DBG: 1 total rule matched
[Mon Nov 10 15:26:43 2008] completed event "processor CPU1 00000081 00000000"
[Mon Nov 10 15:26:45 2008] received event "battery BAT0 00000080 00000001"
[Mon Nov 10 15:26:45 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:26:45 2008] notifying client 3226[68:68]
[Mon Nov 10 15:26:45 2008] DBG: 1 total rule matched
[Mon Nov 10 15:26:45 2008] completed event "battery BAT0 00000080 00000001"
[Mon Nov 10 15:26:45 2008] received event "battery BAT0 00000080 00000001"
[Mon Nov 10 15:26:45 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:26:45 2008] notifying client 3226[68:68]
[Mon Nov 10 15:26:45 2008] DBG: 1 total rule matched
[Mon Nov 10 15:26:45 2008] completed event "battery BAT0 00000080 00000001"
[Mon Nov 10 15:26:45 2008] client connected from 3450[0:0]
[Mon Nov 10 15:26:45 2008] 1 client rule loaded
[Mon Nov 10 15:27:20 2008] received event "video LCD0 00000087 00000000"
[Mon Nov 10 15:27:20 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:27:20 2008] notifying client 3226[68:68]
[Mon Nov 10 15:27:20 2008] DBG: rule from 3450[0:0] matched
[Mon Nov 10 15:27:20 2008] notifying client 3450[0:0]
[Mon Nov 10 15:27:20 2008] DBG: 2 total rules matched
[Mon Nov 10 15:27:20 2008] completed event "video LCD0 00000087 00000000"
[Mon Nov 10 15:27:22 2008] received event "video LCD0 00000087 00000000"
[Mon Nov 10 15:27:22 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:27:22 2008] notifying client 3226[68:68]
[Mon Nov 10 15:27:22 2008] DBG: rule from 3450[0:0] matched
[Mon Nov 10 15:27:22 2008] notifying client 3450[0:0]
[Mon Nov 10 15:27:22 2008] DBG: 2 total rules matched
[Mon Nov 10 15:27:22 2008] completed event "video LCD0 00000087 00000000"
[Mon Nov 10 15:27:23 2008] received event "video LCD0 00000086 00000000"
[Mon Nov 10 15:27:23 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:27:23 2008] notifying client 3226[68:68]
[Mon Nov 10 15:27:23 2008] DBG: rule from 3450[0:0] matched
[Mon Nov 10 15:27:23 2008] notifying client 3450[0:0]
[Mon Nov 10 15:27:23 2008] DBG: 2 total rules matched
[Mon Nov 10 15:27:23 2008] completed event "video LCD0 00000086 00000000"
[Mon Nov 10 15:27:24 2008] received event "video LCD0 00000086 00000000"
[Mon Nov 10 15:27:24 2008] DBG: rule from 3226[68:68] matched
[Mon Nov 10 15:27:24 2008] notifying client 3226[68:68]
[Mon Nov 10 15:27:24 2008] DBG: rule from 3450[0:0] matched
[Mon Nov 10 15:27:24 2008] notifying client 3450[0:0]
[Mon Nov 10 15:27:24 2008] DBG: 2 total rules matched
[Mon Nov 10 15:27:24 2008] completed event "video LCD0 00000086 00000000"
[Mon Nov 10 15:27:52 2008] exiting

------ END ---------
Comment 4 Adam Jackson 2008-11-12 14:56:21 EST
Ack, very strange.  Will try to repro locally.
Comment 8 Adam Jackson 2008-11-18 13:47:11 EST
Okay, this is straightforward.  The code to handle ACPI brightness keys is just not wired up.  Due to unfortunate history, that code translates to APM events, and APM doesn't have backlight controls, so we lose.  They are _also_ emitted as normal keyboard events, but we don't do the right thing with them presumably due to keymap loss.

Fixing this is rather invasive and not likely to make 5.3.  Moving to 5.4 radar and resetting flags to match.
Comment 9 Zack Cerza 2008-11-18 13:54:35 EST
Fair enough. Thanks, ajax!
Comment 10 RHEL Product and Program Management 2008-11-18 14:00:40 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 11 Vladimir Benes 2008-11-18 14:25:45 EST
have you tried new kernel 124? I have solved this issue on freshly installed X61 by moving thinkpad_acpi from kernel/drivers/misc to kernel/drivers/acpi (modules there are loaded automatically) then depmod to regenerate db and reboot. After that brightness keys were mapped correctly
Comment 12 Siddharth Nagar 2008-11-24 15:34:48 EST
The brightness keys do work for me now after upgrading to kernel 124. The sound volume/mute buttons still don't work. I'm not sure if this is related to this bug or if I should close this bug and open a new one. Please advise.
Comment 14 Larry Troan 2008-12-07 14:13:53 EST
On Fri, 2008-12-05 at 12:26 -0500, Jonathan Blandford wrote:
> While it would be nice to get them working, it's less critical for a laptop
> than eg. external monitors are.  We can take another look for 5.4, but we are 
> not going to fix them for 5.3 at this point.
Comment 16 Ben Levenson 2008-12-08 17:47:37 EST
*** Bug 470455 has been marked as a duplicate of this bug. ***
Comment 17 RHEL Product and Program Management 2009-03-11 11:39:42 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 19 Adam Jackson 2009-06-15 17:18:54 EDT
Please test with the current 5.4 snapshot, this is likely fixed with newer hal-info.
Comment 20 Adam Jackson 2009-06-24 17:17:13 EDT
MODIFIED, this should be fixed as of 5.4.
Comment 23 Chris Ward 2009-07-03 14:11:42 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 24 Chris Ward 2009-07-10 15:06:07 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 1 Released! ~~

RHEL 5.4 Snapshot 1 has been released on partners.redhat.com. If you have already reported your test results, you can safely ignore this request. Otherwise, please notice that there should be a fix available now that addresses this particular request. Please test and report back your results here, at your earliest convenience. The RHEL 5.4 exception freeze is quickly approaching.

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other appropriate customer representative.
Comment 27 Ruediger Landmann 2009-08-22 05:09:17 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Lenovo Thinkpad notebooks have a "Fn" key that can be combined with the numbered function keys to access a variety of features, typically including volume, screen brightness, sleep, and switching to an external monitor. Previously, these key combinations would not produce the desired outcomes on X61 Thinkpads. Although some of these functions were enabled by changes in other software components, no support existed within the graphics drivers for the key combinations that would brighten and dim the display. Support for these features is now present in the driver, allowing X61 users to take advantage of this feature on their notebooks.
Comment 28 errata-xmlrpc 2009-09-02 07:55:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1391.html

Note You need to log in before you can comment on or make changes to this bug.