Bug 468472 - gnome-do errors on start up
gnome-do errors on start up
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-do (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 18:17 EDT by Steve Milner
Modified: 2008-12-02 12:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 12:23:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Milner 2008-10-24 18:17:01 EDT
Description of problem:
gnome-do throws errors when attempting to be executed.

Version-Release number of selected component (if applicable):
gnome-do-0.6.1.0-1.fc10.x86_64

How reproducible:
Every time for me :-)

Steps to Reproduce:
1. yum install gnome-do
2. execute gnome-do from a terminal
  
Actual results:
An unhanded exception gets thrown to the console.

Expected results:
The application starts up.

Additional info:
[steve@powerplant ~]$ cat /etc/fedora-release 
Fedora release 9.92 (Rawhide)
[steve@powerplant ~]$ date -I
2008-10-24
[steve@powerplant ~]$ rpm -q gnome-do
gnome-do-0.6.1.0-1.fc10.x86_64
[steve@powerplant ~]$ gnome-do
Add-in could not be loaded: The required addin 'Do.Core,1.0' is not installed.
Mono.Addins.MissingDependencyException: The required addin 'Do.Core,1.0' is not installed.
  at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000] 
  at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000] 

Unhandled Exception: System.InvalidOperationException: Extension node not found in path: /Do/ItemSource
  at Mono.Addins.ExtensionContext.AddExtensionNodeHandler (System.String path, Mono.Addins.ExtensionNodeEventHandler handler) [0x00000] 
  at Mono.Addins.AddinManager.AddExtensionNodeHandler (System.String path, Mono.Addins.ExtensionNodeEventHandler handler) [0x00000] 
  at Do.Core.PluginManager.Initialize () [0x00000] 
  at Do.Do.Main (System.String[] args) [0x00000] 
[steve@powerplant ~]$
Comment 1 Bug Zapper 2008-11-25 23:13:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Sindre Pedersen Bjørdal 2008-12-02 07:28:25 EST
I'm unable to reproduce this, is this still happening?
Comment 3 Steve Milner 2008-12-02 11:50:54 EST
This no longer seems to be the case. It seems to work for me now in F10 proper.

Note You need to log in before you can comment on or make changes to this bug.