Bug 468488 - evolution segfaults when changing folder subscriptions on IMAP
evolution segfaults when changing folder subscriptions on IMAP
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 00:45 EDT by Ian Weller
Modified: 2008-10-31 17:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 17:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
segmentation fault in evolution after clicking checkboxes in subscriptions manager (8.68 KB, text/plain)
2008-10-25 00:45 EDT, Ian Weller
no flags Details

  None (edit)
Description Ian Weller 2008-10-25 00:45:07 EDT
Created attachment 321487 [details]
segmentation fault in evolution after clicking checkboxes in subscriptions manager

Description of problem:
Evolution segfaults when changing folder subscriptions on IMAP in a certain unforseeable pattern.

Version-Release number of selected component (if applicable):
evolution-2.24.1-2.fc10.i386

How reproducible:
Nearly every time.

Steps to Reproduce:
1. Folders -> Subscriptions
2. Click random checkboxes
  
Actual results:
Segfault. Output attached.

Expected results:
It should work.
Comment 1 Milan Crha 2008-10-31 16:53:06 EDT
Could you install debug info packages for evolution and evolution-data-server, run evolution under gdb (command: "gdb evolution --ex r") and when it crashes with the invalid pointer do "thread apply all bt" and paste here the result, with lines where the context where it stopped will be shown, please?

I tried to reproduce, but it seems to work for me, thus asking you for this.
Thanks in advance.
Comment 2 Ian Weller 2008-10-31 17:24:32 EDT
Sorry, I can't reproduce either. Closing.

Note You need to log in before you can comment on or make changes to this bug.