Bug 468504 - preupgrade fail
preupgrade fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 07:39 EDT by Alexey Kuznetsov
Modified: 2008-11-04 10:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 10:56:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error (79.28 KB, image/jpeg)
2008-10-25 07:39 EDT, Alexey Kuznetsov
no flags Details

  None (edit)
Description Alexey Kuznetsov 2008-10-25 07:39:45 EDT
Created attachment 321500 [details]
error

i run preupgrate from f9 to f10rawhide and got attached error.

problem happens because i use swap in file located in my file system.
Comment 1 Jeremy Katz 2008-10-26 12:45:21 EDT
What does your /etc/ffstab look like?
Comment 2 Alexey Kuznetsov 2008-10-26 12:47:48 EDT
ah, sorry here is:

[axet@axet-laptop ~]$ cat /etc/fstab 
UUID=17050de4-c9bc-4938-9615-090c227ce8fb /                       ext3    defaults        1 1
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/var/swap		swap			swap
[axet@axet-laptop ~]$ ll /var/swap 
-rw-r--r-- 1 root root 2147483648 2008-10-16 01:27 /var/swap
[axet@axet-laptop ~]$
Comment 3 Jeremy Katz 2008-10-26 13:06:28 EDT
Can you add 'updates=http://katzj.fedorapeople.org/updates-468504.cgz' to the kernel command line for preupgrade and see if it fixes things for you?


diff --git a/fsset.py b/fsset.py
index a1fdaef..f55e3cb 100644
--- a/fsset.py
+++ b/fsset.py
@@ -1974,7 +1974,7 @@ MAILADDR root
                         else:
                             continue
                     else:
-                        if anaconda.id.getUpgrade() and not (entry.getLabel() or entry.getUuid()):
+                        if anaconda.id.getUpgrade() and not (entry.getLabel() or entry.getUuid()) and entry.device.getDevice().startswith("/dev"):
                             errStr = _("Error mounting device %s as %s: "
                                        "%s\n\n"
                                        "Devices in /etc/fstab should be specified "
Comment 4 Alexey Kuznetsov 2008-10-26 13:13:01 EDT
In my opinion better to have some function who can test file for it's kind: device or file. Funtion can be more cleanly for source code, then magic if.

Do you still think your solution is good enough?
Comment 5 Jeremy Katz 2008-10-26 13:18:07 EDT
It's sufficient... and if it works, then I'll probably make it a little bit cleaner when really committing it :)  But quick and dirty is better for testing
Comment 6 Alexey Kuznetsov 2008-10-26 14:35:16 EDT
ok as you wish. i will create new vm machine for test, take a while..
Comment 7 Alexey Kuznetsov 2008-10-27 09:17:52 EDT
i can't reproduce it on my virtual machine, do you change something already in repo?
Comment 8 Chris Lumens 2008-11-04 10:56:00 EST
This should be fixed as of the October 29th build.  Jeremy committed the fix prior to that date.

Note You need to log in before you can comment on or make changes to this bug.