Bug 468506 - file graphics.cma is missing in ocaml package
file graphics.cma is missing in ocaml package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ocaml (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 08:03 EDT by Michael Krauss
Modified: 2009-07-19 06:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.11.0-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 06:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Krauss 2008-10-25 08:03:15 EDT
Description of problem:
I can't load graphics.cma in toplevel as documented in the ocaml manual, because graphics.cma is not inludeded in the ocaml package.

Version-Release number of selected component (if applicable):
ocaml-3.10.1-3.fc9.x86_64

How reproducible:
This is a permanent problem. 

Steps to Reproduce:
1. start ocaml toplevel
2. try to load graphics.cma
  
Actual results:
[mickraus@gandalf]~% ocaml
        Objective Caml version 3.10.1

# #load "graphics.cma";;
Cannot load required shared library dllgraphics.
Reason: dllgraphics.so: dllgraphics.so: cannot open shared object file: No such file or directory.


Expected results:
The bytecode version of the Graphics module should be included into the ocaml package.

Additional info:
[root@gandalf ~]# rpm -ql ocaml | grep graphics
/usr/lib64/ocaml/graphics.a
/usr/lib64/ocaml/graphics.cmx
/usr/lib64/ocaml/graphics.cmxa
/usr/lib64/ocaml/graphics.mli
/usr/lib64/ocaml/libgraphics.a
Comment 1 Richard W.M. Jones 2008-10-25 09:01:54 EDT
This was also reported on fedora-ocaml-list, although I
couldn't manage to reproduce it:

https://www.redhat.com/archives/fedora-ocaml-list/2008-September/msg00003.html
Comment 2 Michael Krauss 2008-10-27 10:27:31 EDT
To test ocaml package in rawhide, I installed Fedora 10 Snap3 on a ia32 machine.

[mickraus@frodo ~]$ rpm -q ocaml
ocaml-3.10.2-5.fc10.i386
[mickraus@frodo ~]$ rpm -ql ocaml | grep graphics
/usr/lib/ocaml/graphics.a
/usr/lib/ocaml/graphics.cmx
/usr/lib/ocaml/graphics.cmxa
/usr/lib/ocaml/graphics.mli
/usr/lib/ocaml/libgraphics.a
[mickraus@frodo ~]$ 

So graphics.cma is missing in rawhide too, resulting in the same error message as before.
Comment 3 Richard W.M. Jones 2008-10-28 05:36:47 EDT
I'll have a look this morning.
Comment 4 Richard W.M. Jones 2008-10-30 09:03:55 EDT
Nope, still can't reproduce this on Rawhide.  The following
works fine on both 32 bit and 64 bit Rawhide machines I have:

$ ocaml
        Objective Caml version 3.10.2

# #load "graphics.cma";;
#
Comment 5 Richard W.M. Jones 2008-10-30 09:05:41 EDT
I think the problem may be that you need to install ocaml-runtime:

$ rpm -ql ocaml | grep graphics
/usr/lib64/ocaml/graphics.a
/usr/lib64/ocaml/graphics.cmx
/usr/lib64/ocaml/graphics.cmxa
/usr/lib64/ocaml/graphics.mli
/usr/lib64/ocaml/libgraphics.a
$ locate /graphics.cma
/usr/lib64/ocaml/graphics.cma
$ rpm -qf /usr/lib64/ocaml/graphics.cma
ocaml-runtime-3.10.2-5.fc10.x86_64
Comment 6 Michael Krauss 2008-10-30 12:48:05 EDT
You are right, graphics.cma is in ocaml-runtime. But the problem still existed.
So I compared Rawhide with a working Graphics module on an Arch installation. 

In the end I realized that the shared library /usr/lib/ocaml/stublibs/dllgraphics.so was missing on the Fedora installation. Google showed the library being part of the ocaml-x11 package. After installing this the Graphics module is working now.

Thanks for your help.
Comment 7 Richard W.M. Jones 2008-10-30 13:18:47 EDT
Reopening - this is actually a bug.
Comment 8 Ian Main 2009-06-01 18:44:56 EDT
I just hit this today and was able to resolve my troubles because I found this bug.  Just wanted to give it a bump. :)
Comment 9 Fedora Update System 2009-06-02 04:23:46 EDT
ocaml-3.11.0-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ocaml-3.11.0-3.fc11
Comment 10 Fedora Update System 2009-06-04 17:23:59 EDT
ocaml-3.11.0-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ocaml'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5964
Comment 11 Bug Zapper 2009-06-09 05:50:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Fedora Update System 2009-07-19 06:18:52 EDT
ocaml-3.11.0-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.