Bug 468508 - /usr/include/sndfile.h:11:2: error: #endif without #if
/usr/include/sndfile.h:11:2: error: #endif without #if
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libsndfile (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 08:39 EDT by Edward Sheldrake
Modified: 2008-11-06 21:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 21:53:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Sheldrake 2008-10-25 08:39:48 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.17) Gecko/20080925 Fedora/1.1.12-1.fc9 SeaMonkey/1.1.12

This problem appeared with libsndfile-devel-1.0.17-5.fc9.i386 from updates-testing.

When compiling gst-plugins-bad:
In file included from gstsf.h:26
from gstsf.c:28:
/usr/include/sndfile.h:11:2: error: #endif without #if

Reproducible: Always

Steps to Reproduce:
1. Update to libsndfile-devel-1.0.17-5.fc9.i386 from updates-testing
2. Compile gst-plugins-bad
3.
Actual Results:  
gst-plugins-bad fails to compile due to the extra #endif in sndfile.h


Likely applies to other programs that use libsndfile.
Removing the second #endif from sndfile.h fixes the problem.
Comment 1 Andreas Thienemann 2008-10-25 08:50:03 EDT
Good catch Edward.

I accidentially introduced a spurious #endif in the wrapper for sndfile.h.

Updated packages are being built right now.

Please check 1.0.17-6.

regards,
 andreas
Comment 2 Fedora Update System 2008-10-25 09:06:02 EDT
libsndfile-1.0.17-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libsndfile-1.0.17-6.fc9
Comment 3 Edward Sheldrake 2008-10-25 10:08:00 EDT
Yes, I can confirm it's fixed in libsndfile-1.0.17-6.fc9, gstreamer-plugins-bad rebuilt successfully.
Comment 4 Fedora Update System 2008-10-30 08:49:47 EDT
libsndfile-1.0.17-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libsndfile'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9210
Comment 5 Fedora Update System 2008-11-06 21:53:15 EST
libsndfile-1.0.17-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.