Bug 468512 - navigating through .pxt pages produces error messages in apache logs
navigating through .pxt pages produces error messages in apache logs
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Milan Zazrivec
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-10-25 09:38 EDT by Milan Zazrivec
Modified: 2009-08-26 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 15:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/httpd/error_log (1.11 KB, text/plain)
2008-10-25 09:38 EDT, Milan Zazrivec
no flags Details

  None (edit)
Description Milan Zazrivec 2008-10-25 09:38:00 EDT
Created attachment 321502 [details]
/var/log/httpd/error_log

Description of problem:
* Satellite-5.3.0-RHEL5-re20081024.1 / s390x
* Navigating to arbitraty .pxt page in web ui produces errors in apache log
  (error_log)

Despite the errors, everything in the web ui seems to be working OK.

Version-Release number of selected component (if applicable):
spacewalk-web-0.3.3-2
Comment 1 Clifford Perry 2008-10-30 11:53:04 EDT
Humm, - I wonder if someone put in some debug/print statements in spacewalk to fix something and never removed them or committed it by mistake. We should look to clean this up. 

[Sat Oct 25 09:28:16 2008] [error] Class list: $VAR1 = 'Grail::Frame';\n$VAR2 = 'Sniglets::HTML';\n$VAR3 = 'Sniglets::ChannelEditor';\n$VAR4 = 'Sniglets::Channel';\n$VAR5 = 'Sniglets::Lists';\n$VAR6 = 'Sniglets::Users';
[Sat Oct 25 09:28:17 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::HTML';\n$VAR3 = 'Grail::Frame';\n$VAR4 = 'Sniglets::Navi';
[Sat Oct 25 09:28:17 2008] [error] Class list: $VAR1 = 'Sniglets::Header';
[Sat Oct 25 09:28:17 2008] [error] Class list: $VAR1 = 'Sniglets::Navi';
[Sat Oct 25 09:28:17 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::Lists';\n$VAR3 = 'Sniglets::HTML';
[Sat Oct 25 09:28:17 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::Header';\n$VAR3 = 'Sniglets::Search';\n$VAR4 = 'Sniglets::Sets';
[Sat Oct 25 09:28:17 2008] [error] Class list:  at /usr/lib/perl5/site_perl/5.8.8/PXT/ApacheHandler.pm line 527.
[Sat Oct 25 09:28:17 2008] [error] Class list: $VAR1 = 'Sniglets::Utils';\n$VAR2 = 'Sniglets::Users';
[Sat Oct 25 09:28:17 2008] [error] Class list:  at /usr/lib/perl5/site_perl/5.8.8/PXT/ApacheHandler.pm line 527.
Comment 2 Shannon Hughes 2008-11-17 15:51:40 EST
I noticed this earlier too but in the current version of spacewalk it appears to be gone. I browsed 10 different pxt files and could not duplicate. going to close out this bug.
Comment 3 John Sefler 2009-08-26 12:33:33 EDT
I could not reproduce errors in /var/log/httpd/error_log that displayed $VAR information.

I looked at the /var/log/httpd/error_log on three different working staged satellites.  None of them had this logging.

Appears to be working on staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

adding ClosedValid to QA Whiteboard

Note You need to log in before you can comment on or make changes to this bug.