Bug 468513 - NetworkManager crashes while trying to connect to VPN (pptp)
NetworkManager crashes while trying to connect to VPN (pptp)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-pptp (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 09:47 EDT by Tomasz Sałaciński
Modified: 2009-03-18 09:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 09:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Sałaciński 2008-10-25 09:47:43 EDT
Description of problem:

I am using NetworkManager to connect to my work VPN. It works flawlessly, but hangs if user selects "Remember password".


When I start nm-applet from console, I get this while trying to connect to VPN:
*** glibc detected *** /usr/libexec/nm-pptp-auth-dialog: free(): invalid pointer: 0xb7cbb060 ***

It seems that it tries to destroy the authentication dialog that didn't came up on the screen because user saved password in the keyring.

NetworkManager applet is still running, user can right-click to see menus, except for that it doesn't react to anything and needs to be killed.

It doesn't happen is you won't type your password in VPN configuration and force NM to show the auth dialog.


Version-Release number of selected component (if applicable):

NetworkManager 0.7.0


How reproducible:
Always


Steps to Reproduce:
1. Create a new VPN connection
2. Enter your information, login and password
3. See how NM crashes (icon is still showing that it's trying to connect)

Actual results:
NM crashed, but still works (it interacts with user, just can't do anything with it)

Expected results:
NM connects and automatically authenticates the user.

Additional info:
To connect to VPN, just force NM to show you the authentication dialog (you can save your login, but remember not to save the password).

I gave it high severity, because users might think that Linux can't connect to PPTP VPN at all or their VPN is not compatible with NM (because it looks like it's still trying to connect).
Comment 1 Dan Williams 2008-10-27 10:53:14 EDT
Which version of the NetworkManager-pptp RPM do you have installed?
Comment 2 Tomasz Sałaciński 2008-10-27 11:55:32 EDT
I am using:

NetworkManager-pptp-0.7.0-0.11.svn4178.fc10.i386
Comment 3 Bug Zapper 2008-11-25 23:13:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Adam Sobotka 2008-12-07 04:49:42 EST
Looks like same issue. I think it is related to my network configuration (I added one more connection to nm with static ip). I tried to enable mppe and disable everything except mschap2, but it didn't helped and log looks near same.

Dec  7 10:43:15 localhost NetworkManager: <info>  Starting VPN service 'org.freedesktop.NetworkManager.pptp'...
Dec  7 10:43:15 localhost NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.pptp' started (org.freedesktop.NetworkManager.pptp), PID 6240
Dec  7 10:43:15 localhost NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.pptp' just appeared, activating connections
Dec  7 10:43:15 localhost NetworkManager: <info>  VPN plugin state changed: 1
Dec  7 10:43:15 localhost NetworkManager: <info>  VPN plugin state changed: 3
Dec  7 10:43:15 localhost NetworkManager: <info>  VPN connection 'VPN connection 1' (Connect) reply received.
Dec  7 10:43:15 localhost pppd[6244]: Plugin /usr/lib/pppd/2.4.4/nm-pptp-pppd-plugin.so loaded.
Dec  7 10:43:15 localhost kernel: PPP generic driver version 2.4.2
Dec  7 10:43:15 localhost pppd[6244]: pppd 2.4.4 started by root, uid 0
Dec  7 10:43:15 localhost pppd[6244]: Using interface ppp0
Dec  7 10:43:15 localhost pppd[6244]: Connect: ppp0 <--> /dev/pts/0
Dec  7 10:43:15 localhost pptp[6256]: nm-pptp-service-6240 log[main:pptp.c:314]: The synchronous pptp option is NOT activated
Dec  7 10:43:16 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'
Dec  7 10:43:16 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:739]: Received Start Control Connection Reply
Dec  7 10:43:16 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:773]: Client connection established.
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:858]: Received Outgoing Call Reply.
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call established (call ID 0, peer's call ID 29875).
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:950]: PPTP_SET_LINK_INFO received from peer_callid 0
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:953]:   send_accm is 00000000, recv_accm is FFFFFFFF
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 warn[ctrlp_disp:pptp_ctrl.c:956]: Non-zero Async Control Character Maps are not supported!
Dec  7 10:43:17 localhost pppd[6244]: LCP terminated by peer (@]0^D^@<M-Mt^@^@^BM-3)
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:950]: PPTP_SET_LINK_INFO received from peer_callid 0
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:953]:   send_accm is FFFFFFFF, recv_accm is FFFFFFFF
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 warn[ctrlp_disp:pptp_ctrl.c:956]: Non-zero Async Control Character Maps are not supported!
Dec  7 10:43:17 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_disp:pptp_ctrl.c:912]: Received Call Clear Request.
Dec  7 10:43:20 localhost NetworkManager: <info>  VPN plugin failed: 1
Dec  7 10:43:20 localhost pppd[6244]: Connection terminated.
Dec  7 10:43:20 localhost pptp[6256]: nm-pptp-service-6240 warn[decaps_hdlc:pptp_gre.c:204]: short read (-1): Input/output error
Dec  7 10:43:20 localhost pptp[6256]: nm-pptp-service-6240 warn[decaps_hdlc:pptp_gre.c:216]: pppd may have shutdown, see pppd log
Dec  7 10:43:20 localhost pptp[6273]: nm-pptp-service-6240 log[callmgr_main:pptp_callmgr.c:234]: Closing connection (unhandled)
Dec  7 10:43:20 localhost pptp[6273]: nm-pptp-service-6240 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'
Dec  7 10:43:20 localhost pptp[6273]: nm-pptp-service-6240 log[call_callback:pptp_callmgr.c:79]: Closing connection (call state)
Dec  7 10:43:20 localhost NetworkManager: <info>  VPN plugin failed: 1
Dec  7 10:43:20 localhost pppd[6244]: Modem hangup
Dec  7 10:43:20 localhost pppd[6244]: Exit.
Dec  7 10:43:20 localhost NetworkManager: <info>  VPN plugin failed: 1
Dec  7 10:43:20 localhost NetworkManager: <info>  VPN plugin state changed: 6
Dec  7 10:43:20 localhost NetworkManager: <info>  VPN plugin state change reason: 0
Dec  7 10:43:20 localhost NetworkManager: <WARN>  connection_state_changed(): Could not process the request because no VPN connection was active.
Dec  7 10:43:20 localhost NetworkManager: <info>  Policy set 'Wired connection 1' (eth0) as default for routing and DNS.
Comment 5 Dan Williams 2008-12-09 12:12:39 EST
Update: fixed upstream in svn r4373, will get into next NM update.
Comment 6 Alain RUSSIER 2009-03-18 03:45:28 EDT
You may try to add 
refuse-eap
in /etc/ppp/options
Comment 7 Dan Williams 2009-03-18 09:22:21 EDT
Ah, should already be fixed in latest updates with NetworkManager-pptp >= 0.7.0.97.

Or, uncheck "EAP" in the allowed authentication methods dialog in the connection editor for that VPN.

Note You need to log in before you can comment on or make changes to this bug.