Bug 468523 - network-manager-pptp causes AVC denial (SELinux)
network-manager-pptp causes AVC denial (SELinux)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
: 468522 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 11:51 EDT by Lebenskuenstler
Modified: 2008-11-17 03:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 03:16:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SELinux report (2.80 KB, text/plain)
2008-10-25 11:51 EDT, Lebenskuenstler
no flags Details

  None (edit)
Description Lebenskuenstler 2008-10-25 11:51:54 EDT
Created attachment 321512 [details]
SELinux report

Description of problem:

When I tell network-manager-pptp to dial a pptp-connection, SELinux will report an AVC debial. NM will report a fail of starting service.

Version-Release number of selected component (if applicable):
0.10.svn4027.fc9

How reproducible:
every time

Steps to Reproduce:
1. click onto NM-Symbol (Gnome)
2. click VPN connection
3. click any pptp connection
  
Expected results:

starting of the pptp connection.
Comment 1 Lebenskuenstler 2008-10-25 12:06:42 EDT
*** Bug 468522 has been marked as a duplicate of this bug. ***
Comment 2 Dan Williams 2008-10-27 10:54:56 EDT
Dan, I think this has been fixed already in recent policy, right?
Comment 3 Daniel Walsh 2008-10-27 15:40:04 EDT
Fixed in selinux-policy-3.3.1-103.fc9
Comment 4 Lebenskuenstler 2008-11-05 00:28:06 EST
Well, no AVC denial anymore.

My pptp-connection still does not work in F9 but looks better now in F10-Preview ;)
Comment 5 Lebenskuenstler 2008-11-17 03:16:45 EST
pptp and NetworkManager are working in Fedora 10.

Note You need to log in before you can comment on or make changes to this bug.