Bug 468553 - Defaut margins don't seem to be used for text
Defaut margins don't seem to be used for text
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 16:06 EDT by Bruno Wolff III
Modified: 2009-01-21 16:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 16:29:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy of printers.conf file. (381 bytes, application/octet-stream)
2008-10-25 16:06 EDT, Bruno Wolff III
no flags Details
ppd file (37.75 KB, application/octet-stream)
2008-11-02 23:08 EST, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2008-10-25 16:06:42 EDT
Created attachment 321527 [details]
Copy of printers.conf file.

Description of problem:
When I configure a printer and check that the default margins for text output are set, they appear to be reasonable (18 ot 36 points). But when I print text output the leftmost part of the output is cut off and the first line is at the very top of the page. If I use options on lp to specify those same margins, then things print reasonably.

Version-Release number of selected component (if applicable):
cups-1.3.9-2.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1. Print a text file using lp
2.
3.
  
Actual results:
Default margin settings appear to be ignored.

Expected results:
Output prints normally on paper.

Additional info:
Printing from evince or firefox (presumably using postscript) is properly aligned by default.
Comment 1 Tim Waugh 2008-10-30 13:25:00 EDT
Please explain in more detail what you are doing:

1. It really helps to know which printer model you are using; it may seem like a generic problem to you but there is a chance it is specific to one or several models.

2. How are you checking the default margins?

3. What does 'lpoptions -p $queue' say for your queue?

4. How are you specifying the options to lp to make things print reasonably?
Comment 2 Bruno Wolff III 2008-10-30 16:29:40 EDT
I am not home right now so I can't give you all of the information.
I don't see the problem at work, though there there is a windows server that I access through smb.
At home I have an Espon photo stylus (an 870 I think).
I was checking the margins using gnome's admin menu which I think uses system-config-printer.
lp -o page-left=18 -o page-top=18 textfilename
I'll see if I can get more info tonight, but I won't be getting home until late and will be pretty busy tomorrow. So it might be during the weekend that I get a chance to look at it again.
Comment 3 Tim Waugh 2008-10-31 11:22:07 EDT
Does this do anything different?:

lp -o document-format=text/html textfilename

Also, could you please attach the PPD from /etc/cups/ppd for that queue?  Thanks.
Comment 4 Bruno Wolff III 2008-10-31 11:48:07 EDT
I'll get you the rest of the stuff this weekend.
Comment 5 Bruno Wolff III 2008-11-02 23:01:55 EST
[root@bruno bruno]# lpoptions -p bruno
media=Letter finishings=3 fitplot=false copies=1 job-hold-until=no-hold job-priority=50 number-up=1 auth-info-required=none job-sheets=none,none printer-info='Bruno's Espon Sytlus Photo 870' printer-is-accepting-jobs=1 printer-is-shared=1 printer-location='Bruno's office' printer-make-and-model='Epson Stylus Photo 870 Foomatic/gutenprint-ijs-simplified.5.0 (recommended)' printer-state=3 printer-state-change-time=1224963815 printer-state-reasons=none printer-type=167948

With lp -o document-format=text/html it printed the same way.
Comment 6 Bruno Wolff III 2008-11-02 23:08:38 EST
Created attachment 322259 [details]
ppd file
Comment 7 Bug Zapper 2008-11-25 23:14:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2008-12-23 11:57:26 EST
I previous driver stopped working, but when I checked there seemed to be a new option that I don't think (but could be wrong) was there before. So I switched to a cups gutenprint driver instead of a foomatic one. The default margin options for text still appear to be ignored but at least the output is now on the page and not cut off on the top and left sides as it was previously.
bash-3.2$ lpoptions -p bruno
media=Letter finishings=3 fitplot=false copies=1 job-hold-until=no-hold job-priority=50 number-up=1 auth-info-required=none job-sheets=none,none printer-info='Bruno's Espon Sytlus Photo 870' printer-is-accepting-jobs=1 printer-is-shared=1 printer-location='Bruno's office' printer-make-and-model='Epson Stylus Photo 870 - CUPS+Gutenprint v5.2.2' printer-state=3 printer-state-change-time=1230050909 printer-state-reasons=none printer-type=8556556
Comment 9 Tim Waugh 2009-01-05 11:58:21 EST
This is a bug in the paps filter.  When used as 'texttopaps' it is using zero margins by default instead of the advertised values.

Additionally, when used as texttopaps it ought to use left and right margin values of 18 points, not 36.
Comment 10 Akira TAGOH 2009-01-07 02:39:48 EST
using zero margins instead of the advertised values?
it should refers mergins from ppd or CUPS options though.
Tim, can you explain why you conclude so?

I don't remember why I did set 18 for left and right margins. I should had a look at texttops.
or might be a default value from ppd for my printer and got confused possibly.

Anyway I'll fix it.
Comment 11 Tim Waugh 2009-01-07 07:18:46 EST
Oh, false alarm, sorry.  I was comparing texttopaps and texttops incorrectly.  When a PPD is specified it changes the behaviour, and I only specified a PPD when testing texttopaps.

The problem is in system-config-printer which is advertising incorrect defaults.
Comment 12 Tim Waugh 2009-01-07 07:21:27 EST
Fixed upstream.
Comment 13 Fedora Update System 2009-01-14 22:02:15 EST
system-config-printer-1.0.12-8.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11136
Comment 14 Fedora Update System 2009-01-14 22:04:12 EST
system-config-printer-1.0.12-8.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11189
Comment 15 Fedora Update System 2009-01-16 18:45:41 EST
system-config-printer-1.0.13-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11136
Comment 16 Fedora Update System 2009-01-16 18:49:02 EST
system-config-printer-1.0.13-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11189
Comment 17 Fedora Update System 2009-01-21 16:29:46 EST
system-config-printer-1.0.13-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2009-01-21 16:38:33 EST
system-config-printer-1.0.13-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.