Bug 468557 - Ability to check HP Smart Arrays (hardware-raid)
Ability to check HP Smart Arrays (hardware-raid)
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
FeatureRequest
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 18:17 EDT by Stefan Neufeind
Modified: 2010-06-09 05:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 05:20:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-10-25 18:17:33 EDT
HP-util "hpacucli" can be used. Several plugins that interface to that util exist on nagios-exchange. "One" should be chosen (which is most commonly used) and  a package provided for it.
Comment 1 Robert Scheck 2008-10-25 20:25:45 EDT
Packaging something like this would introduce a dependency to a binary-only 
package (hpacucli) which we cannot satisfy with EPEL or RHEL by default in any
case using the repository.

Why not using http://freshmeat.net/projects/arrayprobe/ which includes per
default the support to check HP Smart Arrays and also Nagios Plugin feature:

tux1:~ # arrayprobe
OK Arrayprobe All controllers ok
tux1:~ # 
tux1:~ # echo $?
0
tux1:~ #

tux2:~ # arrayprobe
CRITICAL no logical drives detected
tux2:~ # 
tux2:~ # echo $?
2
tux2:~ #
Comment 2 Stefan Neufeind 2008-10-26 06:05:37 EDT
Would be an option, yes. Wasn't "that easy" to compile since it demands kernel-sources (not kernel-devel or kernel-headers). However the project looks quite "stale".

My idea was to have a plugin bug not add a dependency to the HP-tools - just have a plugin which "expects" the hp-binary is present.
Comment 3 Joshua Roys 2010-02-04 11:07:28 EST
I just recently got cciss_vol_status into EPEL - does that do what you need?
Comment 4 Peter Lemenkov 2010-06-09 05:20:51 EDT
Well, if this request is still valid, then all we need is someone, who would like to create new package and maintain it. I, personally, won't.

Note You need to log in before you can comment on or make changes to this bug.