Bug 468568 - system-install-packages does not work, *again*
system-install-packages does not work, *again*
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 00:10 EDT by Evan
Modified: 2008-11-06 05:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 05:47:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error while processing a print job (42.85 KB, text/plain)
2008-10-26 00:13 EDT, Evan
no flags Details

  None (edit)
Description Evan 2008-10-26 00:10:51 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Evan 2008-10-26 00:13:33 EDT
Created attachment 321534 [details]
error while processing a print job
Comment 2 Tim Waugh 2008-10-30 13:20:52 EDT
What does 'rpm -q pnm2ppa' say?
Comment 3 Evan 2008-11-02 20:41:59 EST
(In reply to comment #2)
> What does 'rpm -q pnm2ppa' say?

package pnm2ppa is not installed  (hummmm)
Comment 4 Tim Waugh 2008-11-03 03:59:55 EST
Now please run this from the command line, as the user you normally log on as (i.e. *don't* switch to root using 'su'):

system-install-packages pnm2ppa

What does it say?
Comment 5 Evan 2008-11-03 18:47:12 EST
(In reply to comment #4)
> Now please run this from the command line, as the user you normally log on as
> (i.e. *don't* switch to root using 'su'):
> 
> system-install-packages pnm2ppa
> 
> What does it say?

[Evan@localhost ~]$ system-install-packages pnm2ppa
Traceback (most recent call last):
  File "/usr/bin/system-install-packages", line 34, in <module>
    os.execv("/usr/bin/gpk-install-package", ["gpk-install-file"] + specified)
OSError: [Errno 2] No such file or directory
[Evan@localhost ~]$
Comment 6 Evan 2008-11-03 22:17:08 EST
I used yum to install package pnm2ppa although I had to log on as root user using (su) command. Not sure what to  do next . It says, pnm2ppa-1.04-16.fc10.i386, now I've installed it.
Comment 7 Tim Waugh 2008-11-04 05:00:44 EST
Now you've installed pnm2ppa I expect you can print.  But the problem is that system-install-packages didn't work, so that's what we need to analyse.

What does this say, as root?:

rpm -V gnome-packagekit
Comment 8 Evan 2008-11-04 23:50:21 EST
(In reply to comment #7)
> Now you've installed pnm2ppa I expect you can print.  But the problem is that
> system-install-packages didn't work, so that's what we need to analyse.
> 
> What does this say, as root?:
> 
> rpm -V gnome-packagekit

A long pause (2-3sec) and #
Comment 9 Evan 2008-11-05 00:06:06 EST
And yes I can print now.
Comment 10 Tim Waugh 2008-11-05 04:22:49 EST
So the problem is that gnome-packagekit ships a broken system-install-packages program again.
Comment 11 Richard Hughes 2008-11-05 06:38:10 EST
My fault, apologies. I've fixed this in http://koji.fedoraproject.org/koji/taskinfo?taskID=918077 -- the system-install-packages command must not have worked for the whole of F10. The compat wrapper is not upstream, so didn't get the same level of testing as the other stuff.

The proper fix would be to patch the session application to use the DBUS interface, rather than an legacy script that calls an application that calls the DBUS interface. It's really easy: http://www.packagekit.org/files/session.c

You then get the window modal to your application, and focus-stealing-prevention works correctly. Plus, it works with KDE when there's no gnome-packagekit installed.

If you want me to submit a patch that 's no problem at all, although I'm sure it would be quicker for you as you know where the calling point is, and how to get your window XID.

Richard.
Comment 12 Tim Waugh 2008-11-05 13:19:57 EST
Thanks.  I've checked in support for doing that upstream.  It was more complicated in the end because:

1. The API is different in Fedora 9
2. I had to use async calls with DBusGMainLoop

If you wouldn't mind casting your eye over this it would be greatly appreciated. ;-)

http://git.fedorahosted.org/git/?p=system-config-printer.git;a=commit;h=3f294bdaee5bd08f422cc0a97c47d55ac2fdfbc9
Comment 13 Richard Hughes 2008-11-05 13:27:40 EST
Ahh cool. In a few weeks I'm going to backport 0.3.x to F9, but your code is probably the belt and braces way. The patch looks good, thanks for doing that.

Note You need to log in before you can comment on or make changes to this bug.