Bug 468610 - user beaglidx not found, using root
user beaglidx not found, using root
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 14:03 EDT by David Nielsen
Modified: 2008-11-06 09:16 EST (History)
2 users (show)

See Also:
Fixed In Version: beagle-0.3.8-9.fc10.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 09:16:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2008-10-26 14:03:27 EDT
Description of problem:

There is problem with the beagle package where if the beagleidx user does not exist it uses the root user (potential security problem one wonders). 

(I apologize for the use of danish) 
Installerer    : beagle                                                   1/1 
advarsel: bruger beaglidx eksisterer ikke - bruger root
advarsel: gruppe beaglidx eksisterer ikke - bruger root
advarsel: bruger beaglidx eksisterer ikke - bruger root
advarsel: gruppe beaglidx eksisterer ikke - bruger root

Please refer to https://fedoraproject.org/wiki/PackageUserCreation

Version-Release number of selected component (if applicable):
beagle-0.3.8-7.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. On a fresh install invoke: yum install beagle
  
Actual results:
the above error message

Expected results:
correct use of seperate user account

Additional info:
x86_64, da_DK.UTF-8
Comment 1 Adel Gadllah 2008-10-26 15:03:45 EDT
Ouch! 
Wrong logic in the return code check, good catch.

I have built a fixed build for rawhide (beagle-0.3.8-8.fc10) and beagle-0.3.8-4.fc9 for F-9 should hit updates soon (next push).

As for F-8 it does not use this check so it was not affected.

Thanks for the report.
Comment 2 David Nielsen 2008-11-06 09:16:41 EST
Confirmed gone in beagle-0.3.8-9.fc10.x86_64

Note You need to log in before you can comment on or make changes to this bug.