Bug 468646 - Executing Mobile Broadband network option prompts for password then fails to connect
Executing Mobile Broadband network option prompts for password then fails to ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 23:03 EDT by Tony Farrell
Modified: 2008-10-31 23:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 23:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog output for the failed connection (2.44 KB, text/plain)
2008-10-26 23:03 EDT, Tony Farrell
no flags Details

  None (edit)
Description Tony Farrell 2008-10-26 23:03:55 EDT
Created attachment 321573 [details]
syslog output for the failed connection

Description of problem:

After yum update of October 26/27 NetworkManager would no longer automatically connect the Mobile Broadband network option. Following are the updates which were installed. One of these has caused the problem to occur. Booting to the previously installed kernel does not fix the problem. 

Oct 27 12:42:09 Updated: kernel-firmware-2.6.27.4-47.rc3.fc10.noarch
Oct 27 12:42:36 Updated: fedora-logos-10.0.0-2.fc10.noarch
Oct 27 12:43:10 Updated: solar-kde-theme-0.1.8-2.fc10.noarch
Oct 27 12:43:26 Updated: kde-settings-4.1-1.fc10.noarch
Oct 27 12:44:48 Updated: selinux-policy-3.5.13-8.fc10.noarch
Oct 27 12:46:52 Updated: selinux-policy-targeted-3.5.13-8.fc10.noarch
Oct 27 12:46:56 Updated: kde-settings-pulseaudio-4.1-1.fc10.noarch
Oct 27 12:47:23 Updated: kde-settings-kdm-4.1-1.fc10.noarch
Oct 27 12:47:37 Updated: audit-libs-1.7.8-4.fc10.i386
Oct 27 12:48:07 Updated: libsndfile-1.0.17-6.fc10.i386
Oct 27 12:48:20 Updated: libmtp-0.3.3-4.fc10.i386
Oct 27 12:48:56 Updated: audit-1.7.8-4.fc10.i386
Oct 27 12:49:08 Updated: audit-libs-python-1.7.8-4.fc10.i386
Oct 27 12:51:02 Installed: kernel-2.6.27.4-47.rc3.fc10.i686
Oct 27 12:51:15 Updated: 1:obex-data-server-0.4.1-1.fc10.i386
Oct 27 12:52:30 Updated: 6:kdepim-libs-4.1.2-4.fc10.i386
Oct 27 12:54:55 Updated: 6:kdepim-4.1.2-4.fc10.i386
Oct 27 13:02:22 Installed: kernel-2.6.27.4-47.rc3.fc10.i686
 

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.11.svn4201.fc10.i386

How reproducible:


Steps to Reproduce:
1. Install Sierra 595 USB Modem to USB port.
2. Start and login to Asus EEE PC as non privileged user.
3. Left click on NetworkManager icon and select Mobile Broadband device option.
  
Actual results:

Mobile Broadband network password prompt appears. Password field entry
is not hidden from user display. Password is not accepted and connection
fails.

Expected results:

The connection was previously accepted automatically using embedded password
and connection occured without further prompting.



Additional info:
Comment 1 Dan Williams 2008-10-30 02:04:43 EDT
Could you:

1) become root
2) Stop NetworkManager
3) run the following command in a terminal
sudo NM_SERIAL_DEBUG=1 NM_PPP_DEBUG=1 /usr/sbin/NetworkManager --no-daemon
4) Grab the output and attach it to this bug (as a private attachment!)

That should print out a lot of PPP debug info to help us figure out why the PPP server hates you :)
Comment 2 Dan Williams 2008-10-30 02:05:18 EDT
Forgot step 3.5: Try to connect with your mobile broadband card
Comment 3 Tony Farrell 2008-10-31 22:35:30 EDT
Following further yum updates to kernel-firmware-2.6.27.4-51 and the same release kernel the problem is resolved and the connection works as it should. I guess I should have been more patient. NetworkManager on Fedora10 Beta is a vast improvement on F9 and works very nicely on Asus EEE PC for wired, wireless and now mobile. The debug output is faultless so won't attach it unless you really want it. Thanks.
Comment 4 Dan Williams 2008-10-31 23:19:27 EDT
ok, thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.