Bug 468654 - secondary filesystems such as /var/spool and /var/log do not get mounted at boot time
secondary filesystems such as /var/spool and /var/log do not get mounted at b...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 04:28 EDT by Tarhon-Onu Victor
Modified: 2014-03-16 23:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 06:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tarhon-Onu Victor 2008-10-27 04:28:38 EDT
Description of problem:

When installing FC9 and attempting to use secondary file systems such as /var/log, /var/spool/, /var/spool/squid and so on, they never get mounted unless issuing from the console, AFTER the system is booted completely, a mount -a. /var gets mounted just fine, but not the subsequent filesystems.

Version-Release number of selected component (if applicable):
It happens on FC9, not on fc8+updates.

How reproducible:
Always.

Steps to Reproduce:
1. install a fresh new FC9 system, chose a custom layout for the disk partitions, and create under /var filesystems such as /var/spool, /var/spool/squid, stuff like this
2. finish the installation
3. log into the system and check the file systems mounted.
  
Actual results:
The /var/spool, /var/spool/squid, /var/log and whatever is created under /var is not mounted, they have to be mounted with mount -a.

Expected results:
These should get mounted automatically as they do with FC8. If a system reboots it requires manual mounting of those filesystems, which is not an option.

Additional info:
Comment 1 Tarhon-Onu Victor 2008-10-27 05:10:07 EDT
This is how fstab looks like:

[root@fc9 ~]# cat /etc/fstab 
UUID=b2906b3c-2bfd-4aae-b190-9786f8ffd24a /                       ext3    defaults        1 1
UUID=048dbdee-f309-42a4-9837-79fa22131c07 /tmp                    ext3    defaults        1 2
UUID=090053ed-67f2-46b1-8608-95af81c0883b /home                   ext3    defaults        1 2
UUID=65c81271-7f6b-4767-b425-559c81671782 /var                    ext3    defaults        1 2
UUID=89449680-4081-43d6-8df6-78e13b907087 /var/log                ext3    defaults        1 2
UUID=9ad95a1b-8714-4b60-a352-6ddb50e39461 /var/spool              ext3    defaults        1 2
UUID=2d441ac7-57b7-41fe-ab3b-338b08557f31 /var/spool/squid        xfs     defaults        1 2
UUID=c2596b60-be60-4362-b2eb-9f0294a10b12 /usr                    ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
UUID=aaaee770-487f-49b2-9151-67bc9dbaa5f9 swap                    swap    defaults        0 0


Also, just right after reboot:

[root@fc9 ~]# uptime
 11:08:24 up 0 min,  1 user,  load average: 0.45, 0.15, 0.05
[root@fc9 ~]# mount
/dev/sda2 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda6 on /tmp type ext3 (rw)
/dev/sda7 on /home type ext3 (rw)
/dev/sda3 on /var type ext3 (rw)
/dev/sda9 on /var/log type ext3 (rw)
/dev/sda5 on /usr type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
[root@fc9 ~]# mount -a
[root@fc9 ~]# mount
/dev/sda2 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda6 on /tmp type ext3 (rw)
/dev/sda7 on /home type ext3 (rw)
/dev/sda3 on /var type ext3 (rw)
/dev/sda9 on /var/log type ext3 (rw)
/dev/sda5 on /usr type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/sda8 on /var/spool type ext3 (rw)
/dev/sda10 on /var/spool/squid type xfs (rw)

Someone suggested also to provide this:
[root@fc9 ~]# chkconfig --list netfs
netfs           0:off   1:off   2:off   3:on    4:on    5:on    6:off

...even though as far as I remember, since when the netfs script was deployed as a service (I dont' even remember when, I think it was since redhat 7 or 8) it was supposed to mount nfs, smbfs and other network file systems.
Comment 2 Tarhon-Onu Victor 2008-10-27 06:08:18 EDT
Also, changing /etc/fstab from using UUIDs to using the disk partition names doesn't help:

/dev/sda2 /                       ext3   defaults        1 1
/dev/sda6 /tmp                    ext3   defaults        1 2
/dev/sda7 /home                   ext3   defaults        1 2
/dev/sda3 /var                    ext3   defaults        1 2
/dev/sda9 /var/log                ext3   defaults        1 2
/dev/sda8 /var/spool              ext3   defaults        1 2
/dev/sda10 /var/spool/squid       xfs    defaults        1 2
/dev/sda5 /usr                    ext3   defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/sda1 swap                    swap   defaults        0 0

This is a default install from the FC9 i386 DVD:

[root@fc9 ~]# uname -a
Linux fc9.hdinit.exe 2.6.25-14.fc9.i686 #1 SMP Thu May 1 06:28:41 EDT 2008 i686 i686 i386 GNU/Linux
[root@fc9 ~]# rpm -q initscripts
initscripts-8.76-1.i386

The DVD SHA1 checksum is:
50253a35b5ba128c9a57b2a10cbd829813fc5119  Fedora-9-i386-DVD.iso


However, after upgrading the system everything works as expected.

Note You need to log in before you can comment on or make changes to this bug.