Bug 468659 - OOO will crash when use OpenOffice automation test suite to test global functionality without oobase installed
OOO will crash when use OpenOffice automation test suite to test global funct...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 05:08 EDT by Yolkfull Chow
Modified: 2008-10-30 10:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 10:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my ~/.testtoolrc (1.04 KB, text/plain)
2008-10-29 10:31 EDT, Caolan McNamara
no flags Details
the test basic from the other issue (2.91 KB, text/plain)
2008-10-29 10:31 EDT, Caolan McNamara
no flags Details
here are my results (4.67 KB, application/x-gzip)
2008-10-29 10:57 EDT, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 95654 None None None Never

  None (edit)
Description Yolkfull Chow 2008-10-27 05:08:46 EDT
+++ This bug was initially created as a clone of Bug #468136 +++

Description of problem:
When use openoffice.org automation test suite to test global functionality, OOO will crash when check database during testing, following are backtrace: 
-------------
(I)    x.org loaded video driver of...
(WW) AllowEmtpyInput is on, devices using drivers 'kbd' or 'mouse' will be
disabled.
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: not GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not
installed
(V)    libgcj version is: libgcj-4.3.2-6-i386
(VI)   kernel is: Linux 2.6.27.3-44.fc10.i686 #1 SMP Fri Oct 24 00:40:32 EDT
2008 i686 i686 i386
(VII)  OpenOffice.org core rpm version is:
openoffice.org-core-3.0.0-9.6.fc10-i386
(VIII) accessibility is: false
(IX)   fedora release is: Fedora release 9.92 (Rawhide)
(X)    LANG is: en_US.utf-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda2             48995912  14010148  32496896  31% /
/dev/sda2             48995912  14010148  32496896  31% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
IcedTea6 1.3.1 Runtime Environment (build 1.6.0_0-b12)
OpenJDK Server VM (build 1.6.0_0-b12, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x354d6c4: 0x1b4a38:
/usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 +
0x256c4
0x354dfff: 0x1b4a38:
/usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 +
0x25fff
0x110400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0x7f280e7: 0x2d5d4:
/usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x1f0e7
0x7f17b70: 0x2d5d4:
/usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0xeb70
0x7f18633: 0x2d5d4:
/usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0xf633
0x7f1c4ee: 0x2d5d4:
/usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x134ee
0x7f1ea63: 0x2d5d4:
/usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x15a63
0x7f1ed30: 0x2d5d4:
/usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x15d30
0x7f28f88: 0x2d5d4:
/usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x1ff88
0x43cfe2b: 0x7747c:
/usr/lib/openoffice.org3/program/../basis-link/program/libfweli.so + 0x5fe2b
(framework::PreventDuplicateInteraction::handle(com::sun::star::uno::Reference<com::sun::star::task::XInteractionRequest>
const&) + 0xd5)
0x7f57509: 0x2d24c:
/usr/lib/openoffice.org3/program/../basis-link/program/libfilterconfig1.so +
0x1f509
0x7f59a34: 0x2d24c:
/usr/lib/openoffice.org3/program/../basis-link/program/libfilterconfig1.so +
0x21a34
0x81285d8: 0x1e528c:
/usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd95d8
0x8128baf: 0x1e528c:
/usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd9baf
0x8122eac: 0x1e528c:
/usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd3eac
0x81231ae: 0x1e528c:
/usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd41ae
0x376f865: 0xe6fc4:
/usr/lib/openoffice.org3/program/../basis-link/program/libcomphelp4gcc3.so +
0x8a865
(comphelper::SynchronousDispatch::dispatch(com::sun::star::uno::Reference<com::sun::star::uno::XInterface>
const&, rtl::OUString const&, rtl::OUString const&, long,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) +
0x27d)
0x4530cd9: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0xaccd9
0x464bb45: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7b45
0x464c413: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c8413
(SfxDispatcher::Execute(unsigned short, unsigned short, unsigned short,
SfxItemSet const&) + 0x109)
0x464c4bb: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c84bb
(SfxDispatcher::Execute(unsigned short, unsigned short, SfxItemSet const&) +
0x29)
0x452f346: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0xab346
0x464bb45: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7b45
0x464be92: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7e92
0x4667da3: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e3da3
0x4667d59: 0x2e6520:
/usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e3d59
0x3e12843: 0x2ebb8c:
/usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x213843
0x386430: 0x65604: /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so
+ 0x46430 (SalDisplay::DispatchInternalEvent() + 0x96)
0x2ca0fc: 0x410f0: /usr/lib/openoffice.org/basis3.0/program/libvclplug_gtkli.so
+ 0x120fc
0x7222d1: 0xe1588: /lib/libglib-2.0.so.0 + 0x352d1
0x724208: 0xe1588: /lib/libglib-2.0.so.0 + 0x37208 (g_main_context_dispatch +
0x1e8)
0x7278b3: 0xe1588: /lib/libglib-2.0.so.0 + 0x3a8b3
0x727a71: 0xe1588: /lib/libglib-2.0.so.0 + 0x3aa71 (g_main_context_iteration +
0x71)
0x2ca1b4: 0x410f0: /usr/lib/openoffice.org/basis3.0/program/libvclplug_gtkli.so
+ 0x121b4
0x38cc49: 0x65604: /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so
+ 0x4cc49 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x3c9b981: 0x2ebb8c:
/usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9c981
(Application::Yield(bool) + 0x57)
0x3c9b9cf: 0x2ebb8c:
/usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9c9cf
(Application::Execute() + 0x2b)
0x534f722: 0x51904:
/usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so +
0x1e722
0x3c9efbb: 0x2ebb8c:
/usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9ffbb
0x3c9f157: 0x2ebb8c:
/usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0xa0157
(SVMain() + 0x2c)
0x536f6b0: 0x51904:
/usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so +
0x3e6b0 (soffice_main + 0xd0)
0x80487c4: 0xccc: /usr/lib/openoffice.org3/program/swriter.bin + 0x7c4 (main +
0x20)
0x50b6d5: 0x16fd7c: /lib/libc.so.6 + 0x166d5 (__libc_start_main + 0xe5)
0x8048711: 0xccc: /usr/lib/openoffice.org3/program/swriter.bin + 0x711
...end stackreport details ...
...start sample ldd details ...
 linux-gate.so.1 =>  (0x00110000)
 libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x004ef000)
 libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00158000)
 libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x001ed000)
 libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x0020a000)
 libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x0027d000)
 libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x002a7000)
 libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x002c4000)
 libcairo.so.2 => /usr/lib/libcairo.so.2 (0x002cf000)
 libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00347000)
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x0038d000)
 libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00420000)
 libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x0044f000)
 libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x00453000)
 librt.so.1 => /lib/librt.so.1 (0x00458000)
 libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00462000)
 libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00480000)
 libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x008d5000)
 libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00916000)
 libvclplug_genli.so =>
/usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so (0x009f9000)
 libvclli.so => /usr/lib/openoffice.org/basis3.0/program/libvclli.so
(0x00a66000)
 libpspli.so => /usr/lib/openoffice.org/basis3.0/program/libpspli.so
(0x00d5a000)
 libsotli.so => /usr/lib/openoffice.org/basis3.0/program/libsotli.so
(0x00e23000)
 libutlli.so => /usr/lib/openoffice.org/basis3.0/program/libutlli.so
(0x00e71000)
 libtlli.so => /usr/lib/openoffice.org/basis3.0/program/libtlli.so (0x00ee0000)
 libcomphelp4gcc3.so =>
/usr/lib/openoffice.org/basis3.0/program/libcomphelp4gcc3.so (0x00f62000)
 libucbhelper4gcc3.so =>
/usr/lib/openoffice.org/basis3.0/program/libucbhelper4gcc3.so (0x02121000)
 libuno_cppuhelpergcc3.so.3 =>
/usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3
(0x02301000)
 libuno_cppu.so.3 =>
/usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppu.so.3
(0x01e51000)
 libvos3gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libvos3gcc3.so
(0x01da1000)
 libuno_sal.so.3 =>
/usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_sal.so.3
(0x03731000)
 libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x004c1000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0x05c7f000)
 libXext.so.6 => /usr/lib/libXext.so.6 (0x04b8d000)
 libdl.so.2 => /lib/libdl.so.2 (0x04ac7000)
 libpthread.so.0 => /lib/libpthread.so.0 (0x04c41000)
 libstlport_gcc.so =>
/usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libstlport_gcc.so
(0x058a1000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x05b71000)
 libm.so.6 => /lib/libm.so.6 (0x03e2a000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x03d52000)
 libc.so.6 => /lib/libc.so.6 (0x04882000)
 libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x004c8000)
 libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x03cfa000)
 libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x0104c000)
 libpng12.so.0 => /usr/lib/libpng12.so.0 (0x02412000)
 libXrender.so.1 => /usr/lib/libXrender.so.1 (0x021a6000)
 libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x01051000)
 libXi.so.6 => /usr/lib/libXi.so.6 (0x01054000)
 libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x021ba000)
 libselinux.so.1 => /lib/libselinux.so.1 (0x03d70000)
 libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x040f7000)
 libz.so.1 => /lib/libz.so.1 (0x03cc8000)
 libexpat.so.1 => /lib/libexpat.so.1 (0x03e57000)
 /lib/ld-linux.so.2 (0x004cc000)
 libnsl.so.1 => /lib/libnsl.so.1 (0x0105d000)
 libcap.so.2 => /lib/libcap.so.2 (0x02b2b000)
 libSM.so.6 => /usr/lib/libSM.so.6 (0x02b6a000)
 libICE.so.6 => /usr/lib/libICE.so.6 (0x02ce4000)
 libi18nisolang1gcc3.so =>
/usr/lib/openoffice.org/basis3.0/program/libi18nisolang1gcc3.so (0x01077000)
 libbasegfxli.so => /usr/lib/openoffice.org/basis3.0/program/libbasegfxli.so
(0x03167000)
 libicuuc.so.40 => /usr/lib/libicuuc.so.40 (0x044d8000)
 libicule.so.40 => /usr/lib/libicule.so.40 (0x03f21000)
 libjvmaccessgcc3.so.3 =>
/usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libjvmaccessgcc3.so.3
(0x03cbe000)
 libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_salhelpergcc3.so.3
(0x03c97000)
 libcrypt.so.1 => /lib/libcrypt.so.1 (0x050ce000)
 libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x04cc9000)
 libxcb.so.1 => /usr/lib/libxcb.so.1 (0x04eeb000)
 libXau.so.6 => /usr/lib/libXau.so.6 (0x04cde000)
 libuuid.so.1 => /lib/libuuid.so.1 (0x030b5000)
 libicudata.so.40 => /usr/lib/libicudata.so.40 (0xb7222000)
 libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x030e7000)
...end sample ldd details ...
--------------

Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.10.el5-i386

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from caolanm@redhat.com on 2008-10-23 04:08:31 EDT ---

Please give some steps to reproduce this, its only takes a few extra seconds to do this as you know how you got to this point

--- Additional comment from yzhou@redhat.com on 2008-10-23 05:06:36 EDT ---

(In reply to comment #1)
> Please give some steps to reproduce this, its only takes a few extra seconds to
> do this as you know how you got to this point

Caolan,
I am sorry for that since it is only an automation test tool from OpenOffice.org qa team. So far what I know is it is testing OOO database. I will read the codes and try to catch the steps.

--- Additional comment from caolanm@redhat.com on 2008-10-24 04:38:14 EDT ---

Is this the testtool from the RHEL-5 openoffice.org-testtools rpm, or something else ? All I really need to know is how to repeat what you did to make it crash.

--- Additional comment from yzhou@redhat.com on 2008-10-24 05:57:43 EDT ---

(In reply to comment #3)
> Is this the testtool from the RHEL-5 openoffice.org-testtools rpm, or something
> else ? All I really need to know is how to repeat what you did to make it
> crash.

I used the testscript and test tool from openoffice.org qa team , while not rhel5 openoffice-testtool. 
I tried to reproduce this problem but failed so far.  It is testing database tables. biblio.odb. Just use oowriter to open this database file and try to view all tables. 
Although I haven't been able to reproduce ,I found following error messages: 
** (soffice:14337): CRITICAL **: GdkPixbuf* bitmapToPixbuf(SalBitmap*, SalBitmap*): assertion `pBitmap->mnBitCount == 24' failed

I will continue to try to reproduce this problem.

--- Additional comment from caolanm@redhat.com on 2008-10-24 06:19:38 EDT ---

"** (soffice:14337): CRITICAL **: GdkPixbuf* bitmapToPixbuf(SalBitmap*,
SalBitmap*): assertion `pBitmap->mnBitCount == 24' failed" is known as rhbz#456845 and isn't too serious.

Otherwise I still don't have a mechanism with which to reproduce this problem, so I'll reset to NEEDINFO for now

--- Additional comment from yzhou@redhat.com on 2008-10-27 04:34:59 EDT ---

I just ran the automation test suite to test OOO-3.0 rawhide on F10, and it crash as well. Following are the backtrace output, do I need open another bug against Fedora? 
---------------------

(I)    x.org loaded video driver of...
(WW) AllowEmtpyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: not GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.3.2-6-i386
(VI)   kernel is: Linux 2.6.27.3-44.fc10.i686 #1 SMP Fri Oct 24 00:40:32 EDT 2008 i686 i686 i386
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-3.0.0-9.6.fc10-i386
(VIII) accessibility is: false
(IX)   fedora release is: Fedora release 9.92 (Rawhide)
(X)    LANG is: en_US.utf-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda2             48995912  14010148  32496896  31% /
/dev/sda2             48995912  14010148  32496896  31% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
IcedTea6 1.3.1 Runtime Environment (build 1.6.0_0-b12)
OpenJDK Server VM (build 1.6.0_0-b12, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x354d6c4: 0x1b4a38: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x256c4
0x354dfff: 0x1b4a38: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x25fff
0x110400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0x7f280e7: 0x2d5d4: /usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x1f0e7
0x7f17b70: 0x2d5d4: /usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0xeb70
0x7f18633: 0x2d5d4: /usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0xf633
0x7f1c4ee: 0x2d5d4: /usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x134ee
0x7f1ea63: 0x2d5d4: /usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x15a63
0x7f1ed30: 0x2d5d4: /usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x15d30
0x7f28f88: 0x2d5d4: /usr/lib/openoffice.org3/program/../basis-link/program/libuuili.so + 0x1ff88
0x43cfe2b: 0x7747c: /usr/lib/openoffice.org3/program/../basis-link/program/libfweli.so + 0x5fe2b (framework::PreventDuplicateInteraction::handle(com::sun::star::uno::Reference<com::sun::star::task::XInteractionRequest> const&) + 0xd5)
0x7f57509: 0x2d24c: /usr/lib/openoffice.org3/program/../basis-link/program/libfilterconfig1.so + 0x1f509
0x7f59a34: 0x2d24c: /usr/lib/openoffice.org3/program/../basis-link/program/libfilterconfig1.so + 0x21a34
0x81285d8: 0x1e528c: /usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd95d8
0x8128baf: 0x1e528c: /usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd9baf
0x8122eac: 0x1e528c: /usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd3eac
0x81231ae: 0x1e528c: /usr/lib/openoffice.org3/program/../basis-link/program/libfwkli.so + 0xd41ae
0x376f865: 0xe6fc4: /usr/lib/openoffice.org3/program/../basis-link/program/libcomphelp4gcc3.so + 0x8a865 (comphelper::SynchronousDispatch::dispatch(com::sun::star::uno::Reference<com::sun::star::uno::XInterface> const&, rtl::OUString const&, rtl::OUString const&, long, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 0x27d)
0x4530cd9: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0xaccd9
0x464bb45: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7b45
0x464c413: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c8413 (SfxDispatcher::Execute(unsigned short, unsigned short, unsigned short, SfxItemSet const&) + 0x109)
0x464c4bb: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c84bb (SfxDispatcher::Execute(unsigned short, unsigned short, SfxItemSet const&) + 0x29)
0x452f346: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0xab346
0x464bb45: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7b45
0x464be92: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7e92
0x4667da3: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e3da3
0x4667d59: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e3d59
0x3e12843: 0x2ebb8c: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x213843
0x386430: 0x65604: /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so + 0x46430 (SalDisplay::DispatchInternalEvent() + 0x96)
0x2ca0fc: 0x410f0: /usr/lib/openoffice.org/basis3.0/program/libvclplug_gtkli.so + 0x120fc
0x7222d1: 0xe1588: /lib/libglib-2.0.so.0 + 0x352d1
0x724208: 0xe1588: /lib/libglib-2.0.so.0 + 0x37208 (g_main_context_dispatch + 0x1e8)
0x7278b3: 0xe1588: /lib/libglib-2.0.so.0 + 0x3a8b3
0x727a71: 0xe1588: /lib/libglib-2.0.so.0 + 0x3aa71 (g_main_context_iteration + 0x71)
0x2ca1b4: 0x410f0: /usr/lib/openoffice.org/basis3.0/program/libvclplug_gtkli.so + 0x121b4
0x38cc49: 0x65604: /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so + 0x4cc49 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x3c9b981: 0x2ebb8c: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9c981 (Application::Yield(bool) + 0x57)
0x3c9b9cf: 0x2ebb8c: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9c9cf (Application::Execute() + 0x2b)
0x534f722: 0x51904: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x1e722
0x3c9efbb: 0x2ebb8c: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9ffbb
0x3c9f157: 0x2ebb8c: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0xa0157 (SVMain() + 0x2c)
0x536f6b0: 0x51904: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x3e6b0 (soffice_main + 0xd0)
0x80487c4: 0xccc: /usr/lib/openoffice.org3/program/swriter.bin + 0x7c4 (main + 0x20)
0x50b6d5: 0x16fd7c: /lib/libc.so.6 + 0x166d5 (__libc_start_main + 0xe5)
0x8048711: 0xccc: /usr/lib/openoffice.org3/program/swriter.bin + 0x711
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00110000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x004ef000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00158000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x001ed000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x0020a000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x0027d000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x002a7000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x002c4000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x002cf000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00347000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x0038d000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00420000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x0044f000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x00453000)
	librt.so.1 => /lib/librt.so.1 (0x00458000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00462000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00480000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x008d5000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00916000)
	libvclplug_genli.so => /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so (0x009f9000)
	libvclli.so => /usr/lib/openoffice.org/basis3.0/program/libvclli.so (0x00a66000)
	libpspli.so => /usr/lib/openoffice.org/basis3.0/program/libpspli.so (0x00d5a000)
	libsotli.so => /usr/lib/openoffice.org/basis3.0/program/libsotli.so (0x00e23000)
	libutlli.so => /usr/lib/openoffice.org/basis3.0/program/libutlli.so (0x00e71000)
	libtlli.so => /usr/lib/openoffice.org/basis3.0/program/libtlli.so (0x00ee0000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libcomphelp4gcc3.so (0x00f62000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libucbhelper4gcc3.so (0x02121000)
	libuno_cppuhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x02301000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppu.so.3 (0x01e51000)
	libvos3gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libvos3gcc3.so (0x01da1000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_sal.so.3 (0x03731000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x004c1000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x05c7f000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x04b8d000)
	libdl.so.2 => /lib/libdl.so.2 (0x04ac7000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x04c41000)
	libstlport_gcc.so => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libstlport_gcc.so (0x058a1000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x05b71000)
	libm.so.6 => /lib/libm.so.6 (0x03e2a000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x03d52000)
	libc.so.6 => /lib/libc.so.6 (0x04882000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x004c8000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x03cfa000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x0104c000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x02412000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x021a6000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x01051000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x01054000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x021ba000)
	libselinux.so.1 => /lib/libselinux.so.1 (0x03d70000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x040f7000)
	libz.so.1 => /lib/libz.so.1 (0x03cc8000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x03e57000)
	/lib/ld-linux.so.2 (0x004cc000)
	libnsl.so.1 => /lib/libnsl.so.1 (0x0105d000)
	libcap.so.2 => /lib/libcap.so.2 (0x02b2b000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x02b6a000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x02ce4000)
	libi18nisolang1gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libi18nisolang1gcc3.so (0x01077000)
	libbasegfxli.so => /usr/lib/openoffice.org/basis3.0/program/libbasegfxli.so (0x03167000)
	libicuuc.so.40 => /usr/lib/libicuuc.so.40 (0x044d8000)
	libicule.so.40 => /usr/lib/libicule.so.40 (0x03f21000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libjvmaccessgcc3.so.3 (0x03cbe000)
	libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x03c97000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x050ce000)
	libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x04cc9000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x04eeb000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x04cde000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x030b5000)
	libicudata.so.40 => /usr/lib/libicudata.so.40 (0xb7222000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x030e7000)
...end sample ldd details ...
-----------------

Meanwhile, this bug is mostly possible due to cann't open database according to the test result file:
------
Warning: database not open
Warning: error while open database
------

--- Additional comment from yzhou@redhat.com on 2008-10-27 04:39:00 EDT ---

Caolan,

This bug is really similar to this one: http://ubuntuforums.org/showthread.php?t=538912

But sorry for that I haven't been able to reproduce it manually.

--- Additional comment from yzhou@redhat.com on 2008-10-27 04:41:45 EDT ---

And I found these messages in result file:

1;~framework\first\inc\first.inc;294;19;45;"tDatabaseCheck"
4;~framework\first\inc\first.inc;296;4;65535;""
4;~framework\first\inc\first.inc;305;8;65535;"check if database is open"
5;~framework\first\inc\first.inc;320;12;65535;"Database not open"
5;~framework\first\inc\first.inc;324;8;65535;"error while open database."
4;~global\system\inc\master.inc;558;8;65535;"global::system::inc::PleaseRecover: No office running while trying to recover: "
Comment 1 Caolan McNamara 2008-10-28 06:11:28 EDT
How do I reproduce this. i.e.

"I just ran the automation test suite to test OOO-3.0 rawhide on F10, and it
crash as well. Following are the backtrace output, do I need open another bug
against Fedora?"

So, which automation test-suite, and how was it run. What are the steps I need to follow to launch the same test-suite the same way as you did ?
Comment 2 Yolkfull Chow 2008-10-28 06:22:26 EDT
Hi Caolan,
Please refer to https://bugzilla.redhat.com/show_bug.cgi?id=468136 comment #10 and comment #11, I had uploaded the test scripts which just test database of OOO.
Comment 3 Caolan McNamara 2008-10-29 10:31:07 EDT
Created attachment 321808 [details]
my ~/.testtoolrc
Comment 4 Caolan McNamara 2008-10-29 10:31:43 EDT
Created attachment 321809 [details]
the test basic from the other issue
Comment 5 Caolan McNamara 2008-10-29 10:38:09 EDT
So... here's what I did on rawhide

1> yum -y install openoffice.org-writer openoffice.org-calc openoffice.org-math openoffice.org-impress openoffice.org-draw openoffice.org-base openoffice.org-testtools
2> place the attachment in comment #3 and copied it to ~/.testtoolrc
3> cd /tmp
4> cvs -d:pserver:anoncvs@anoncvs.services.openoffice.org:/cvs co -P qa/qatesttool
5> cd qa and copied the attachment of #4 to /tmp/qa/testme.bas
6> ran /usr/lib64/openoffice.org/basis3.0/program/testtool.bin
7> open that testme.bas
8> program start
Comment 6 Caolan McNamara 2008-10-29 10:57:16 EDT
Created attachment 321813 [details]
here are my results
Comment 7 Caolan McNamara 2008-10-29 11:25:00 EDT
Program start: 29/10/2008; 14:39:38

...

**  All tests finished.
**  Start generating quaste database files.
 * - Status successfully created - * 
**  Writing status to database    : 0h 0m 2s

* - End of the test - *
Date : 29/10/2008   Time: 14:54:49

i.e. When using our own testtool binary, the HEAD qatesttool checkout, with the above rpms installed under GNOME I don't see a rawhide (x86_64 at least) during execution.
Comment 8 Caolan McNamara 2008-10-29 13:14:53 EDT
But if I rpm --erase openoffice.org-base then I can see it. Aha...
Comment 9 Caolan McNamara 2008-10-30 10:42:41 EDT
Screwed if I can see a way around the crash.

Clearly if base is installed, then we're ok. If the testtool script is changed to expect the Filter Dialog as a failure case and pop it down, then we would be ok. Its not possible in the UI to close OOo while a modal dialog is open, so it doesn't arise except in a scripted case like this.

So what I've done is to simply add all the components that are in the qatests as Requires on our own testtools package. So if we were using our own testtools rpm the requirements for base etc would have to be installed before it would install which should be good enough.

Longer term I've logged a bug upstream to see if there is any way we can handle the case inside OOo. Maybe a two stage event, dispatch cancel modal dialogs, and then dispatch close application window.

Note You need to log in before you can comment on or make changes to this bug.