Bug 468663 - kernel 2.6.27.5-117 breaks resume from suspend on T60
kernel 2.6.27.5-117 breaks resume from suspend on T60
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 05:59 EDT by Ferry Huberts
Modified: 2009-02-14 09:53 EST (History)
11 users (show)

See Also:
Fixed In Version: 2.6.27.12-170.2.5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-14 09:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ferry Huberts 2008-10-27 05:59:34 EDT
Description of problem:
kernel 2.6.26.6-79 breaks resume from suspend on T60. no binary ATI driver, using open driver.
going back to kernel 2.6.26.5-45 fixes the issue so the problem was introduced in the update from 45 to 79

Version-Release number of selected component (if applicable):
kernel-2.6.26.6-79

How reproducible:
always

Steps to Reproduce:
1. boot kernel 79 and login
2. suspend
3. try to resume
  
Actual results:
no resume

Expected results:
resume

Additional info:
Comment 1 Milos Jakubicek 2008-10-27 14:57:09 EDT
I have the same issue on FSC AmiloPro V3505 -- I never had problems with suspend/resume, but with this kernel the resume fails (only the LCD goes on, but nothing happens, even the SysRQ quirks don't work:) in most cases (about 75 %), whereas 2.6.26.5-45 works still fine. 
See my smolt profile here:
http://www.smolts.org/client/show/pub_bc0e2ea3-aa19-49f3-9439-b81881fb4a74
Comment 2 Gray Kimbrough 2008-10-27 23:08:56 EDT
I have the same problem on a Thinkpad T61; didn't have trouble with the previous kernel.  My smolt profile is:
http://www.smolts.org/show?uuid=pub_4fdc7b38-20fb-4776-b58b-0293a532fee0
Comment 3 Ferry Huberts 2008-10-28 03:33:29 EDT
my smolt profile is here:
http://www.smolts.org/client/show/pub_e03aca25-405b-4001-a9bb-0f8786d90fca
Comment 4 Joel Eidsath 2008-10-29 10:25:18 EDT
I'm seeing exactly the same issue on my Lenovo x61. The 2.6.26.6-79 kernel breaks resume after suspend.
Comment 5 Paul Bolle 2008-10-30 10:20:40 EDT
Me too spam here (since I want to add myself to the cc list anyway): IBM ThinkPad X41 (both suspend/resume and hibernate/thaw _seem_ to be troublesome in 2.6.26.6-79).

Please feel free to prod for further info.
Comment 6 Joel Eidsath 2008-10-30 10:30:14 EDT
To be a little more scientific about this, I just tried to suspend three times with the 2.6.26.6-79 kernel. It failed to resume each time, coming up with a cursor in the top left instead.

Then I booted into the last kernel, 2.6.26.5-45, and was able to suspend/resume fine each time.
Comment 7 Stephen Moehle 2008-11-02 16:52:49 EST
Same symptoms, but this time on a Dell Latitude D820 with nVidia GeForce Go 7400 graphics and the binary nVidia driver. Resume has never worked with the nv driver. Resume works with kernel 2.6.26.5-45 and fails with 2.6.26.6-79. Fedora 9 x86.

http://www.smolts.org/client/show/?uuid=pub_440f3aa2-9bf8-489d-91f5-c4a8e45c0dc5
Comment 8 Stephen Moehle 2008-11-03 01:07:02 EST
This issue is not present (resume works) in 2.6.27.4-19 from updates testing. At least it works for me.
Comment 9 Milos Jakubicek 2008-11-04 09:02:56 EST
I can confirm that 2.6.27.4-19 seems to work fine, I'll comment on the update.
Comment 10 Simo Sorce 2008-11-07 13:38:42 EST
I think this and 648627 maybe teh same bug.

When I try to resume since the last kernel update, initially the machine seem completely stuck, not reposnse even from pressing capslock/numlck etc, and I have the blinking cursor on upper left corner.

But if you wait long enough it eventually slowly comes up to speed, first you get to cranckly switch consoles, than at some point everything wakes up and X is resumed. All is fine then.

On my laptop it takes 5 minutes or more to go through the process.
When finally it comes up I see this in dmesg:

sd 0:0:0:0: [sda] 195371568 512-byte hardware sectors (100030 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 195371568 512-byte hardware sectors (100030 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
BUG: soft lockup - CPU#1 stuck for 187s! [events/1:20821]
Modules linked in: tun vfat fat usb_storage ipt_MASQUERADE iptable_nat nf_nat bridge bnep rfcomm l2cap bluetooth ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi autofs4 coretemp sunrpc nf_conntrack_netbios_ns ipt_REJECT nf_conntrack_ipv4 iptable_filter ip_tables ip6t_REJECT ip6t_ipv6header xt_tcpudp nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables cpufreq_ondemand acpi_cpufreq freq_table dm_multipath ipv6 uinput kvm_intel kvm snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss sr_mod cdrom i915 snd_mixer_oss snd_pcm video arc4 snd_timer ecb crypto_blkcipher thinkpad_acpi hwmon drm battery ac snd_page_alloc yenta_socket output iwl3945 rfkill iTCO_wdt i2c_i801 i2c_algo_bit e1000e snd_hwdep rsrc_nonstatic iTCO_vendor_support snd pata_acpi soundcore i2c_core mac80211 joydev pcspkr cfg80211 ata_piix ata_generic sg dm_snapshot dm_zero dm_mirror dm_log dm_mod ahci libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: scsi_wait_scan]
CPU 1:
Modules linked in: tun vfat fat usb_storage ipt_MASQUERADE iptable_nat nf_nat bridge bnep rfcomm l2cap bluetooth ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi autofs4 coretemp sunrpc nf_conntrack_netbios_ns ipt_REJECT nf_conntrack_ipv4 iptable_filter ip_tables ip6t_REJECT ip6t_ipv6header xt_tcpudp nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables cpufreq_ondemand acpi_cpufreq freq_table dm_multipath ipv6 uinput kvm_intel kvm snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss sr_mod cdrom i915 snd_mixer_oss snd_pcm video arc4 snd_timer ecb crypto_blkcipher thinkpad_acpi hwmon drm battery ac snd_page_alloc yenta_socket output iwl3945 rfkill iTCO_wdt i2c_i801 i2c_algo_bit e1000e snd_hwdep rsrc_nonstatic iTCO_vendor_support snd pata_acpi soundcore i2c_core mac80211 joydev pcspkr cfg80211 ata_piix ata_generic sg dm_snapshot dm_zero dm_mirror dm_log dm_mod ahci libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: scsi_wait_scan]
Pid: 20821, comm: events/1 Not tainted 2.6.26.6-79.fc9.x86_64 #1
RIP: 0010:[<ffffffff81033b3c>]  [<ffffffff81033b3c>] finish_task_switch+0x2d/0xba
RSP: 0018:ffff81007e811dd0  EFLAGS: 00000287
RAX: ffff81007f3d43e0 RBX: ffff81007e811df0 RCX: ffff81007f38d000
RDX: 0000000000000000 RSI: ffff81007f3d43e0 RDI: ffff810001025700
RBP: ffffffff8104c723 R08: ffff81007e810000 R09: 0000000000000000
R10: 0000000000000001 R11: ffff81007f3d93e8 R12: ffff81007e811d70
R13: 0000000000000000 R14: ffff8100010217c0 R15: ffff8100010217c8
FS:  0000000000000000(0000) GS:ffff81007f004780(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 0000000000000000 CR3: 0000000000201000 CR4: 00000000000026a0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400

Call Trace:
 [<ffffffff8129bc40>] ? thread_return+0x3d/0xc2
 [<ffffffff81047768>] ? queue_delayed_work+0x21/0x23
 [<ffffffff81047783>] ? schedule_delayed_work+0x19/0x1e
 [<ffffffff81046d74>] ? worker_thread+0xa9/0xee
 [<ffffffff8104a388>] ? autoremove_wake_function+0x0/0x38
 [<ffffffff81046ccb>] ? worker_thread+0x0/0xee
 [<ffffffff8104a05b>] ? kthread+0x49/0x76
 [<ffffffff8100d178>] ? child_rip+0xa/0x12
 [<ffffffff8104a012>] ? kthread+0x0/0x76
 [<ffffffff8100d16e>] ? child_rip+0x0/0x12

sd 0:0:0:0: [sda] Starting disk
PM: Finishing wakeup.
Restarting tasks ... done.



Hope this helps hunting down the problem.

Simo.
Comment 11 Ferry Huberts 2008-11-20 02:16:44 EST
kernel 2.6.27.5-37.fc9.x86_64 solves the problem for me
Comment 12 Ferry Huberts 2008-12-01 14:16:45 EST
upgraded T60 to F10:

kernel 2.6.27.5-117.fc10.x86_64 does suspend, but no resume.
hardware comes up, but software hangs.
Comment 13 Paul Bolle 2008-12-01 15:46:38 EST
(In reply to comment #12)
> kernel 2.6.27.5-117.fc10.x86_64 does suspend, but no resume.
> hardware comes up, but software hangs.

Doesn't this make this bug into a bit of a moving target? It started out as a bug for a specific kernel version for F9 and now this should be a bug for another kernel version for F10.

Wouldn't it be better to file a separate bug for that kernel version for F10 - perhaps with more info than just "hardware comes up, but software hangs"?
Comment 14 Simo Sorce 2008-12-01 16:48:34 EST
(In reply to comment #12)
> upgraded T60 to F10:
> 
> kernel 2.6.27.5-117.fc10.x86_64 does suspend, but no resume.
> hardware comes up, but software hangs.

Have you tried waiting for >= 5 minutes ?

Sometimes it seems to hang for me too, but if I wait long enough it eventually wakes up.

Not ideal, but would cast a different light.
Comment 15 Ferry Huberts 2008-12-01 17:33:08 EST
yes I did wait, read your other comment.

and to paul bolle:
no need to get all worked up. my comment was just a quick note. and if you know how to debug resume problems then please let me know and I'll oblige. and if you want a new report for f10 then please go ahead and file it. otherwise keep your snappy remarks to yourself please.
Comment 16 Ferry Huberts 2008-12-01 17:38:18 EST
when i switch to a vt first and then do a echo 3 > /proc/acpi/sleep then it _does_ resume but the video is all garbled up. switching to the x server after resume hangs the machine.
I have an X1400 card with the ati driver. maybe dave airlie can help out here?
Comment 17 Paul Bolle 2008-12-01 18:05:52 EST
(In reply to comment #15)
> my comment was just a quick note. 

While adding that comment you also changed the product's version and the summary.
Comment 18 Ferry Huberts 2008-12-02 11:07:44 EST
there were some updates pending and after applying i'm seeing that resume does work, but the screen/video is all garbled and does not come back. switching vt's does not help. i can enter my password after resume and some things happen. pressing the power button results in a clean/normal shutdown. 

using nomodeset on the kernel line in grub solve the problem

KMS for radeon is to blame appearently...
Comment 19 Noel J. Bergman 2008-12-09 14:04:09 EST
(In reply to comment #12)
> upgraded T60 to F10:
> 
> kernel 2.6.27.5-117.fc10.x86_64 does suspend, but no resume.
> hardware comes up, but software hangs.

I am running kernel 2.6.27.5-117 on a T61p and resume from suspend works just fine, with the exception of Bug 475585.

Which video driver are you using?  For example, those of us with nvidia chips know that we must use real nvidia drivers, since the open source drivers cannot handle suspend/resume (amongst other lacks).
Comment 20 Ferry Huberts 2008-12-09 14:11:53 EST
my updated smolt profile:
http://www.smolts.org/client/show/pub_e03aca25-405b-4001-a9bb-0f8786d90fca
Comment 21 Ferry Huberts 2008-12-09 14:20:37 EST
aha, somehow smolt thinks that I use fglrx but I use the OSS ati driver.
Comment 22 Milos Jakubicek 2009-02-14 09:53:40 EST
I'm closing this for now, please comment/reopen if you still experience a regression in this from 2.6.26 to 2.6.27.

Note You need to log in before you can comment on or make changes to this bug.