Bug 468673 - rt73usb: Cold plugged USB device often does not work
rt73usb: Cold plugged USB device often does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 07:52 EDT by Remy Maucherat
Modified: 2009-02-10 09:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 09:33:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System log for the failed association (7.21 KB, text/plain)
2008-10-27 07:52 EDT, Remy Maucherat
no flags Details

  None (edit)
Description Remy Maucherat 2008-10-27 07:52:23 EDT
Created attachment 321606 [details]
System log for the failed association

Description of problem:
Device ID 06f8:e010 Guillemot Corp. HWGUSB2-54-LB, which uses the rt73usb driver, often fails to associate with an access point if it was already plugged in when the computer is started.


Version-Release number of selected component (if applicable):
F9 (2.6.26-79 i686 4 core) and rawhide (F10 snap 3)
ID 06f8:e010 Guillemot Corp. HWGUSB2-54-LB

How reproducible:
About 50%.

Steps to Reproduce:
1. Plug device and start computer
2. Attempt to associate with an access point
3.

Actual results:
See attached log

Expected results:
Association works and wifi is usable.

Additional info:
Device works properly on Windows XP. Workaround is to unplug the device and hotplug it.
Comment 1 Ivo van Doorn 2008-11-11 12:36:55 EST
Hmm. what seems to be happening is that network manager starts talking to rt73, and suddenly the USB host decides that the hardware is gone.

This is either due to either sending an incorrect signal to the device, or bashing register values into the device. In both cases rt73usb (and rt2500usb) are known to simply shutdown immediately, and forcing the user to reinsert the device.

I'll try to find out what NetworkManager is actually doing when it prints:
NetworkManager: <info>  (wlan0): supplicant connection state change
Comment 2 Bug Zapper 2008-11-25 23:17:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 John W. Linville 2009-02-09 16:08:00 EST
Does this continue to happen with current rawhide kernels?
Comment 4 Remy Maucherat 2009-02-10 06:57:04 EST
It appears to be fixed with kernel-2.6.29-0.22.rc4.git1.fc10 so the rt73usb stick should now be reliable.
However, my rt2500usb stick no longer works with this new kernel (it associates with the access point very quickly, but the DHCP times out). Do you want a bugzilla about this ?
Comment 5 John W. Linville 2009-02-10 09:33:55 EST
Sure, please do.  In the meantime, I'll close this one.

Note You need to log in before you can comment on or make changes to this bug.