Bug 468706 - Evolution does not honor Page Setup page size, only locale setting
Evolution does not honor Page Setup page size, only locale setting
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On: 527099
Blocks: 743405 1002709
  Show dependency treegraph
 
Reported: 2008-10-27 11:30 EDT by Richard Monk
Modified: 2013-10-06 21:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:33:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (8.15 KB, application/octet-stream)
2009-10-06 03:09 EDT, ritz
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 540282 None None None Never

  None (edit)
Description Richard Monk 2008-10-27 11:30:02 EDT
Description of problem:
When printing, Evolution will ignore any printer settings or the configuration in File->Page Setup as to the paper size.  It will use the paper size dictated by the locale.


Version-Release number of selected component (if applicable):
evolution-2.12.3-8.el5_2.2

How reproducible:
Change the paper size away from your locales default (print to A4 with en_US for example)

Steps to Reproduce:
1. File->Page Setup
2. Set en_US system to A4
3. Print email
  
Actual results:
Printout is set to Letter size

Expected results:
Printout is set to A4 size

Additional info:

if you set LC_PAPER="POSIX", you can get A4 paper in en_US locale.  This is more evidence that it is using the locale data.
Comment 1 Matthew Barnes 2008-10-27 12:10:26 EDT
This was subsequently fixed upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=540282
Comment 4 ritz 2009-10-06 03:09:27 EDT
Created attachment 363782 [details]
patch based on upstream code
Comment 8 RHEL Product and Program Management 2010-08-09 15:38:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-05-31 11:12:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2011-09-22 20:42:44 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2012-06-11 21:27:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 Andrius Benokraitis 2013-10-06 21:33:42 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.