Bug 468752 - OpenJDK IcedTea plugin applet fails to initialize: a "fatal error occurred while trying to verify jars"
OpenJDK IcedTea plugin applet fails to initialize: a "fatal error occurred wh...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 15:54 EDT by P Rauser
Modified: 2008-11-26 13:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 13:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Rauser 2008-10-27 15:54:53 EDT
Description of problem:

OpenJDK with IcedTea plugin fails to initialize webstart applet.  Console output follows.

Version-Release number of selected component (if applicable):

java-1.6.0-openjdk-1.6.0.0-1.1.b12.fc10
java-1.6.0-openjdk-plugin-1.6.0.0-1.1.b12.fc10

Steps to Reproduce:
1.  Navigate to site with signed applet (occurs for me on Juniper SSL VPN)
2.  Status bar indicates that applet is starting
3.  Applet does not initialize, but hangs instead.
  
Actual results:

Applet hangs.

Expected results:

Applet launches & runs.

Additional info from console:

ICEDTEAPLUGIN_DEBUG = (null)
Initializing JVM...
NOT IMPLEMENTED: virtual nsresult IcedTeaPluginInstance::Start()
Jar string: hc_launcher.6.2.0.13527.jar
jars length: 1
JNLPRuntime already initialized
java.lang.NullPointerException
	at net.sourceforge.jnlp.tools.JarSigner.verifyJars(JarSigner.java:192)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.verifyJars(JNLPClassLoader.java:609)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:302)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:134)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:191)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:445)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
netx: Initialization Error: Could not initialize applet. (net.sourceforge.jnlp.LaunchException Fatal: Initialization Error: A fatal error occurred while trying to verify jars.)
netx: Initialization Error: Could not initialize applet. (net.sourceforge.jnlp.LaunchException Fatal: Initialization Error: A fatal error occurred while trying to verify jars.)
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet.
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:472)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:308)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:134)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:191)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:445)
	... 2 more
Caused by: 
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:308)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:134)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:191)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:445)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
IcedTeaPlugin.cc:3809: Error: Failed to flush bytes to output channel: Broken pipe
Comment 1 Deepak Bhole 2008-11-14 15:46:06 EST
Can you provide the address of a page where this is reproducible?
Comment 2 Bug Zapper 2008-11-25 23:19:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 P Rauser 2008-11-26 13:53:27 EST
Bug resolved in build java-1.6.0-openjdk-1.6.0.0-6.b12.fc10

Note You need to log in before you can comment on or make changes to this bug.