Bug 468761 - [RHEL5.3] Can't install new kernel on ppc systems with Beta tree
[RHEL5.3] Can't install new kernel on ppc systems with Beta tree
Status: CLOSED DUPLICATE of bug 466848
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
ppc64 Linux
medium Severity high
: rc
: ---
Assigned To: Peter Jones
Mike Gahagan
http://rhts.redhat.com/testlogs/33788...
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 16:43 EDT by Jeff Burke
Modified: 2010-03-14 17:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On PPC platform, if you want to yum-update the kernel rpm post-beta, then you need to manually update the yaboot.conf file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 11:27:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-10-27 16:43:14 EDT
Description of problem:
We were trying to test a new kernel for post beta. When using yum upgrade to update the kernel yaboot.conf was never updated with the new kernel information.

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20081020.1

How reproducible:
Always

Steps to Reproduce:
1. Install a ppc system with RHEL5.3-Server-20081020.1
2. Try to install DonZ test kernel 
http://drseuss.usersys.redhat.com/~dzickus/dist-cvs-repos/kernel-2.6.18-120.el5dz_test2
  
Actual results:
***** Start of kernel install test *****
***** Install kernel via yum kernel-2.6.18-120.el5dz_test2.ppc64 *****
This system is not registered with RHN.
RHN support will be disabled.
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package kernel.ppc64 0:2.6.18-120.el5dz_test2 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package      Arch        Version                      Repository          Size
================================================================================
Installing:
 kernel       ppc64       2.6.18-120.el5dz_test2       rhts-custom1        19 M

Transaction Summary
================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 19 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

  Installing     : kernel                                            [1/1] 

Installed: kernel.ppc64 0:2.6.18-120.el5dz_test2
Complete!
This system is not registered with RHN.
RHN support will be disabled.
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package kernel-devel.ppc64 0:2.6.18-120.el5dz_test2 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package          Arch      Version                      Repository        Size
================================================================================
Installing:
 kernel-devel     ppc64     2.6.18-120.el5dz_test2       rhts-custom1     4.8 M

Transaction Summary
================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 4.8 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

  Installing     : kernel-devel                                      [1/1] 

Installed: kernel-devel.ppc64 0:2.6.18-120.el5dz_test2
Complete!
***** Attempting to switch boot kernel to (2.6.18-120.el5dz_test2) *****
image=/vmlinuz-2.6.18-120.el5
# yaboot.conf generated by anaconda

boot=/dev/hda1
init-message=Welcome to Red Hat Enterprise Linux Server!\nHit <TAB> for boot options

partition=2
timeout=80
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
nonvram
fstype=raw

image=/vmlinuz-2.6.18-120.el5
	label=linux
	read-only
	initrd=/initrd-2.6.18-120.el5.img
	root=/dev/VolGroup00/LogVol00
	append="console=hvc0"

***** End of kernel install test *****
4831414
/distribution/kernelinstall/rhts-reboot result: PASS
   metric: 0
   Log: /tmp/tmp.FL2816
/4831530
distribution/kernelinstall/kernel-2.6.18-120.el5 result: FAIL
   metric: 1
   Log: /tmp/tmp.FL2816
   DMesg: /tmp/dmesg.log

Expected results:
yaboot.conf should have been updated.

Additional info:
If I run this test with the 0814.0 it works fine.
If I use the 1020.1 beta tree it fails.
Comment 1 Linda Wang 2008-10-27 16:59:44 EDT
"possible" related fix that may have caused this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=426992

just fyi..
Comment 2 Linda Wang 2008-10-28 08:56:25 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
On PPC platform, if you want to yum-update the kernel rpm post-beta, then you need to manually update the yaboot.conf file.
Comment 3 Peter Jones 2008-10-29 11:27:37 EDT

*** This bug has been marked as a duplicate of bug 466848 ***

Note You need to log in before you can comment on or make changes to this bug.