Bug 468781 - Repomd* (re)generation should be spawned for rhnpush or sat-sync operations in addition to client check-ins
Repomd* (re)generation should be spawned for rhnpush or sat-sync operations i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
511
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
: FutureFeature
: 488330 (view as bug list)
Depends On: 494593
Blocks: 456985 456995 472052 483875 485807 491021
  Show dependency treegraph
 
Reported: 2008-10-27 18:58 EDT by Xixi
Modified: 2010-10-23 01:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 491021 (view as bug list)
Environment:
Last Closed: 2009-09-10 14:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spacewalk-debug (5.40 MB, application/x-bzip)
2009-04-07 10:07 EDT, wes hayutin
no flags Details

  None (edit)
Description Xixi 2008-10-27 18:58:58 EDT
Description of problem:

Per discussion with Prad, currently we spawn the repomd generation for channels only when yum update/install/list etc. is run from client, where it checks in with the server, sees if the cache is there, if so fetches the pkg, and if not server spawns the generation.  The repomd generation is not spawned for rhnpush or satsync operations, which would be useful, at least for sat-sync as there usually is a number of updates.  

Version-Release number of selected component (if applicable):
Multiple, latest is 5.1.1.

How reproducible:
Always.

Steps to Reproduce:
1. See description.
2.
3.
  
Actual results:
See description.

Expected results:
See description.

Additional info:
Comment 9 wes hayutin 2009-04-07 10:01:58 EDT
taking this bug
Comment 10 wes hayutin 2009-04-07 10:04:52 EDT
this does not appear to be working..

basic recreate:
1. install satellite
2. sat sync channel from an exported dump
3. check repomd level.. 
I see rhnmd-5.0.0-8.el5.i386.rpm

4. now sat sync from hosted webqa
the sat sync pulls down rhnmd-5.1.7-1.el5sat

looking at the repomd.xml file on the sat server..
me>rhnmd</name><arch>i386</arch><version ver="5.0.0" rel="8.el5" epoch="0"/><checksum type="md5" pkgid="Y
ES">08312b5b62c0c6d666cb93d3f60547e7</checksum><summary>Red Hat Network Monitoring Daemon
</summary><description>rhnmd package for use with the RHN Monitoring Scout.
This package enables secure ssh-based communication between the monitoring
scout and the monitored host.
</description><packager/><url/><time file="1180039444" build="1180039444"/><size package="8100" archive="7056" i
nstalled=""/><location href="getPackage/rhnmd-5.0.0-8.el5.i386.rpm"/><format><rpm:license>GPL</rpm:license><rpm:
vendor>Red Hat, Inc.</rpm:vendor><rpm:group>System Environment/Daemons </rpm:group><rpm:buildhost>ls20-bc2-14.bu
ild.redhat.com</rpm:buildhost><rpm:sourcerpm>rhnmd-5.0.0-8.el5.src.rpm</rpm:sourcerpm><rpm:header-range start="4
40" end="5152"/><rpm:provides><rpm:entry name="config(rhnmd)" flags="EQ" epoch="0" ver="5.0.0" rel="8.el5"/><rpm
:entry name="librhnmdwrap.so"/><rpm:entry name="rhnmd" flags="EQ" epoch="0" ver="5.0.0" rel="8.el5"/></rpm:provi
des><rpm:requires><rpm:entry name="/bin/sh"/><rpm:entry name="/bin/sh"/><rpm:entry name="/bin/sh"/><rpm:entry na
me="/bin/sh"/><rpm:entry name="rtld(GNU_HASH)"/><rpm:entry name="libc.so.6"/><rpm:entry name="rpmlib(CompressedF
ileNames)" flags="LE" epoch="0" ver="3.0.4" rel="1"/><rpm:entry name="libc.so.6(GLIBC_2.1.3)"/><rpm:entry name="
/bin/bash"/><rpm:entry name="rpmlib(PayloadFilesHavePrefix)" flags="LE" epoch="0" ver="4.0" rel="1"/><rpm:entry 
name="openssh-server"/><rpm:entry name="openssh"/><rpm:entry name="config(rhnmd)" flags="EQ" epoch="0" ver="5.0.
0" rel="8.el5"/></rpm:requires><rpm:conflicts><rpm:entry name="NPusers"/></rpm:conflicts><rpm:obsoletes/><file>/
etc/pam.d/rhnmd</file><file>/usr/sbin/rhnmd</file><file>/usr/sbin/rhnmd-wrap</file><file>/etc/init.d/rhnmd</file
></format></package><package type="rpm"><name>rhn-kickstart</name><arch>noarch</arch><version ver="2.0.10" rel="
10.el5" epoch="0"/><checksum type="md5" pkgid="YES">04c8724c94ecc0ef8a7addf0d526dc3d</che


so I think this fails.
Comment 11 wes hayutin 2009-04-07 10:07:17 EDT
Created attachment 338508 [details]
spacewalk-debug
Comment 14 wes hayutin 2009-04-07 10:54:52 EDT
spoke w/ prad.. the issue documented in comment #10 is valid and a problem.  I'll test out the other scenarios in comment #13
Comment 15 wes hayutin 2009-04-07 10:59:35 EDT
To elaborate a little more here.
Basically w/o the repomd file getting updated, the customer can see a package at a certain level in the webui.  When the customer tries to install that package they will actually install a different older version of the package.

The package version we display in the webui has to equal what we will install on a client.
Comment 16 wes hayutin 2009-04-07 11:22:57 EDT
prad would like to take the issue in comment #10 and open a new bug
I will verify his steps #13 in this bug.
Comment 18 wes hayutin 2009-04-23 11:41:30 EDT
SQL> select * from rhnRepoRegenQueue;

        ID
----------
CHANNEL_LABEL
--------------------------------------------------------------------------------
CLIENT
--------------------------------------------------------------------------------
REASON
--------------------------------------------------------------------------------
F B NEXT_ACTI CREATED   MODIFIED
- - --------- --------- ---------
      5974
westest01
server.app.channelPackageSubscription

        ID
----------
CHANNEL_LABEL
--------------------------------------------------------------------------------
CLIENT
--------------------------------------------------------------------------------
REASON
--------------------------------------------------------------------------------
F B NEXT_ACTI CREATED   MODIFIED
- - --------- --------- ---------
testAutoFile-2-1.0.i386.rpm testAutoFile-2-1.0.i386.rpm testAutoFile-2-1.0.i386.
rpm testAutoFile-2-1.0.i386.rpm testAutoFile-2-1
N N           23-APR-09 23-APR-09

        ID
----------
CHANNEL_LABEL
--------------------------------------------------------------------------------
CLIENT
--------------------------------------------------------------------------------
REASON
--------------------------------------------------------------------------------
F B NEXT_ACTI CREATED   MODIFIED
- - --------- --------- ---------


SQL> select * from rhnRepoRegenQueue;

no rows selected

SQL>
Comment 19 wes hayutin 2009-04-23 11:42:15 EDT
[root@grandprix westest01]# ls
filelists.xml.gz.new  other.xml.gz.new  primary.xml.gz.new
[root@grandprix westest01]# ls
filelists.xml.gz.new  other.xml.gz.new  primary.xml.gz.new
[root@grandprix westest01]# ls
filelists.xml.gz  other.xml.gz  primary.xml.gz  repomd.xml
Comment 20 wes hayutin 2009-04-23 12:01:58 EDT
SQL> select * from rhnRepoRegenQueue;

        ID
----------
CHANNEL_LABEL
--------------------------------------------------------------------------------
CLIENT
--------------------------------------------------------------------------------
REASON
--------------------------------------------------------------------------------
F B NEXT_ACTI CREATED   MODIFIED
- - --------- --------- ---------
      5975
redhat-rhn-proxy-5.3-server-x86_64-5
satsync.linkPackagesToChannels

        ID
----------
[root@grandprix repodata]# cd redhat-rhn-proxy-5.3-server-x86_64-5
[root@grandprix redhat-rhn-proxy-5.3-server-x86_64-5]# ls
filelists.xml.gz.new  other.xml.gz.new  primary.xml.gz.new
[root@grandprix redhat-rhn-proxy-5.3-server-x86_64-5]# ls
filelists.xml.gz.new  other.xml.gz.new  primary.xml.gz.new
[root@grandprix redhat-rhn-proxy-5.3-server-x86_64-5]# ls
filelists.xml.gz  other.xml.gz  primary.xml.gz  repomd.xml
[root@grandprix redhat-rhn-proxy-5.3-server-x86_64-5]#
Comment 21 Pradeep Kilambi 2009-06-01 09:57:50 EDT
*** Bug 488330 has been marked as a duplicate of this bug. ***
Comment 24 Dave Parker 2009-08-13 21:20:15 EDT
satellite-sync case fails

Error: Cannot open/read repomd.xml file for repository: rhel-i386-server-hts-5
Comment 27 Miroslav Suchý 2009-08-17 03:56:29 EDT
I still fully do not agree with solution commented in #23, but this is not issue for this BZ neither for this release.
It works in stage.
Comment 28 Brandon Perkins 2009-09-10 14:40:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.