Bug 468782 - SELinux is preventing bluetoothd (bluetooth_t) "sys_resource" bluetooth_t.
SELinux is preventing bluetoothd (bluetooth_t) "sys_resource" bluetooth_t.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 18:59 EDT by Matěj Cepl
Modified: 2008-10-29 16:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 16:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-10-27 18:59:35 EDT
Souhrn:

SELinux is preventing bluetoothd (bluetooth_t) "sys_resource" bluetooth_t.

Podrobný popis:

SELinux denied access requested by bluetoothd. It is not expected that this
access is required by bluetoothd and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Další informace:

Kontext zdroje                system_u:system_r:bluetooth_t
Kontext cíle                 system_u:system_r:bluetooth_t
Objekty cíle                 None [ capability ]
Zdroj                         bluetoothd
Cesta zdroje                  /usr/sbin/bluetoothd
Port                          <Neznámé>
Počítač                    viklef
RPM balíčky zdroje          bluez-4.16-1.fc10
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.5.13-8.fc10
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Enforcing
Název zásuvného modulu     catchall
Název počítače            viklef
Platforma                     Linux viklef 2.6.27.4-47.rc3.fc10.i686 #1 SMP Sat
                              Oct 25 00:21:53 EDT 2008 i686 i686
Počet upozornění           1
Poprvé viděno               Po 27. říjen 2008, 22:53:09 CET
Naposledy viděno             Po 27. říjen 2008, 22:53:09 CET
Místní ID                   1c8b41a4-78af-48d5-9235-4f9fda1b97af
Čísla řádků              

Původní zprávy auditu      

node=viklef type=AVC msg=audit(1225144389.313:212): avc:  denied  { sys_resource } for  pid=4354 comm="bluetoothd" capability=24 scontext=system_u:system_r:bluetooth_t:s0 tcontext=system_u:system_r:bluetooth_t:s0 tclass=capability

node=viklef type=SYSCALL msg=audit(1225144389.313:212): arch=40000003 syscall=102 success=yes exit=0 a0=2 a1=bfa7aaf0 a2=b7f7b1bc a3=bfa7ab3a items=0 ppid=1 pid=4354 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="bluetoothd" exe="/usr/sbin/bluetoothd" subj=system_u:system_r:bluetooth_t:s0 key=(null)
Comment 1 Bastien Nocera 2008-10-27 21:00:43 EDT
Errors messages in Czech don't help me.
Comment 3 Matěj Cepl 2008-10-28 17:45:19 EDT
Well, the best what I can do for you:

[matej@viklef ~]$ cat /tmp/tmpalert.txt 
node=viklef type=AVC msg=audit(1225144389.313:212): avc:  denied { sys_resource } for  pid=4354 comm="bluetoothd" capability=24 scontext=system_u:system_r:bluetooth_t:s0 tcontext=system_u:system_r:bluetooth_t:s0 tclass=capability

node=viklef type=SYSCALL msg=audit(1225144389.313:212): arch=40000003 syscall=102 success=yes exit=0 a0=2 a1=bfa7aaf0 a2=b7f7b1bc a3=bfa7ab3a items=0 ppid=1 pid=4354 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="bluetoothd" exe="/usr/sbin/bluetoothd" subj=system_u:system_r:bluetooth_t:s0 key=(null)
[matej@viklef ~]$ audit2why< /tmp/tmpalert.txt
node=viklef type=AVC msg=audit(1225144389.313:212): avc:  denied { sys_resource } for  pid=4354 comm="bluetoothd" capability=24 scontext=system_u:system_r:bluetooth_t:s0 tcontext=system_u:system_r:bluetooth_t:s0 tclass=capability

	Was caused by:
		Missing type enforcement (TE) allow rule.

		You can use audit2allow to generate a loadable module to allow this access.

[matej@viklef ~]$ audit2allow< /tmp/tmpalert.txt


#============= bluetooth_t ==============
allow bluetooth_t self:capability sys_resource;
[matej@viklef ~]$
Comment 4 Matěj Cepl 2008-10-29 05:39:34 EDT
(In reply to comment #1)
> Errors messages in Czech don't help me.

bug 468970
Comment 5 Daniel Walsh 2008-10-29 12:27:50 EDT
ext4?
Comment 6 Matěj Cepl 2008-10-29 16:04:56 EDT
Shut, this one too? OK, committing suicide.

Note You need to log in before you can comment on or make changes to this bug.