This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468822 - Assertion from boost variant visitation
Assertion from boost variant visitation
Status: CLOSED DUPLICATE of bug 471247
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity urgent
: 1.1
: ---
Assigned To: Andrew Stitcher
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 05:19 EDT by Gordon Sim
Modified: 2008-11-13 07:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 07:33:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-10-28 05:19:18 EDT
Pasted from email from freznice@redhat.com

A triggered this after two thirds of a day running on dell-pe830-01.rhts.bos.redhat.com, RHEL51_x86_64
MRG was build from trunk on 'Oct 23 10:11' Boston timezone

There are already three observations of this issue one one on RHEL5.1 and the other two on RHEL4.7, packages are stored in:
mrg5.lab.bos.redhat.com:/root/qpid_test_kolchak_RHEL51_x86_64_failures.tar.bz2
mrg5.lab.bos.redhat.com:/root/qpid_test_kolchak_FAILURE_VALGRIND_RHEL47_x86_64.tar.bz2
mrg5.lab.bos.redhat.com:/root/qpid_test_kolchak_FAILURE_RHEL47_x86_64.tar.bz2

see tail of qpid_test_kolchak/qpidd.log file

Shorten log of last observation:
2008-oct-23 18:30:29 warning SASL: No Authentication Performed
qpidd: /usr/include/boost/variant/detail/visitation_impl.hpp:203: typename Visitor::result_type boost::detail::variant::visitation_impl(int, int,
Visitor&, VPCV, mpl_::true_, NBF, W*, S*) [with W = mpl_::int_<20>, S = boost::detail::variant::visitation_impl_step<boost::mpl::l_iter<boost::mpl
::l_end>, boost::mpl::l_iter<boost::mpl::l_end> >, Visitor = boost::detail::variant::destroyer, VPCV = void*, NBF = boost::variant<qpid::TcpAddres
s, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::vari
ant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::det
ail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, b
oost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant::void_, boost::detail::variant:
:void_>::has_fallback_type_]: Assertion `false' failed.

It might be problem in boost, but if I have right now 2 independent observations on RHEL4.7 (boost 1.35) and RHEL5.1 (boost 1.33)...we most probably need to look what it cases...
http://www.google.com/search?num=100&hl=en&q=visitation_impl.hpp%3A+typename+Visitor%3A%3Aresult_type&btnG=Search
Comment 1 Gordon Sim 2008-10-30 07:26:48 EDT
Also tracked by https://issues.apache.org/jira/browse/QPID-1414
Comment 2 Gordon Sim 2008-11-13 07:33:12 EST
Caused by concurrent modifcation of brokers known url list.

*** This bug has been marked as a duplicate of bug 471247 ***

Note You need to log in before you can comment on or make changes to this bug.