Bug 468906 - fence_wti returns Status: PROBLEM where there is no problem
fence_wti returns Status: PROBLEM where there is no problem
Status: CLOSED DUPLICATE of bug 468904
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 14:46 EDT by Dean Jansa
Modified: 2009-04-16 18:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 11:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2008-10-28 14:46:25 EDT
Description of problem:

fence_wti seems to be confused by the state of the device.  Everything seems A-OK yet fence_wti -o status returns 'Status: PROBLEM'

[root@z1 ~]# fence_wti  -a zwti -l wti -p password -n 1 -o status
Status: PROBLEM

[root@z1 ~]# fence_wti -v -a zwti -l wti -p password -n 1 -o status
Trying 10.15.89.23...
Connected to zwti.
Escape character is '^]'.
login: wti

Password: 


LOCAL - Managed Power Controller      Site ID: MSP Z Cluster Rack               

PLUG |           NAME           | STATUS | BOOT DELAY | DEFAULT | PRIORITY 
-----+--------------------------+--------+------------+---------+----------
 A1  | zflea                    |  ON    |    5 Secs  |   ON    |    1    |
 A2  | Local_InfeedA_Outlet2    |  ON    |    5 Secs  |   ON    |    2    |
 A3  | Local_InfeedA_Outlet3    |  ON    |    5 Secs  |   ON    |    3    |
 A4  | Local_InfeedA_Outlet4    |  ON    |    5 Secs  |   ON    |    4    |
 B1  | Local_InfeedB_Outlet1    |  ON    |  0.5 Secs  |   ON    |    5    |
 B2  | Local_InfeedB_Outlet2    |  ON    |  0.5 Secs  |   ON    |    6    |
 B3  | Local_InfeedB_Outlet3    |  ON    |  0.5 Secs  |   ON    |    7    |
 B4  | Local_InfeedB_Outlet4    |  ON    |  0.5 Secs  |   ON    |    8    |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
* = Plug in BUSY state

Enter /H for command menu.
MPC> /S

LOCAL - Managed Power Controller      Site ID: MSP Z Cluster Rack               

PLUG |           NAME           | STATUS | BOOT DELAY | DEFAULT | PRIORITY 
-----+--------------------------+--------+------------+---------+----------
 A1  | zflea                    |  ON    |    5 Secs  |   ON    |    1    |
 A2  | Local_InfeedA_Outlet2    |  ON    |    5 Secs  |   ON    |    2    |
 A3  | Local_InfeedA_Outlet3    |  ON    |    5 Secs  |   ON    |    3    |
 A4  | Local_InfeedA_Outlet4    |  ON    |    5 Secs  |   ON    |    4    |
 B1  | Local_InfeedB_Outlet1    |  ON    |  0.5 Secs  |   ON    |    5    |
 B2  | Local_InfeedB_Outlet2    |  ON    |  0.5 Secs  |   ON    |    6    |
 B3  | Local_InfeedB_Outlet3    |  ON    |  0.5 Secs  |   ON    |    7    |
 B4  | Local_InfeedB_Outlet4    |  ON    |  0.5 Secs  |   ON    |    8    |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
     |                          |        |            |         |         |
* = Plug in BUSY state


MPC>
Status: PROBLEM


Version-Release number of selected component (if applicable):

cman-2.0.94-1.el5

fence_wti -V
2.0.94 (built Mon Sep 29 17:24:15 EDT 2008)

WTI MPC Firmware version: Version 1.40
Comment 1 Marek Grac 2008-10-29 10:56:52 EDT
I believe that this is the correct behaviour. There is no such thing as port '1' and if we are not able to find a port it should be a problem. Fence agent works with port 'A1'
Comment 2 Marek Grac 2008-10-29 11:48:33 EDT
Bug #468904 point to same problem - get status does not work, but set status works.

*** This bug has been marked as a duplicate of bug 468904 ***

Note You need to log in before you can comment on or make changes to this bug.