Bug 468936 - No prompt for passphrase for LUKS disk encryption
No prompt for passphrase for LUKS disk encryption
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 19:15 EDT by eric@christensenplace.us
Modified: 2008-11-13 10:29 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 10:29:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2008-10-28 19:15:49 EDT
Description of problem: When starting the system, there is no prompt to enter a passphrase to unlock the LUKS partition.  The system appears to load (the white bar will go all the way across the screen) but will go no further.


Version-Release number of selected component (if applicable): 2.6.27.4-58.fc10.i686


How reproducible: Always


Steps to Reproduce:
1. Boot computer
2. Use the 2.6.27.4-58.fc10.i686 kernel

  
Actual results: System attempts to load the system but fails.


Expected results: System should prompt for a passphrase to unlock the LUKS partition.


Additional info:
Comment 1 Oleg Girko 2008-10-29 21:15:37 EDT
This bug is related to bug #468887.
Comment 2 Brian Jedsen 2008-10-31 13:00:36 EDT
I have this very problem, it appears the install hooks to make the initrd work aren't. The relevant kernel modules are not loaded and the plymouth passphrase/cryptsetup lines are missing from the initrd, as if the install process missed that the system is encrypted.
Comment 3 eric@christensenplace.us 2008-11-05 07:44:49 EST
I think this has been fixed in the latest kernel release.
Comment 4 Peter Reuschlein 2008-11-05 07:55:51 EST
yes, problem seems to be fixed within the last update
Comment 5 eric@christensenplace.us 2008-11-13 10:29:18 EST
Done.

Note You need to log in before you can comment on or make changes to this bug.