Bug 468979 - openoffice menu bar contains some item without any title on it
openoffice menu bar contains some item without any title on it
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Tardon
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 06:59 EDT by Vivian Bian
Modified: 2008-10-30 09:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 09:52:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The situation in oocalc (47.46 KB, image/png)
2008-10-29 07:00 EDT, Vivian Bian
no flags Details
situation in ooimpress (1) (60.33 KB, image/png)
2008-10-29 07:01 EDT, Vivian Bian
no flags Details
situation in ooimpress (2) (64.67 KB, image/png)
2008-10-29 07:01 EDT, Vivian Bian
no flags Details
situation in ooimpress (3) (31.24 KB, image/png)
2008-10-29 07:02 EDT, Vivian Bian
no flags Details
situation in ooimpress (4) (53.89 KB, image/png)
2008-10-29 07:03 EDT, Vivian Bian
no flags Details
situation in oowriter (41.04 KB, image/png)
2008-10-29 07:03 EDT, Vivian Bian
no flags Details
situation in oowriter on my installation (43.34 KB, image/png)
2008-10-29 07:58 EDT, David Tardon
no flags Details

  None (edit)
Description Vivian Bian 2008-10-29 06:59:59 EDT
Description of problem:
After start up the openoffice in KDE with the Chinese(simple) configuration,the openoffice menu bar contains some item without any title on it.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.5-10.6.0.5.EL4
openoffice.org-libs-1.1.5-10.6.0.5.EL4
openoffice.org-i18n-1.1.5-10.6.0.5.EL4
Red Hat Enterprise Linux AS release 4 (Nahant Update 7) 
kernel:2.6.9-78.12.ELsmp x86_64

How reproducible:
Always

Steps to Reproduce:
1.login the system with any locale as you like
2.go to the "system configuration" Menu item and choose the language
3.choose the Chinese (P.R. of china)简体中文
4.log out the system
5.relog in the system with KDE environment
6.start up one openoffice tool (oowriter for example)  
Actual results:
openoffice menu bar contains some item without any title on it

Expected results:
all the menu item has its own title full displayed on it

Additional info:
other language (Janpanese -日本語) also tested and have the same problem exist
Comment 1 Vivian Bian 2008-10-29 07:00:49 EDT
Created attachment 321779 [details]
The situation in oocalc
Comment 2 Vivian Bian 2008-10-29 07:01:32 EDT
Created attachment 321780 [details]
situation in ooimpress (1)
Comment 3 Vivian Bian 2008-10-29 07:01:57 EDT
Created attachment 321781 [details]
situation in ooimpress (2)
Comment 4 Vivian Bian 2008-10-29 07:02:42 EDT
Created attachment 321782 [details]
situation in ooimpress (3)
Comment 5 Vivian Bian 2008-10-29 07:03:06 EDT
Created attachment 321783 [details]
situation in ooimpress (4)
Comment 6 Vivian Bian 2008-10-29 07:03:31 EDT
Created attachment 321784 [details]
situation in oowriter
Comment 7 Caolan McNamara 2008-10-29 07:16:49 EDT
The 1.1.X series is really old now, it may be a difficulty with font and glyph substitution or bad translations. Probably glyph substitution. Do you see any such problems in RHEL-5 ?
Comment 8 David Tardon 2008-10-29 07:35:41 EDT
Seems to be OK in RHEL 5.3 .
Comment 9 David Tardon 2008-10-29 07:58:01 EDT
Created attachment 321792 [details]
situation in oowriter on my installation

And in RHEL 4.7 as well.
Comment 10 David Tardon 2008-10-29 08:42:32 EDT
dtardon->vbian: You can be missing some fonts. What's result of running
rpm -qa | grep font
in terminal? What says
rpm -V openoffice.org-langpack-zh_CN
? If everything is OK here, it's probably some OOo<->KDE incompatibility.
Comment 11 Vivian Bian 2008-10-29 21:43:36 EDT
vbian->dtardon: Here is my results after executing the two commands:
[root@dhcp-66-70-28 ~]# rpm -qa|grep font
fontconfig-2.2.3-13.el4
liberation-fonts-1.0-1.el4
fonts-xorg-75dpi-6.8.2-1.EL
ttfonts-zh_TW-2.11-28
fontconfig-devel-2.2.3-13.el4
fonts-xorg-cyrillic-6.8.2-1.EL
fonts-hebrew-0.100-4
bitmap-fonts-cjk-0.3-4
fonts-xorg-ISO8859-2-75dpi-6.8.2-1.EL
ghostscript-fonts-5.50-13
ttfonts-ta-1.10-1.EL
xorg-x11-font-utils-6.8.2-1.EL.52
fonts-ISO8859-2-75dpi-1.0-13
ttfonts-gu-1.10-1.EL
fonts-KOI8-R-75dpi-1.0-7
fonts-xorg-truetype-6.8.2-1.EL
urw-fonts-2.2-6.1
bitmap-fonts-0.3-4
fonts-xorg-100dpi-6.8.2-1.EL
ttfonts-zh_CN-2.14-6
ttfonts-bn-1.10-1.EL
ttfonts-pa-1.10-1.EL
fonts-xorg-ISO8859-15-100dpi-6.8.2-1.EL
fonts-xorg-base-6.8.2-1.EL
fonts-ISO8859-2-1.0-13
fonts-KOI8-R-100dpi-1.0-7
ttfonts-ja-1.2-36.EL4.0
fonts-bengali-0.1-3
fonts-xorg-ISO8859-14-75dpi-6.8.2-1.EL
fontconfig-2.2.3-13.el4
bitstream-vera-fonts-1.10-4
fonts-xorg-ISO8859-9-100dpi-6.8.2-1.EL
ttfonts-ko-1.0.11-32.2
ttfonts-hi-1.10-1.EL
fonts-xorg-ISO8859-2-100dpi-6.8.2-1.EL
taipeifonts-1.2-26
fonts-arabic-1.5-3
fonts-xorg-ISO8859-15-75dpi-6.8.2-1.EL
tetex-fonts-2.0.2-22.0.1.EL4.10
fonts-ISO8859-2-100dpi-1.0-13
fonts-xorg-syriac-6.8.2-1.EL
fonts-xorg-ISO8859-9-75dpi-6.8.2-1.EL
chkfontpath-1.10.0-2
fonts-KOI8-R-1.0-7
fonts-ja-8.0-16
fonts-xorg-ISO8859-14-100dpi-6.8.2-1.EL
[root@dhcp-66-70-28 ~]# rpm -V openoffice.org-langpack-zh_CN
並未安裝套件 openoffice.org-langpack-zh_CN

But,in the GNOME environment,the OOo could display the menu bar well.
Comment 12 David Tardon 2008-10-30 04:38:32 EDT
I'm confirming the problem on RHEL 4.7 using KDE. On RHEL 5.3 it's OK.
Comment 13 David Tardon 2008-10-30 09:04:56 EDT
Fix for the problem is following: go to Tools->Options->Openoffice.org->Accessibility and unset "Use system font for user interface".

dtardon->caolanm: I think we can close it as NOTABUG with that, can't we?
Comment 14 Caolan McNamara 2008-10-30 09:35:23 EDT
There have been a massive amount of improvements to fontconfig glyph and font substitution since 1.1.X as in RHEL-5 and afterwards. I don't think it makes a lot of sense to invest time in this one. i.e. 1.1.X on RHEL-4 under KDE.
Comment 15 RHEL Product and Program Management 2008-10-30 09:52:15 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.