Bug 468992 - *.la files in MinGW packages report "script-without-shebang"
*.la files in MinGW packages report "script-without-shebang"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 07:58 EDT by Richard W.M. Jones
Modified: 2009-09-09 11:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 11:41:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2008-10-29 07:58:50 EDT
MinGW package guidelines were approved recently:

http://fedoraproject.org/wiki/Packaging/MinGW

MinGW packages may contain *.la (libtool linker scripts),
contrary to the normal practice for Fedora packages.  This
is because they are required for libtool to be able to link
Windows binaries.

rpmlint gives a rather unexpected error here.  As an example:

mingw32-libjpeg.noarch: E: script-without-shebang /usr/i686-pc-mingw32/sys-root/mingw/lib/libjpeg.la
(bug 467401).

(Libtool also installs these files as 0755 - whether this
is required or not I am not sure, it may be a bug in libtool
or there may be some reason behind it).
Comment 1 Bug Zapper 2008-11-25 23:25:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Richard W.M. Jones 2009-09-09 11:41:51 EDT
Closing - rpmlint no longer reports this as a problem.

Note You need to log in before you can comment on or make changes to this bug.