Bug 469004 - Resume from Suspend issues with Fedora 10 (beta)
Resume from Suspend issues with Fedora 10 (beta)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 09:29 EDT by Noel J. Bergman
Modified: 2008-11-11 18:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 12:12:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noel J. Bergman 2008-10-29 09:29:04 EDT
Description of problem:

Suspend works.  Resume works with the following reproducible caveats:

  1) I have to resume 3 times.  The first two attempts begin to wake, and then immediately go back to sleep.  The third time stays awake.  It does not appear to matter if the wake is caused by opening the lid, hitting the Fn key or hitting the power key.

  2) The gnome password dialog accepts credentials, but hangs.  Again, this is reproducible.  I have to switch to a console, kill (-HUP is sufficient) the dialog, switch back to the X11 screen, and the re-issued dialog works fine.


Version-Release number of selected component (if applicable):

Fedora 10, all daily updates installed.  nVidia 177.80 native driver installed and working properly.


How reproducible:

Very.


Steps to Reproduce:
Actual results:
Expected results:

See detailed description, above.


Additional info:

ThinkPad T61p 6457-7WU

You tell me what would be helpful, since this has been easily reproducible.
Comment 1 Dave Jones 2008-11-11 12:12:44 EST
if you're using the nvidia binary driver, there's nothing we can do to help. You'll need to report the bug to nvidia.
Comment 2 Noel J. Bergman 2008-11-11 18:48:08 EST
> if you're using the nvidia binary driver

If one is not using the nvidia driver, suspend/resume doesn't work at all, since your "supported" open source drivers are broken and do not support suspend and resume.

> there's nothing we can do to help.

There is a difference between cannot and will not.  You can communicate with nvidia, just as Canonical does.  You just *choose* not to do so.

Keep in mind that suspend and resume work fine with Ubuntu 8.10 using the same driver, so it does not appear that it is the driver to blame.

Note You need to log in before you can comment on or make changes to this bug.