Bug 469024 - xorg is slow and unresponsive, and fills up memory and swap
xorg is slow and unresponsive, and fills up memory and swap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 10:59 EDT by Espen Stefansen
Modified: 2008-10-31 14:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 20:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (34.09 KB, text/plain)
2008-10-29 12:11 EDT, Yanko Kaneti
no flags Details
Xorg.0.log (95.64 KB, text/plain)
2008-10-29 13:48 EDT, Espen Stefansen
no flags Details

  None (edit)
Description Espen Stefansen 2008-10-29 10:59:04 EDT
Description of problem:
After i updated my machine with xorg packages the last 4-5 days, xorg has gotten slow and unresponsive. Everything seems sluggish. Xorg usually takes about 20% CPU and often maxes out when opening/closing, maximizing/minimizing programs or push programs to the foreground. If i play music as well, the music stop at times because xorg takes 100% CPU. For instance, if i take a program to the foreground it takes about 4 seconds to show, the same time to minimize. Or just change tabs in Opera, takes seconds. Much slower than a week ago. 

If the screensaver is on, memory increases dramatically. I have 2GB RAM and 2GB swap, and during the night i think both of them have filled up and closed my xorg session, cos the next morning i see the gdm-screen.



Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-34.fc10.i386
xorg-x11-server-common-1.5.2-10.fc10.i386
xorg-x11-server-utils-7.4-3.fc10.i386
xorg-x11-server-Xorg-1.5.2-10.fc10.i386
kernel-2.6.27.4-61.fc10.i686

How reproducible:
All the time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2008-10-29 11:56:10 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Yanko Kaneti 2008-10-29 12:11:38 EDT
Created attachment 321818 [details]
Xorg log

I can confirm the observation that somewhere after(not including) xorg-x11-drv-ati-6.9.0-29.fc10.i386 X started leaking quite noticeably. Growing to ~1GB RSS in a few hours of normal usage. log attached. No xorg.conf file
Comment 3 Espen Stefansen 2008-10-29 13:48:05 EDT
Created attachment 321833 [details]
Xorg.0.log

I do not use a xorg.conf. 

And since i reported this, i've upgraded to: 
xorg-x11-drv-ati-6.9.0-36.fc10.i386
kernel-2.6.27.4-65.fc10.i686
Comment 4 Yanko Kaneti 2008-10-30 03:36:03 EDT
leak successfully plugged here by xorg-x11-drv-ati-6.9.0-37.fc10.i386
Comment 5 Matěj Cepl 2008-10-30 18:44:08 EDT
*** Bug 469242 has been marked as a duplicate of this bug. ***
Comment 6 Dave Airlie 2008-10-30 20:24:46 EDT
Fixed in xorg-x11-drv-ati-6.9.0-37.fc10
Comment 7 Espen Stefansen 2008-10-31 14:24:28 EDT
It looks like i reported two problems in one. The new ati-driver fixed the memory and swap filling up. But xorg is still extremely slow. Putting a program like evolution in the foreground takes seconds, xorg takes 100% cpu and if i play music, it starts and stops all the time. Xorg is actually using lots of cpu for the slightest thing.

If i should file a new bug, let me know.

Note You need to log in before you can comment on or make changes to this bug.