Bug 469026 - muine 0.8.9-1 gnome-sharp dependancy problem
muine 0.8.9-1 gnome-sharp dependancy problem
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: muine (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 11:26 EDT by trevik
Modified: 2008-12-21 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 18:38:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description trevik 2008-10-29 11:26:48 EDT
Description of problem:

Dependancy of ghome-sharp is not included in the rpm.

Additionally even, if rawhide gnome-sharp is installed (2.24.0-1.fc10) muine doesn't run, because it cannot find the assemby, neither in GAC, neither as a .dll (is it muine problem of dll search path or mono/gnome-sharp problem?)

setting 
MONO_PATH=/usr/lib/mono/gtk-sharp-2.0
helps

Version-Release number of selected component (if applicable):
0.8.9-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:

$ muine 

** (/usr/lib/muine/muine.exe:4245): WARNING **: The following assembly referenced from /usr/lib/muine/muine.exe could not be loaded:
     Assembly:   gnome-sharp    (assemblyref_index=7)
     Version:    2.20.0.0
     Public Key: 35e10195dab3c99f
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/lib/muine).


** (/usr/lib/muine/muine.exe:4245): WARNING **: Could not load file or assembly 'gnome-sharp, Version=2.20.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' or one of its dependencies.
The entry point method could not be loaded


Expected results:


Additional info:
Comment 1 Bug Zapper 2008-11-25 23:26:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Sindre Pedersen Bjørdal 2008-12-02 07:41:03 EST
This appears to be fixed in latest update: https://admin.fedoraproject.org/updates/muine-0.8.10-2.fc10

Can you please confirm?
Comment 3 Gianluca Sforna 2008-12-16 03:15:01 EST
just tested muine-0.8.10-3.fc10 from updates-testing and this problem is fixed, though the program is still unusable for reasons I'm investigating...

Note You need to log in before you can comment on or make changes to this bug.