Bug 469034 - client should handle the arch information if sent down from server instead of jus comparing NVRE
client should handle the arch information if sent down from server instead of...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.9
All Linux
medium Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
Jeff Browning
: FutureFeature
Depends On:
Blocks: 469719
  Show dependency treegraph
 
Reported: 2008-10-29 12:13 EDT by Pradeep Kilambi
Modified: 2009-05-18 16:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:13:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-10-29 12:13:11 EDT
Description of problem:

up2date by default seems to ignore the arch information for packages while installing/updating/scheduled actions. This is due to the fact that server never sent down arch info. But once we have the server sent down arch, look slike the client seems to ignore the data and still take into account only the NVRE.

possible changes would be in wrapper.py, u2dateBatch.py and rhnPackageInfo.py
Comment 14 Jeff Browning 2009-04-07 00:13:04 EDT
Verified.

The above test cases have been verified.

In addition, Prad's diff test has also been verified.
Comment 16 errata-xmlrpc 2009-05-18 16:13:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0972.html

Note You need to log in before you can comment on or make changes to this bug.