Bug 469067 - System Set channel manipulation without org admin status: Permission Denied.
System Set channel manipulation without org admin status: Permission Denied.
Status: CLOSED DUPLICATE of bug 467945
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
511
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Sayli Karmarkar
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-10-29 14:37 EDT by Jeremy Hallum
Modified: 2009-08-18 03:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 15:59:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Hallum 2008-10-29 14:37:17 EDT
Description of problem:

If a user attempts to switch a group of machines from channel to channel via the system set interface without Org Admin permissions gets a 'permission denied screen.  When the user is given Org Admin status, the channel manipulation tool works correctly, and a user is able to move machines from channel to channel


Version-Release number of selected component (if applicable):5.1.1


How reproducible: Always


Steps to Reproduce:
1.Create a system set of machines with a user with all permissions except org admin status and satellite admin status.
2.in the page: network/systems/ssm/index.pxt, click on the Manage systems' channel memberships link.
3.
  
Actual results: User gets a Permission denied page.


Expected results:User should get the page: rhn/channel/ssm/ChildSubscriptions.do
which allows the user to Alter subscriptions for each machine.  

Additional info:If user is given org admin privileges, they are able to do the task as expected.
Comment 1 Clifford Perry 2008-11-20 12:52:33 EST
Going to have a review. I wonder if this is a user needs group admin rights to perform this action. Obviously maybe we should not display the page to then hit the permission denied page.
Comment 2 Shannon Hughes 2008-12-11 15:59:11 EST
this fix has been made in spacewalk 0.4 as #468302

*** This bug has been marked as a duplicate of bug 468302 ***
Comment 3 Brandon Perkins 2009-08-18 02:41:08 EDT
Closed as a duplicate of the wrong bug.  It should be bug 467945

*** This bug has been marked as a duplicate of bug 467945 ***

Note You need to log in before you can comment on or make changes to this bug.