Bug 46907 - Upgrade to kernel 2.4.3 kills midi for Crystal sound car
Upgrade to kernel 2.4.3 kills midi for Crystal sound car
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 21:32 EDT by Leonard Evens
Modified: 2007-03-26 23:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-01 21:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard Evens 2001-07-01 21:32:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-12 i686; en-US; rv:0.9.1)
Gecko/20010608

Description of problem:
I am running RH7.1 on a VALinux Varstation 27.  Sound worked
properly under the 2.4.2-2 kernel.  After upgrading to
kernel 2.4.3-12, the midi configuration of my sound card
failed.  



How reproducible:
Always

Steps to Reproduce:
1. Reboot
2.  Run sndconfig
3.
	

Actual Results:  I can illustrate this by telling what happens
when I run sndconfig.

Sndconfig reports it found CS4236B:Ctrl

In /var/log/messages, the following appears:

Jul 1 19:36:35 localhost kernel: cs4232: set synthio and synthirq to use
the wavefront facilities.


It then tells me it will play a sound, which I do hear
and then it tells me it will play a midi sound. But
instead it responds with

/lib/modules/2.4.3-12/kernel/drivers/sound/opl3.o:
init_module: No such device
/lib/modules/2.4.3-12/kernel/drivers/sound/opl3.o: insmod
/lib/modules/2.4.3-12/kernel/drivers/sound/opl3.o failed
/lib/modules/2.4.3-12/kernel/drivers/sound/opl3.o: insmod
synth0 failed

At the same time, /var/log/messages reports

Jul 1 19:39:41 localhost kernel: YM3812 and OPL-3 driver Copyright (C) by
Hannu Savolainen, Rob Hooft 1993-1996
Jul 1 19:39:41 localhost kernel: OPL3 not detected ff

It then takes me through a manual configuration, but the
same things happen.

I tried other possible sound card settings, but nothing worked.

As I noted above, this all worked with 2.4.2-2.

Expected Results:  Proper configuration of the sound card.  Under 2.4.3-12
I get the following entries in modules.conf

alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options cs4232 isapnp=1

Under 2.4.2, I got

alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options cs4232 io=0x534 irq=5 dma=1 dma2=0 mpuio=0x330 mpuirq=10

Additional info:
Comment 1 Leonard Evens 2001-07-02 13:53:50 EDT
Further analysis shows that sound is actually working, but not as before.

I was misled because realplay didn't work, but it started working after I
started esd sound under gnome.  It was a question of how realplay was
configured.  I was also misled because apparently
the uart401 module is no longer using irq10.

Here is what modules.conf shows (after apparently being configured during
boot under 2.4.3)

alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options cs4232 isapnp=1

Here is what lsmod shows relevant to sound

ad1848 17200 0 [cs4232]
uart401 6128 0 [cs4232]
sound 54528 0 [cs4232 ad1848 uart401]
soundcore 3600 4 [sound]

What doesn't work is sndconfig, as noted before.  But perhaps that was
because sound was already configured by the kernel.  I have the
package sndconfig-0.64.8-1. 

Note You need to log in before you can comment on or make changes to this bug.