Bug 46909 - Unable to allocate IRQ for cardbus on Thinkpad 760XL
Unable to allocate IRQ for cardbus on Thinkpad 760XL
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 23:17 EDT by Rupa Schomaker
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 03:05:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rupa Schomaker 2001-07-01 23:17:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)

Description of problem:
When trying to use a cardbus based network card (3com 578 based I think) 
on a Thinkpad 760XD laptop I get an error about being unable to allocate 
an IRQ.  The network card does not work.  If I use a 16bit PCMCIA card 
then everything seems to work.


I've tried setting pci=biosirq and it has no affect (still tries to 
allocate IRQ 0) other than not saying to try biosirq.


How reproducible:
Always

Steps to Reproduce:
1.plug in cardbus nic card
2.
3.
	

Actual Results:  Logs:
Jun 30 13:37:02 fw kernel: PCI: Enabling device 01:00.0 (0000 -> 0003)
Jun 30 13:37:02 fw kernel: PCI: No IRQ known for interrupt pin A of device 
01:00.0. Please try using pci=biosirq.
Jun 30 13:37:02 fw cardmgr[549]: initializing socket 0
Jun 30 13:37:02 fw cardmgr[549]: socket 0: 3Com 3c575-TX Fast EtherLink XL
Jun 30 13:37:02 fw cardmgr[549]: executing: 'modprobe cb_enabler'
Jun 30 13:37:03 fw cardmgr[549]: executing: 'modprobe 3c59x'
Jun 30 13:37:03 fw kernel: PCI: No IRQ known for interrupt pin A of device 
01:00.0. Please try using pci=biosirq.
Jun 30 13:37:03 fw kernel: 3c59x.c:LK1.1.13 27 Jan 2001  Donald Becker and 
others. http://www.scyld.com/network/vortex
.html
Jun 30 13:37:03 fw kernel: See Documentation/networking/vortex.txt
Jun 30 13:37:03 fw kernel: eth0: 3Com PCI 3c575 Boomerang CardBus at 
0x1000, PCI: Setting latency timer of device 01:0
0.0 to 64
Jun 30 13:37:03 fw kernel:  00:10:4b:60:6c:56, IRQ 0
Jun 30 13:37:03 fw kernel:  *** Warning: IRQ 0 is unlikely to work! ***
Jun 30 13:37:03 fw kernel:   product code 4e53 rev 06.0 date 06-11-98
Jun 30 13:37:03 fw kernel:   8K word-wide RAM 3:5 Rx:Tx split, 
autoselect/MII interface.
Jun 30 13:37:03 fw kernel:   MII transceiver found at address 0, status 
7809.
Jun 30 13:37:03 fw kernel:   Enabling bus-master transmits and whole-frame 
receives.
Jun 30 13:37:03 fw kernel: eth0: scatter/gather enabled. h/w checksums 
disabled
Jun 30 13:37:03 fw cardmgr[549]: executing: './network start 3c59x'
Jun 30 13:37:04 fw /etc/hotplug/net.agent: register event not handled
Jun 30 13:37:05 fw pumpd[1046]: starting at (uptime 0 days, 0:02:25) Sat 
Jun 30 13:37:05 2001  
Jun 30 13:37:05 fw kernel: eth0: Could not reserve IRQ 0
Jun 30 13:37:05 fw last message repeated 2 times
Jun 30 13:37:05 fw dhcpcd[1047]: dhcpStart: ioctl SIOCSIFFLAGS: Device or 
resource busy 
Jun 30 13:37:43 fw cardmgr[549]: executing: './network check 3c59x'
Jun 30 13:37:43 fw cardmgr[549]: shutting down socket 0
Jun 30 13:37:43 fw cardmgr[549]: executing: './network stop 3c59x'
Jun 30 13:37:43 fw cardmgr[549]: + usage: ifdown <device name>
Jun 30 13:37:43 fw cardmgr[549]: stop cmd exited with status 1
Jun 30 13:37:43 fw cardmgr[549]: executing: 'modprobe -r 3c59x'
Jun 30 13:37:43 fw cardmgr[549]: executing: 'modprobe -r cb_enabler'
Jun 30 13:37:44 fw kernel: cs: cb_free(bus 1)
Jun 30 13:37:44 fw /etc/hotplug/pci.agent: PCI remove event not supported



Expected Results:  it should work

Additional info:
Comment 1 Need Real Name 2001-08-27 00:43:37 EDT
I am experiencing the same problem on the Thinkpad 765D.
I have tried using the 2.4.9 kernel and it makes no difference.
When PC Cards are inserted into the machine, the card is recognized 
by the system.  However, because the IRQ is set to 0 (the timer) 
it is impossible for events from the PC Cards to be delivered to the
drivers.

Performing a search through the archives of the linux-kernel mailing
list shows similar complaints on a variety of systems going back to
November 2000.  However, I can find no solutions to the problem.
The recommendation to append pci=biosirq removes the advisory 
message, but that is about it.

Is there a config file that I can modify to specify an IRQ to be used?

Any other suggestions?


Note You need to log in before you can comment on or make changes to this bug.