Bug 469112 - Please put the X server back on tty7 by default
Please put the X server back on tty7 by default
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 19:02 EDT by Dax Kelson
Modified: 2008-10-31 02:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 00:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2008-10-29 19:02:43 EDT
Description of problem:

Have plymouth start the X server on tty7. As more and more drivers get KMS this will not cause any flicker, the time to switch VTs (without a mode switch) should not even be measurable. On systems without KMS, you already had a flicker and that won't change here.

This way both camps of people can be happy and eat cake!

Reasoning:

* The change violates the Principle of Least Surprise. The default behavior of X on tty7 has been in place since the beginning (almost a decade and a half). Long standing behaviors and defaults should not be changed unless there is a VERY good reason with a significant upside. Since we still have shiny fast boot while keeping the X server on tty7 we should do that.

* Fedora (and presumably RHEL6) now behaves differently from all the
major distributions. This fractures the user community, creating
separate pockets of knowledge and experience for each system. If you were able to get the other major distros do come to agreement on a new defacto standard, this reason would disappear.

* The "exception to the rule" (such as this one) dramatically increases
the costs of cross-distribution support and training. It turns 300-page books into 1000-page books. Similarly one must remember and commit to memory all
the "exceptions" and swap them in and out of your mental working set as
needed.

* Fedora is now inconsistent with itself in regards to where X is
running depending on if you booted to runlevel 3 and used startx or if
you booted to runlevel 5. When your uptime is 3 weeks, how do you
remember which method you used to start the GUI? Likewise getting back to X when you are in a text terminal is no longer deterministic. Using trial and error to find the X server is regression compared to the being to the find the X server on tty7 (remember, we are talking about default configurations).

* This specific Linux behavior is well documented in hundreds of
thousand of publications ranging from college text books, HOWTOs, Linux
books sold in retail stores, blogs, forums, guides, and training
manuals. Making a change invalidates all that published and institutional knowledge.

* Having tty1 be the user's "primary console" (as mentioned in BZ
465547) is not a worthy goal as desktop (GUI only) users should not and
do not care what tty X is on.

* Experienced users will try CONTROL-ALT-F1 and nothing will happen, the
first thing that comes to mind is "something is broke". This speaks to the Principal of Least Surprise.

* When using fast user switching, the X TTYS are no longer contiguous. Likewise if you are running 4 X servers, you would presumably want them at VT7 .. VT10, and not randomly scattered at VT1, VT9, VT12, etc.

* There is no need to make the change. We can still have the new shiny faster boot while keeping X on tty7.

See the discussion on fedora-devel:

http://thread.gmane.org/gmane.linux.redhat.fedora.devel/96255
http://thread.gmane.org/gmane.linux.redhat.fedora.devel/96076
Comment 1 Will Woods 2008-10-30 00:16:38 EDT
You emailed a version of this list to me personally yesterday; I answered some questions but did not indicate any intent to revert the change. 

Today you emailed an updated version of that list to fedora-devel-list. Some key points from the ensuing, endless email thread:

- We are frozen for F10 and thus not making any major changes,
- This change was planned and documented over a year and a half ago,
- This change was approved by FESCo two and a half months ago:
  * http://bpepple.fedorapeople.org/fesco/FESCo-2008-08-06.html
- This change has documented benefits, including:
  * Speeding up boot times, and
  * Less screen flickering at startup for most users.
- This change has been further reviewed, without objection, by:
  * The Fedora QA lead,
  * The Fedora Release Engineering lead,
  * The maintainer of the kernel tty layer, 
  * One of the original authors of the X Windowing System,
  * The current X.org release manager, and
  * The entire Fedora Desktop team,
  among others.

Ignoring all this, you've now filed a bug - not with any sort of improvement over the current FESCo-approved peer-reviewed plan - just: "No, don't make this change, I don't care what anyone else has said, here are the same reasons that we've already discussed." 

This is not helpful. This behaviour makes the Fedora community a more hostile place, where change is resisted at all costs and arguments are won not by whoever has the best plan, but by whoever talks the most. 

Here's what you should do: Come up with a *better* plan and propose it for F11. (It's only ~3 months to Fedora 11 Alpha!) You're a member of a community. Get people involved. Work together with your peers to make things better, rather than working against a good plan because you disagree with one tiny part of it.

Otherwise you're just wasting time that could be spent fixing *real* problems in Fedora 10 - or planning for F11. That doesn't help anyone.
Comment 2 Dax Kelson 2008-10-30 01:41:38 EDT
(In reply to comment #1)
> You emailed a version of this list to me personally yesterday; I answered some
> questions but did not indicate any intent to revert the change. 
> 
> Today you emailed an updated version of that list to fedora-devel-list. Some
> key points from the ensuing, endless email thread:
> 
> - We are frozen for F10 and thus not making any major changes,
> - This change was planned and documented over a year and a half ago,
> - This change was approved by FESCo two and a half months ago:
>   * http://bpepple.fedorapeople.org/fesco/FESCo-2008-08-06.html
> - This change has documented benefits, including:
>   * Speeding up boot times, and
>   * Less screen flickering at startup for most users.
> - This change has been further reviewed, without objection, by:
>   * The Fedora QA lead,
>   * The Fedora Release Engineering lead,
>   * The maintainer of the kernel tty layer, 
>   * One of the original authors of the X Windowing System,
>   * The current X.org release manager, and
>   * The entire Fedora Desktop team,
>   among others.

This is very misleading at best. Sure everyone agreed to wanting better shiny faster bootup, however, I can see no documentation where it was plainly stated "We will move X from tty7 to tty1". That is an important implementation detail not widely communicated or known. This is evidenced by the mailing list discussion, blogs, news stories that came out today.

It's exactly analogous a half page rider attached to a 1000 page defense appropriation bill and 99% of the legislators don't know what they are voting for. 

> Ignoring all this, you've now filed a bug - not with any sort of improvement
> over the current FESCo-approved peer-reviewed plan - just: "No, don't make this
> change, I don't care what anyone else has said, here are the same reasons that
> we've already discussed." 
> 
> This is not helpful. This behaviour makes the Fedora community a more hostile
> place, where change is resisted at all costs and arguments are won not by
> whoever has the best plan, but by whoever talks the most. 

This is a mischaracterization. In fact it is pretty ironic considering that just about the exact opposite happened (including your comments on who talks the most).

Proponents of this change responded with personal and straw man attacks ignored the technical arguments and refused to discuss the X tty change issue in good faith.

In any case a filed bug report is appropriate as bugzilla is where people going to go when this change surprises them.
Comment 3 Dan Horák 2008-10-31 02:32:51 EDT
Because I think it is technically possible to allow the old setup (where X goes to vt7) to work, can you publish somewhere instructions what to change/set to keep it?

Note You need to log in before you can comment on or make changes to this bug.