Bug 469146 - rpm -V fails after upgrade. Missing *.pyc files
rpm -V fails after upgrade. Missing *.pyc files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kickstart (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 03:43 EDT by Alexander Todorov
Modified: 2009-01-20 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-30 03:43:23 EDT
Description of problem:
rpm -V fails after upgrade. Missing .pyc files

Version-Release number of selected component (if applicable):
system-config-kickstart-2.6.19.8-1.el5.noarch.rpm  	

How reproducible:
Always

Steps to Reproduce:
1. on a 5.2 system install system-config-kickstart
2. upgrade to 5.3 version of system-config-kickstart
3.
  
Actual results:
/usr/share/system-config-kickstart/*.pyc files are removed

Expected results:
Files are updated

Additional info:
The rpm package contains this scriptlet

preuninstall scriptlet (using /bin/sh):
if [ -d /usr/share/system-config-kickstart ] ; then
  rm -rf /usr/share/system-config-kickstart/*.pyc
fi


Additionally the .pyc files don't appear in the %files section in the spec file. The spec file doesn't seem to fully conform to https://fedoraproject.org/wiki/Packaging/Python
Comment 2 Chris Lumens 2008-10-30 10:54:27 EDT
Simple to fix, assuming we can still fix these sorts of things for 5.3.
Comment 3 Alexander Todorov 2008-10-30 11:43:02 EDT
Chris,
system-config-samba had the same issue and they removed the offending script in the 5.3 package. However this will probably need to be release noted.
Comment 5 Chris Lumens 2008-10-31 14:12:06 EDT
This should be fixed in system-config-kickstart-2.6.19.8-2.
Comment 7 Alexander Todorov 2008-11-07 11:29:45 EST
s-c-kickstart is fixed now but the issue is in the older version. 

yum remove system-config-kickstart && yum install-system-config-kickstart makes it verify again. 

Does this need a release note?
Comment 9 errata-xmlrpc 2009-01-20 17:06:08 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0228.html

Note You need to log in before you can comment on or make changes to this bug.