Bug 469148 - rpm -V fails after upgrade. Missing *.pyc files
rpm -V fails after upgrade. Missing *.pyc files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-samba (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nils Philippsen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 03:52 EDT by Alexander Todorov
Modified: 2008-10-30 06:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 06:37:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-30 03:52:59 EDT
Description of problem:
rpm -V fails after upgrade. Missing *.pyc files

Version-Release number of selected component (if applicable):
system-config-samba-1.2.41-3

How reproducible:
Always

Steps to Reproduce:
1. on a 5.2 system install system-config-samba
2. upgrade to 5.3 version of system-config-samba
3.
  
Actual results:
/usr/share/system-config-samba/*.pyc files are removed

Expected results:
Files are not removed

Additional info:

(old) package has:
preuninstall scriptlet (using /bin/sh):
if [ -d /usr/share/system-config-samba ] ; then
  rm -rf /usr/share/system-config-samba/*.pyc
fi


Spec file doesn't seem to conform to: https://fedoraproject.org/wiki/Packaging/Python
Comment 2 Nils Philippsen 2008-10-30 06:37:14 EDT
The error you see is caused by the bad preuninstall script in the old package. If you want rpm to verify correctly, you need to re-install the new fixed package, as is described in the errata documentation.

Note You need to log in before you can comment on or make changes to this bug.