Bug 469162 - Directory /var/lib/iscsi is NOT owned by iscsi-initiator-utils
Directory /var/lib/iscsi is NOT owned by iscsi-initiator-utils
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Christie
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 07:23 EDT by Milos Malik
Modified: 2010-04-21 08:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0103 normal SHIPPED_LIVE iscsi-initiator-utils bug fix update 2009-01-20 11:04:35 EST

  None (edit)
Description Milos Malik 2008-10-30 07:23:48 EDT
Description of problem:
The package owns /var/lock/iscsi but does not own /var/lib/iscsi. Why?

The filesystem on newly installed RHEL-5.3 machine contains /var/lib/iscsi with wrong SELinux label (correct context is recorded in SELinux policy but is not applied in the filesystem until you call restorecon -v /var/lib/iscsi).

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20081029.0
iscsi-initiator-utils-6.2.0.868-0.11.el5

How reproducible:
always

Steps to Reproduce:
* install new RHEL-5.3 machine (via RHTS)
* install iscsi-initiator-utils package
# rpm -qf /var/lock/iscsi
iscsi-initiator-utils-6.2.0.868-0.11.el5
# rpm -qf /var/lib/iscsi
file /var/lib/iscsi is not owned by any package
# matchpathcon -V /var/lock/iscsi
/var/lock/iscsi verified.
# matchpathcon -V /var/lib/iscsi
/var/lib/iscsi has context root:object_r:rpm_var_lib_t:s0, should be system_u:object_r:iscsi_var_lib_t:s0
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike Christie 2008-10-30 17:17:54 EDT
Is this due to a goof up in the spec?

%files

.....
%dir /var/lib/iscsi/nodes
%dir /var/lib/iscsi/send_targets
%dir /var/lib/iscsi/static
%dir /var/lib/iscsi/slp
%dir /var/lib/iscsi/isns
%dir /var/lib/iscsi/ifaces
%dir /var/lock/iscsi

Is there also supposed to be a

%dir /var/lib/iscsi

?
Comment 2 Milos Malik 2008-10-31 04:57:43 EDT
I think that both /var/lock/iscsi and /var/lib/iscsi should be written in %files section.
Comment 3 Mike Christie 2008-10-31 13:24:58 EDT
Adding devel ACK. This seems like it is low risk so I am also setting the 5.3 flag (not sure if I need to set the exception flag too).
Comment 4 Tom Coughlan 2008-10-31 14:09:26 EDT
(In reply to comment #3)
> (not sure if I need to set the exception flag too).

Yes, after beta ships the BZ has to have exception or blocker. Otherwise it gets deflagged. I'll set blocker, since we really should not ship it this way.
Comment 7 Mike Christie 2008-11-05 10:45:21 EST
Checked in iscsi-initiator-utils 6.2.0.868-0.12.el5.
Comment 12 Mike Gahagan 2008-12-14 21:49:42 EST
verified in snapshot 6.

Installed: iscsi-initiator-utils.i386 0:6.2.0.868-0.17.el5
Complete!
[root@localhost ~]# rpm -qf /var/lock/iscsi
iscsi-initiator-utils-6.2.0.868-0.17.el5
[root@localhost ~]# rpm -qf /var/lib/iscsi
iscsi-initiator-utils-6.2.0.868-0.17.el5
Comment 14 errata-xmlrpc 2009-01-20 15:57:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0103.html

Note You need to log in before you can comment on or make changes to this bug.