Bug 469172 - "not one update possibility" error keeps popping up
"not one update possibility" error keeps popping up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 09:33 EDT by Tom "spot" Callaway
Modified: 2008-11-06 05:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 05:46:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible fix (1.25 KB, patch)
2008-10-30 11:33 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Tom "spot" Callaway 2008-10-30 09:33:12 EDT
Description of problem:

PackageKit keeps popping up an error where the "More details" are:

   not one update possibility

Ignoring the grammar issues, and the total lack of useful data in the error message, it's really annoying!

Version-Release number of selected component (if applicable):

PackageKit-0.3.9-2.fc10.x86_64

Analysis:

It was easy to find the error text in the source code and figure out the problem. The code looks like this:

  # is preupgrade installed?
  pkgs = self.yumbase.rpmdb.searchNevra(name='preupgrade')
  if len(pkgs) == 0:
      #install preupgrade
      pkgs = self.yumbase.pkgSack.searchNevra(name='preupgrade')
      if len(pkgs) == 0:
          self.error(ERROR_PACKAGE_NOT_FOUND, "Could not find upgrade preupgrade package in any enabled repos")
      elif len(pkgs) == 1:
          txmbr = self.yumbase.install(po=pkgs[0])
          if txmbr:
              self._runYumTransaction()
      else:
          self.error(ERROR_INTERNAL_ERROR, "not one update possibility")

Now, my system is triggering this error because I have two Rawhide repositories installed, one for i386 and one for x86_64. Thus, when pkgSack.searchNevra(name='preupgrade') runs, len(pkgs) == 2.

Given that preupgrade is always a noarch package, why do we care how many hits we find? The obvious fix (in my mind) seems to be to drop the else: conditional with the self.error.
Comment 1 Richard Hughes 2008-10-30 11:33:45 EDT
Created attachment 321948 [details]
possible fix

What do you think of this?
Comment 2 Tom "spot" Callaway 2008-10-30 11:41:31 EDT
Looks fine to me. :)
Comment 3 Richard Hughes 2008-10-30 12:49:56 EDT
Can you try http://koji.fedoraproject.org/koji/taskinfo?taskID=912590 please.
Comment 4 Bill Nottingham 2008-10-30 14:03:11 EDT
Fixes it for me.
Comment 5 Tom "spot" Callaway 2008-10-30 14:06:38 EDT
Yep, same here. Thanks for the quick turnaround.

Note You need to log in before you can comment on or make changes to this bug.