Bug 469199 - systemtap testsuite regressions
systemtap testsuite regressions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: systemtap (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Smith
BaseOS QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 11:23 EDT by David Smith
Modified: 2009-01-20 16:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:06:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Smith 2008-10-30 11:23:31 EDT
Description of problem:

During rhel5.3 beta testing, regressions were found in testing.  A few regressions aren't actual problems with systemtap, just with the systemtap testsuite.

For instance, the problems outlined by the following systemtap bugs:

- http://sourceware.org/bugzilla/show_bug.cgi?id=6762 (Some syscalls functions just wrappers for other syscalls)

- http://sources.redhat.com/bugzilla/show_bug.cgi?id=6562 ($SYSTEMTAP_DEBUGINFO_PATH does not work)

Version-Release number of selected component (if applicable):

Kernel Version: 2.6.18-118.el5
Related Package Version: systemtap-0.7.2-1.el5

How reproducible:

Every time

Steps to Reproduce:
  
1. Run systemtap-0.6.2-1.el5 testsuite
2. Run systemtap-0.7.2-1.el5 testsuite
3. Compare results

systemtap.base/debugpath.exp (PASS -> FAIL on all arches)
systemtap.syscalls/syscalls.exp will see additional failures on x86_64
Comment 1 Frank Ch. Eigler 2008-10-30 11:28:01 EDT
Setting "Regression" flag, though it's cosmetic.  Patches are ready for
backporting into rhel5.3.
Comment 2 RHEL Product and Program Management 2008-10-30 11:49:29 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 David Smith 2008-11-05 10:40:24 EST
The following patches have been added to the spec file for this issue:

systemtap-0.7.2-syscall-testsuite-fixes.patch
systemtap-0.7.2-debugpath-testsuite-fixes.patch
Comment 10 errata-xmlrpc 2009-01-20 16:06:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0184.html

Note You need to log in before you can comment on or make changes to this bug.