This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469207 - konsole cannot use 6x13 font
konsole cannot use 6x13 font
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 11:56 EDT by Jeff Bastian
Modified: 2009-01-09 12:44 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 12:44:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of Fedora 8 (123.56 KB, image/png)
2008-10-30 11:58 EDT, Jeff Bastian
no flags Details
screenshot of Fedora 10 (258.50 KB, image/png)
2008-10-30 11:59 EDT, Jeff Bastian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 173994 None None None Never

  None (edit)
Description Jeff Bastian 2008-10-30 11:56:29 EDT
Description of problem:
The classic xterm defaults to the 6x13 fixed font which I find is very easy to read.  In Fedora 8, I could get KDE's konsole to use the same font by choosing the MiscFixed family of fonts, Regular style, and entering '10' in the size box.  Note that 10 was in the list of choices for size, but I could still enter it in the box and it would use the 6x13 font.

In Fedora 10 Beta (9.92 Rawhide), I can no longer enter '10' in the size box.  It forces me to choose 8 or 11 from the list, and neither of these work well (8 is too small, 11 is too big).

It could be argued that Fedora 8's konsole was the buggy version since it let me choose a font that wasn't listed, but it gave me the font I wanted! :)


Version-Release number of selected component (if applicable):
kdebase-4.1.2-5.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1. Launch Konsole
2. Go to Settings -> Edit Current Profile -> Appearance -> Edit Font
3. Choose MiscFixed family, try to enter a 10 in the size box
  
Actual results:
It jumps to 11 when you try to enter 10

Expected results:
Somehow allow me to choose the venerable 6x13 fixed font

Additional info:
Comment 1 Jeff Bastian 2008-10-30 11:58:00 EDT
Created attachment 321951 [details]
screenshot of Fedora 8

Here is a screenshot of Konsole and xterm side-by-side in Fedora 8 using the same 6x13 font
Comment 2 Jeff Bastian 2008-10-30 11:59:04 EDT
Created attachment 321952 [details]
screenshot of Fedora 10

Here is a screenshot of Fedora 10 Konsole and xterm side-by-side.  The closest I could get Konsole to the 6x13 font was miscfixed-regular-8pt which is too small.
Comment 3 Rex Dieter 2008-10-30 12:01:21 EDT
MiscFixed lists sizes 4-10,12,13,... and selecting 10 works here. ??
Comment 4 Jeff Bastian 2008-10-30 12:25:07 EDT
In Fedora 8 (kdebase-3.5.10-2.fc8.i386), I am able to enter 10 even though it's not listed.  (As I mentioned in comment #0, maybe this should be the real bug.)  In Fedora 10 (kdebase-4.1.2-5.fc10.i386) I am no longer able to enter 10 and it's still not listed.

In any case, all I would like to do is use the 6x13 font in Konsole.
Comment 5 Jeff Bastian 2008-10-31 15:44:16 EDT
I opened a BZ with kde.org too:
https://bugs.kde.org/show_bug.cgi?id=173994
Comment 6 Bug Zapper 2008-11-25 23:30:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Steven M. Parrish 2009-01-09 12:44:11 EST
Thanks for reporting this upstream.  Will monitor for resolution.

Note You need to log in before you can comment on or make changes to this bug.