Bug 469215 - 'yum update' killed named installation
'yum update' killed named installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
9
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 12:34 EDT by David Woodhouse
Modified: 2014-01-21 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 12:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2008-10-30 12:34:09 EDT
After a 'yum update', my functional nameserver on Fedora 9 was broken.

The CVS-managed contents of /var/named seem to have been turned into a symlink farm, and the config file /etc/sysconfig/named had been modified to enable a non-function chroot-based configuration.

Doing this in a 'stable' update is completely insane.
Comment 1 Adam Tkac 2008-10-30 17:56:31 EDT
Are you sure you don't have bind-chroot package installed?
Comment 2 David Woodhouse 2008-10-31 07:29:45 EDT
I seem to have two copies of it, in fact. Does it get installed by default?

[root@casper ~]# rpm -q bind-chroot
bind-chroot-9.5.0-33.P1.fc9.i386
bind-chroot-9.5.0-35.P2.fc9.i386
Comment 3 Adam Tkac 2008-10-31 09:14:39 EDT
(In reply to comment #2)
> I seem to have two copies of it, in fact. Does it get installed by default?
> 
> [root@casper ~]# rpm -q bind-chroot
> bind-chroot-9.5.0-33.P1.fc9.i386
> bind-chroot-9.5.0-35.P2.fc9.i386

It is installed when you install "DNS Name Server" group
Comment 4 Adam Tkac 2008-10-31 09:15:55 EDT
Ah, assigned to comps by accident. Moving back to bind
Comment 5 David Woodhouse 2008-10-31 10:45:25 EDT
It was the 'bind-chroot-admin --enable' in the %post script which ate my configuration, wasn't it? It looks like that _is_ doing the right thing, and trying to run that only on _install_ and not upgrade.

Was it the fact that I somehow had two copies of the package installed simultaneously that confused it?
Comment 6 Adam Tkac 2008-11-03 02:38:14 EST
(In reply to comment #5)
> It was the 'bind-chroot-admin --enable' in the %post script which ate my
> configuration, wasn't it? It looks like that _is_ doing the right thing, and
> trying to run that only on _install_ and not upgrade.
> 
> Was it the fact that I somehow had two copies of the package installed
> simultaneously that confused it?

I don't think so. In my opinion you had ROOTDIR=/path/to/chroot option in /etc/sysconfig/named set so when you updated bind-chroot then bind-chroot-admin --sync was called and broke your configuration.
Comment 7 David Woodhouse 2008-11-03 03:39:54 EST
I have three such options in /etc/sysconfig/named, but they're all commented out:

#ROOTDIR=/var/named/chroot
#ROOTDIR=/var/named/chroot
#ROOTDIR=/var/named/chroot

They seem to get appended when the bind packages are upgraded.
Comment 8 David Woodhouse 2008-11-03 03:46:52 EST
That is; they get appended _without_ the leading #, and then I comment them out after the update, when I realise the nameserver got hosed again.
Comment 9 Adam Tkac 2008-11-03 06:53:47 EST
(In reply to comment #8)
> That is; they get appended _without_ the leading #, and then I comment them out
> after the update, when I realise the nameserver got hosed again.

Well, I'm not sure what exactly happen but you should not have bind-chroot installed on non-chroot configurations.
Comment 10 David Woodhouse 2008-11-03 07:01:59 EST
Seems like a reasonable assertion. Can we find whatever appends the line reading 'ROOTDIR=/var/named/chroot' to /etc/sysconfig/named, and make it include a comment to that effect too? Something along the lines of:

# WARNING: Do not simply comment out the ROOTDIR= line below if you don't
#          want to run named in chroot mode. Make sure you completely
#          remove the 'bind-chroot' package from the system, or your
#          configuration will be broken each time the packages are
#          updated!
ROOTDIR=/var/named/chroot
Comment 11 Adam Tkac 2008-11-03 07:37:58 EST
(In reply to comment #10)
> Seems like a reasonable assertion. Can we find whatever appends the line
> reading 'ROOTDIR=/var/named/chroot' to /etc/sysconfig/named, and make it
> include a comment to that effect too? Something along the lines of:
> 
> # WARNING: Do not simply comment out the ROOTDIR= line below if you don't
> #          want to run named in chroot mode. Make sure you completely
> #          remove the 'bind-chroot' package from the system, or your
> #          configuration will be broken each time the packages are
> #          updated!
> ROOTDIR=/var/named/chroot

Something like that seems right for me but let me think about that, there are more problems related this issue.
Comment 12 Adam Tkac 2008-11-10 12:03:14 EST
After investigation it seems you hit this scenario:

- you installed bind-chroot
- you disabled chroot configuration (commented out ROOTDIR option in /etc/sysconfig/named) but you left bind-chroot installed
- you updated bind-chroot and it detected that chroot is not enabled so enabled it

Enabling chroot by default when bind-chroot is installed is long-time-ago-behavior. You should remove bind-chroot package if you don't want to use chroot. Using of bind-chroot on non-chroot configurations should be possible on Fedora >= 11.

Closing, if you think this is a bug please reopen

Note You need to log in before you can comment on or make changes to this bug.