Bug 469226 - no user account == no login
no user account == no login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 469359 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 13:44 EDT by Andrew Cagney
Modified: 2008-11-07 15:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 15:11:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2008-10-30 13:44:57 EDT
(Please note that this isn't intended as a root-login-to-gdm dogma bug report)

When re-installing a machine with fedora 10 beta (from a USB key), I planned for what I thought was the reasonable approach of:

- install with no accounts
- login as root
- restore the account information

which meant I indicated 'no' when asked to create an initial user account (perhaps the warning indicated there'd be consequences, I didn't notice).  This in turn meant that once the install had finished, I'd rebooted, I couldn't login.

(After recovering from the panic, and finding a TTY (hey they moved :-), I got to a terminal and finished the process.)

Anyway, if a user refuses to provide an account or network name services, should the machine be left in run-state 3 so that at least a login is possible?
Comment 1 Chris Lumens 2008-10-30 13:52:05 EDT
firstboot let you bypass the user account creation step without having any non-root users on the system?
Comment 2 Andrew Cagney 2008-10-30 14:57:26 EDT
(In reply to comment #1)
> firstboot let you bypass the user account creation step without having any
> non-root users on the system?

Yes; it displayed a message about how this wasn't a good idea; but let me soldier on.
Comment 3 Andrew Cagney 2008-10-30 15:00:52 EDT
If it is relevant; this was using the live CD (copied to a USB).
Comment 4 Chris Lumens 2008-10-31 10:45:22 EDT
*** Bug 469359 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2008-11-03 12:41:32 EST
Hm, did you have any users or anything existing on the system before firstboot was run?  I can't get a default livecd install to give me the option of skipping making a user.  The only time it should ever present that dialog is if there's any user account with UID above 500.  Otherwise, you have to make a new user.
Comment 6 Andrew Cagney 2008-11-03 13:20:55 EST
(In reply to comment #5)
> Hm, did you have any users or anything existing on the system before firstboot
> was run?  I can't get a default livecd install to give me the option of
> skipping making a user.  The only time it should ever present that dialog is if
> there's any user account with UID above 500.  Otherwise, you have to make a new
> user.

I'm pretty any remnants of the old accounts were lost.

See: https://bugzilla.redhat.com/show_bug.cgi?id=468867 for the system lost its existing user accounts.
Comment 7 Chris Lumens 2008-11-07 15:11:04 EST
This is fixed in firstboot-1.100, which is the version right after the beta was released.

Note You need to log in before you can comment on or make changes to this bug.