Bug 469233 - If format fails because of a misconfigured TPS server, it should no longer show the progress bar
If format fails because of a misconfigured TPS server, it should no longer sh...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: esc (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 14:00 EDT by Suzanne Hillman
Modified: 2010-07-02 15:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: esc-1.1.0-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix to this issue. (4.37 KB, patch)
2010-01-27 14:03 EST, Jack Magne
no flags Details | Diff

  None (edit)
Description Suzanne Hillman 2008-10-30 14:00:39 EDT
Description of problem:
If format fails because of a misconfigured TPS server, it should no longer show the progress bar

Version-Release number of selected component (if applicable):
esc-1.0.0-37.el5

How reproducible:
Always

Steps to Reproduce:
1. Misconfigure the TPS server.
2. Try to format a card
  
Actual results:
It will fail, and not change the status back to Unformatted.

Expected results:
It should fail and change the status back to Unformatted.

Additional info:
I have no idea if this is a regression.
Comment 1 Jack Magne 2008-10-30 17:59:18 EDT
This depends upon how the TPS is misconfigured. Formatted means the token has an applet on it. When you tried to reformat it and it failed, it's possible that TPS did nothing to the card. If this is the case, the applet could still be on the card thus still formatted. ESC is just checking to see if we have an applet when it puts up that status.
Comment 2 Suzanne Hillman 2008-11-03 10:42:02 EST
See subject. :) It's still showing as the progress bar, which is wrong.
Comment 3 Jack Magne 2008-11-03 12:54:58 EST
Sorry for the misunderstanding... So how did you misconfigure the TPS and how did it fail? I would have to be able to reasonably reproduce your situation to see if I can get it to happen. Also, would it be possible to hit your server to test this?

BTW, I've never seen the before , but maybe you have come up with a new test case to cause the issue.
Comment 4 Suzanne Hillman 2008-11-03 14:09:30 EST
It was unable to talk to the TPS server when I had inserted an unformatted card and you tell it to enter an address. There is no 'cancel', so I hit ok to make the window go away, then wondered what it would do if I tried to format.
Comment 5 Jack Magne 2008-11-03 16:15:58 EST
Oh, so you had nothing set for the tps url set in your prefs.... It should just try to connect and note a bad url and flag an error. I' will give that a try.
Comment 6 Jack Magne 2008-11-04 14:59:41 EST
Checking this out today.
Comment 7 Jack Magne 2008-11-04 20:25:25 EST
OK, was finally able to reproduce this by messing with my profile. This happens when ESC tells the user that ESC has been misconfigured. I actually got it to happen with the 5.2 version so it is not a regression. The workaround is to remove and reinsert the key or to kill the smart card manager window and bring it back up. This should be an easy fix if we choose to put it in.
Comment 8 Suzanne Hillman 2008-11-05 10:35:03 EST
If not a regression, I suspect it should be proposed for 5.4. Have done.
Comment 10 Chandrasekar Kannan 2009-08-05 15:20:25 EDT
per smart card login team bug council, shifting this bug to rhel 6
Comment 11 Jack Magne 2010-01-25 20:51:18 EST
How to Test:

1. Make sure ESC is not running.

2. Edit the users profile data.

3. Goto ~/.redhat/esc/Profiles/*default/prefs.js

4. Find the cuid number of a formatted or blank token. This token should be listed in the prefs.js file with one entry that look like this:

user_pref("Operation-409xxxxx","http://test.host.com:7888/nk_service");

For the purposes of this test simply set the second string above to "", thus removing the URL of the TPS server. This will cause ESC to detect an error and complain about ESC being misconfigured.

5. Start ESC and insert the token that has the CUID number as the one where we edited the prefs file above. In this case, it's "409xxxxx".

6. Attempt a Format operation on this card. The result should be the same "misconfigured" error string, but this time the temporary progress bar should not be there and the status of the token should be listed instead.

7. Attempt this test but instead make sure that Enroll and PIN Reset work the same way. Make sure that the progress bar is not left behind after the failed attempt at the operation in question.

8. After all tests, either remove the user profile directory completely or go back and restore the URL that was temporarily removed from the entry in the explanation above.
Comment 12 Jack Magne 2010-01-27 14:03:51 EST
Created attachment 387156 [details]
Proposed fix to this issue.
Comment 13 Matthew Harmsen 2010-01-28 13:39:36 EST
attachment (id=387156) +mharmsen
Comment 14 Jack Magne 2010-01-28 14:27:08 EST
/cvs/dirsec/esc/src/app/xul/esc/chrome/content/esc/ESC.js,v  <--  ESC.js
new revision: 1.27; previous revision: 1.26
done
Comment 15 Jack Magne 2010-01-28 16:41:07 EST
Fix in esc-1.1.0-14.el6.
Comment 17 Jack Magne 2010-03-10 20:15:52 EST
OK:

Revised instructions on how to get this test working:

1. Stop ESC.

2. Edit the profile, set the value to something like "dhcp-110.sjc.redhat.com". Basically, just leave "http://" off the string.

3. Insert the token and THEN start ESC.

4. Consult the diagnostics page to make sure the Operation URL is as above.

5. Attempt the Format operation.
Comment 19 Asha Akkiangady 2010-03-16 17:00:19 EDT
Tested on RHEL 6 i386 (build date 11-Mar-2010) with esc-1.1.0-15.el6.x86_64.rpm. Enrollment and Format operation using a formated token with a misconfigured profile throws "The Smart card Manager has been misconfigured" message. The status of the token is listed as formated. Progress bar is not shown.

Format/Enroll/Pin reset operation with misconfigured profile on an enrolled token throws "The Smart card Manager has been misconfigured" message. The status of the token is listed as enrolled.

After the test, removed the user profile directory completely or restored the
URL that was temporarily modified in the profile, able to perform token operations without any problems.

Marking the bug verified.
Comment 21 releng-rhel@redhat.com 2010-07-02 15:04:01 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.